Print Page | Close Window

AB350 Gaming K4 Sound Blaster Cinema 3

Printed From: ASRock.com
Category: Technical Support
Forum Name: AMD Motherboards
Forum Description: Question about ASRock AMD motherboards
URL: https://forum.asrock.com/forum_posts.asp?TID=12244
Printed Date: 20 May 2024 at 11:18am
Software Version: Web Wiz Forums 12.04 - http://www.webwizforums.com


Topic: AB350 Gaming K4 Sound Blaster Cinema 3
Posted By: Aerius
Subject: AB350 Gaming K4 Sound Blaster Cinema 3
Date Posted: 20 Aug 2019 at 2:23pm
Hello, my system is windows 10 RS5 and when i try to open sound blaster cinema 3 get error message: this audio device is disabled, not present, not supported by the application or it has disconnected jack connections. Do you want to select another audio device now?
So now I am not able to use this function at all. Please help me that how can I install it properly on my board, thanks a lot!!



Replies:
Posted By: ASRock_TSD
Date Posted: 20 Aug 2019 at 2:40pm
Dear Aerius,

Greetings, this is ASRock TSD.


Please refer to below link to download Sound Blaster via Microsoft store to check again.
https://www.microsoft.com/en-sg/store/p/sound-blaster-connect/9n66rljrt8z2

If the problem stills the same, please re-install the audio driver on the system.
http://asrock.pc.cdn.bitgravity.com/Drivers/All/Audio/Audio(v8067_FF10).zip

FAQ:
https://www.asrock.com/support/faq.asp?k=sound+blaster    


Thanks!

All the best,
ASRock TSD



Print Page | Close Window

Forum Software by Web Wiz Forums® version 12.04 - http://www.webwizforums.com
Copyright ©2001-2021 Web Wiz Ltd. - https://www.webwiz.net