Print Page | Close Window

Taichi x399 : Dr Debug code 90!

Printed From: ASRock.com
Category: Media&User's Review
Forum Name: AMD Motherboards
Forum Description: ASRock AMD Motherboards
URL: http://forum.asrock.com/forum_posts.asp?TID=12248
Printed Date: 04 Mar 2024 at 9:55am
Software Version: Web Wiz Forums 12.04 - http://www.webwizforums.com


Topic: Taichi x399 : Dr Debug code 90!
Posted By: Headrat
Subject: Taichi x399 : Dr Debug code 90!
Date Posted: 20 Aug 2019 at 7:01pm
Hi,

Mobo = Taichi x399
Memory = 4 x BLE4G4D26AFEA.8FAD (Crucial, on QVL list)
GPU = Vega 64
Cooler = LIQTECH II TR4 240 RGB CPU WATER COOLER - 240MM
Power = EVGA 1600G2

I have a Taichi x399 which now refuses to boot (it was working OK), error code is 90. I've tried removing/adding back memory, CMOS reset, different GFX cards etc but the sucker will not boot, lots of other codes flip by on the LCD but it ends up at 90 and sits there! (I believe 90 is Boot Device Selection (BDS) phase is starts)

I had recently upgraded to the 3.60 BIOS but everything had been running OK, the PC just crashed while unattended last night and now fails to start!

OK I've also just tried to use the "Bios Flashback" to the bridge bios 2.3 and I just get a solid green light which means it didn't work, as per FAQ "If the LED light turns solid green, this means that the BIOS Flashback is not operating properly"

I'm at a bit of a lost what to try next, I know the PSU is also OK as it was running another rig until about 5 days ago!

Thanks



Replies:
Posted By: Xaltar
Date Posted: 20 Aug 2019 at 9:08pm
Disconnect all drives from your system including any flash drives you may have connected and see if that allows you to post. It sounds like something went wrong with your boot selection in the UEFI. If that doesn't get you a POST then try clearing CMOS by disconnecting the system from power then removing the CMOS battery for an hour.

-------------


Posted By: Headrat
Date Posted: 21 Aug 2019 at 1:19am

Hi Xaltar,

OK I've tried disconnecting all drives, no post.

Can you just confirm when clearing the CMOS with the little button on the MOBO, do I do that when the machine:

1. Powered off
2. Powered on

how long should I hold it down for etc?

I pressed the button multiple times but I'm not convinced it's actually clearning anything ;)

Many Thanks for your post.

HEADRAT


Posted By: Xaltar
Date Posted: 21 Aug 2019 at 4:52am
You need to take the button cell battery out of the motherboard, a simple CMOS
clear is often not enough with issues like this. Also, always clear CMOS with the
system powered off and disconnected from power. The odds of damaging something
are not terribly high but better not to risk it.

-------------


Posted By: Headrat
Date Posted: 21 Aug 2019 at 3:04pm

OK took battery out overnight, this morning I pressed CMOS button multiple times with system powered off, no joy still no boot and error code 90

I'm not sure what I can do next


Posted By: Xaltar
Date Posted: 21 Aug 2019 at 3:39pm
What BIOS version did you have on there? Try flashback to the same version. If that fails contact ASRock's Tech Support here:

https://event.asrock.com/tsd.asp

-------------


Posted By: Headrat
Date Posted: 21 Aug 2019 at 4:41pm

Unfortunately I forgot to note what version I was coming from, I've tried a flashback of both the latest 3.60 BIOS and the 2.3 bridge bios and while it starts flashing green in ends up "solid green"


Posted By: Headrat
Date Posted: 21 Aug 2019 at 4:44pm

I've already opened a support case with Asrock.

How do you "edit" post on this forum


Posted By: Xaltar
Date Posted: 21 Aug 2019 at 10:19pm
There is no edit function on the forum, it was removed thanks to spammers abusing it to add links to old posts. It got to the point where I was spending all my time digging for week old posts to delete

Try flashback to the BIOS before the bridge BIOS. The bridge BIOS is not a true update, more of a stepping stone to prep for the new microcode in the later BIOSes and the later BIOS versions may not flash without the bridge BIOS.   

-------------


Posted By: Headrat
Date Posted: 22 Aug 2019 at 3:03am

I've tried multiple different older vesion:

1.8
2.0
2.3

no joy, couple of green flashes then it goes solid green.



Posted By: Xaltar
Date Posted: 22 Aug 2019 at 11:55pm
Damn, is there any chance you forgot to extract the BIOS files from the Zip
files? The contents of the zip file need to be on your flash drive, not the
zipped files themselves.

If that wasn't the issue I am afraid there is nothing more I can suggest. You
will need to wait for ASRock Tech Support to get back to you.

-------------


Posted By: Headrat
Date Posted: 23 Aug 2019 at 11:26pm

I've extracted them and renamed the to Creative.rom as per:

https://www.asrock.com/support/faq.asp?id=447

Thanks



Posted By: Headrat
Date Posted: 23 Aug 2019 at 11:29pm

I presume it's not case sensitive as in the FAQ in one of the pictures it says

Creative.rom (capitalized first letter)

in the wording it says

creative.rom (all lowercase)

or should it be

CREATIVE.ROM (all uppercase)

Hmmmmmmm ;)


Posted By: Headrat
Date Posted: 31 Aug 2019 at 4:16pm

I opened a case with ASROCK on Aug 20, still no reply, anybody know how long it takes them to respond?


Posted By: Headrat
Date Posted: 04 Sep 2019 at 7:07pm

Still no message from ASROCK


Posted By: sharptooth
Date Posted: 15 Dec 2019 at 3:51am
I have been experiencing similar problems today following a failed downgrade from 3.8 to 2.3 (also on the Taichi X399). After the update to 2.3 the system failed to boot, with code '0d'. Nothing I tried worked, so when I resorted to BIOS flashback, I was disappointed to experience the same issue as yourself with "couple of green flashes then it goes solid green".

So I decided to try a different USB flash drive for one final attempt at BIOS flashback and, to my surprise, it worked first time, and I'm now booted back in successfully.

Found your post while looking for potential solutions and thought it might be useful to share this experience; for reference - the USB flash drive that did not work is a SanDisk Cruzer 4GB USB 2.0 ... the one that DOES work is a Transcend JetFlash 16 GB USB 3.0 - both are old drives.


Posted By: asrockmeamadeus
Date Posted: 18 Jan 2020 at 4:07am
New PC here, no OS, entered BIOS, changed boot type to UEFI -> same "code 90" issue (no more access to BIOS).
Tried BIOS update to latest (worked, light turned off after blinking some minutes), cleared CMOS, removed hardware (only CPU, 1 DIMM and GPU left), still "code 90"...


Posted By: asrockmeamadeus
Date Posted: 18 Jan 2020 at 4:18am
forgot to mention, mobo is x570 taichi, debug code seems the same though...



Print Page | Close Window

Forum Software by Web Wiz Forums® version 12.04 - http://www.webwizforums.com
Copyright ©2001-2021 Web Wiz Ltd. - https://www.webwiz.net