Print Page | Close Window

X570 Taichi - Uknown USB Device

Printed From: ASRock.com
Category: Technical Support
Forum Name: AMD Motherboards
Forum Description: Question about ASRock AMD motherboards
URL: https://forum.asrock.com/forum_posts.asp?TID=12541
Printed Date: 21 May 2024 at 6:04am
Software Version: Web Wiz Forums 12.04 - http://www.webwizforums.com


Topic: X570 Taichi - Uknown USB Device
Posted By: AndSol
Subject: X570 Taichi - Uknown USB Device
Date Posted: 29 Sep 2019 at 3:46am
Hi, I am getting a strange error in my Device Manager:

Unknown USB Device (Device Descriptor Request Failed)
(Standard USB Host Controller)
Port_#0003.Hub_#0002

```
Device USB\VID_0000&PID_0002\8&25f65393&0&3 was configured.

Driver Name: usb.inf
Class Guid: {36fc9e60-c465-11cf-8056-444553540000}
Driver Date: 06/21/2006
Driver Version: 10.0.18362.1
Driver Provider: Microsoft
Driver Section: BADDEVICE.Dev.NT
Driver Rank: 0xFF0000
Matching Device Id: USB\DEVICE_DESCRIPTOR_FAILURE
Outranked Drivers: usb.inf:USB\DEVICE_DESCRIPTOR_FAILURE:00FF2000
Device Updated: false
Parent Device: USB\ROOT_HUB30\7&11e6caf8&0&0
```

I have tried disconnecting all USB devices from the machine but the error does not disappear.

Please help.



Replies:
Posted By: thepower99
Date Posted: 26 Nov 2019 at 8:46am
Hi Mate,

Don't know if you ever fixed this, but in case you didn't (and for any others searching) I had the same issue which I have now resolved.

For me the reason was I had the USB header plugged into the AMD supplied cooler (Wraith Prism) as well as the RGB header.

Simply unplugging the USB header fixed the issue for me.

The Taichi manual is quite vague in its instructions for this setup, while it does say only some cables should be plugged in, the picture has all 3 connected (CPU fan connection, USB header connection, RGB header).

I'm not really sure what this USB header is supposed to do, but I have not noticed any difference since unplugging it, besides USB3 now working (which for me it wasn't).

Hope that helps you (or others!)


Posted By: alexwaston
Date Posted: 22 Apr 2020 at 6:24pm
Occurrence of Unknown USB Device (Device Descriptor Request Failed) error is very common. Well, if you are also going through same issue then just relax and calm! You can fix device descriptor request failed error easily. Sometimes, this problem is caused by Power Supply. So, try to remove the power supply to fix this problem. For this follow the below instructions:

1. First, remove the Power Supply plug from PC.
2. Next, re-plug in the Power Supply.
3. Restart your computer and connect the device to the USB port.

For more info: http://www.rescuedigitalmedia.com/fix-unknown-usb-device-device-descriptor-request-failed-on-windows

-------------
alexwaston



Print Page | Close Window

Forum Software by Web Wiz Forums® version 12.04 - http://www.webwizforums.com
Copyright ©2001-2021 Web Wiz Ltd. - https://www.webwiz.net