Print Page | Close Window

X99 Extreme6/ac POST/Boot problem

Printed From: ASRock.com
Category: Technical Support
Forum Name: Intel Motherboards
Forum Description: Question about ASRock Intel Motherboards
URL: http://forum.asrock.com/forum_posts.asp?TID=1257
Printed Date: 25 Feb 2024 at 12:34pm
Software Version: Web Wiz Forums 12.04 - http://www.webwizforums.com


Topic: X99 Extreme6/ac POST/Boot problem
Posted By: mipko
Subject: X99 Extreme6/ac POST/Boot problem
Date Posted: 16 Nov 2015 at 8:14pm
Hello,

I just got system upgrade

1. Asrock Extreme6/ac
2. Intel 5930K
3. 4x4GB Corsair RAM
5. Seasonic 850W platinum
6. Asus Nvidia GTX 780Ti referent model
7. Intel 250GB SSD x 2 - Raid 0

peripherals - USB 2.0:

1. USB Keyboard Steelseries 6GV2
2. Logitech wireless mouse - universal wifi receiver
3. Thrustmaster Warthog Throttle
4. Thrustmasster Warthog Jostick
5. MFG Crosswind rudder pedals

OS : Win 10 Pro 64bit

BIOS: 1.70

The problem:

If Thrustmaster Warhtog Throttle or MFG crosswind are plugged into the USB 3.0 port Motherboard refuses to pass POST stage. It gets stuck after the RAID screen info. Sometimes it passes the POST screen (very very rare). In Case system pases the POST stage it will simply hang in Windows Boot.

When system is is stuck at the POST screen I cen continue POST by simply unplugging the Throttle or Pedalls from the USB 3.0 port. In that case Windows boots normally and everything works OK.

Once system is booted I can connect Throttle or any other USB peripheral to any USB port and system recognizes it and works OK.

Before Extreme6/ac I had Z77 Extreme4 MB with same peripherals and OS and everything worked just fine.

It seems to me that USB 3.0 does not handle legacy USB 2.0 properly at POST/BOOT time. I have tried all possible combinations of USB setting in the BIOS with no luck at all.

Does anyone have any idea if this issue can be addressed with some future BIOS upgrade or I will need to twist with my devices in order to have stable working system?

many thanks,
Mirko



Print Page | Close Window

Forum Software by Web Wiz Forums® version 12.04 - http://www.webwizforums.com
Copyright ©2001-2021 Web Wiz Ltd. - https://www.webwiz.net