Print Page | Close Window

My Z270 Extreme 4 won't boot, lights only flicker.

Printed From: ASRock.com
Category: Technical Support
Forum Name: Intel Motherboards
Forum Description: Question about ASRock Intel Motherboards
URL: http://forum.asrock.com/forum_posts.asp?TID=12607
Printed Date: 03 Mar 2024 at 9:38pm
Software Version: Web Wiz Forums 12.04 - http://www.webwizforums.com


Topic: My Z270 Extreme 4 won't boot, lights only flicker.
Posted By: oKei
Subject: My Z270 Extreme 4 won't boot, lights only flicker.
Date Posted: 07 Oct 2019 at 4:42am
I got my Asrock Z270 extreme 4 because I had 2 other motherboards that were incompatible with my 7700k and I didn't know they had to be until just recently, felt like I could trust asrock as my old motherboard that worked was also made by them.

I got everything plugged in, made sure 100 times that it's all in tight and in correctly, my 8pin power plug is a CPU cord and not a PCIe one, I wanted to test my motherboard turns on with a garbage graphics card (GT 740) before I put a beefy RTX 2070 in since it's a lot easier to remove a 740. I tried putting one stick into the B2 slot like someone else suggested on other posts, and my PSU is brand new (OCZ ZX 850w Gold) so I HIGHLY doubt it's that. Need some advice.



Replies:
Posted By: RLGL
Date Posted: 07 Oct 2019 at 11:44pm
Remove the GPU and try to boot to the on board graphics

-------------
Asrock Z370 Gaming K6,Intel i7 8700K,
Asrock x570 Taichi



Posted By: oKei
Date Posted: 08 Oct 2019 at 2:04am
tried that, still looks like there is no power going into the motherboard


Posted By: ASRock_TSD
Date Posted: 08 Oct 2019 at 9:54am
Dear oKei,

Thank you for choosing ASRock.

Please try to clear CMOS by moving the CMOS jumper and remove the CMOS battery.
User manual page 20:
http://asrock.pc.cdn.bitgravity.com/Manual/Z270%20Extreme4.pdf
Also, please make sure to put back the CMOS jumper before start up the system.

Thank you!
Yours truly,
ASRock TSD


Posted By: oKei
Date Posted: 10 Oct 2019 at 3:43am
Hey, thanks for the reply but still no response from the computer. Lights on the motherboard still flicker but nothing happens when I hit the power button. Are the lights supposed to stay on on the motherboard?


Posted By: RLGL
Date Posted: 11 Oct 2019 at 3:33am
Check the CPU socket for damage, bent pins etc. Try a known good power supply.

-------------
Asrock Z370 Gaming K6,Intel i7 8700K,
Asrock x570 Taichi




Print Page | Close Window

Forum Software by Web Wiz Forums® version 12.04 - http://www.webwizforums.com
Copyright ©2001-2021 Web Wiz Ltd. - https://www.webwiz.net