Print Page | Close Window

New build won't boot

Printed From:
Category: Technical Support
Forum Name: AMD Motherboards
Forum Description: Question about ASRock AMD motherboards
Printed Date: 14 Apr 2024 at 3:02pm
Software Version: Web Wiz Forums 12.04 -

Topic: New build won't boot
Posted By: Jansong1
Subject: New build won't boot
Date Posted: 22 Nov 2019 at 12:42am
Hello everyone,

I am fairly new to pc building and have put together my second pc build but have run into some issues with booting up the system.

When I first put the components together, I flashed the bios to the latest version (3.50) via instant flash using my old ryzen 5 1600 processor from my previous system. I downloaded the bios directly from the asrock website. The bios flash was successful and I then swapped in my new ryzen 5 3600 cpu. I did this without Windows installation.

I was able to successfully install windows 10 using my USB stick onto the m2 ssd. Windows started up and I installed some amd graphics drivers and drivers for my LG monitor during this time. I also connected my old ssd to retrieve some files using the sata connection on my psu. This ssd also had an installation of windows 10 on it (don't know if this had any impact?)

When I restarted my computer, the pc was stuck with the cpu fans running but it did not turn off and the front panel Led was still on. I forcibly turned off the pc via the power button held for 2-3 seconds.

I read on various forums and reddit for solutions and thought I would try to reset the cmos. I have little to no knowledge about this kind of thing but it seemed to have worked when I touched the cmos pins on the motherboard using a metal spoon. I do not have a jumper cap as far as I know it did not come with the mobo. I made sure to unplug everything from the psu and switch the psu off. When I reconnected everything the computer was able to reach the bios screen and eventually windows. I played around in windows for a bit and then tried to restart the pc again to check if the problem was still present.

After restart the computer was not able to boot to Windows and did not show the asrock logo or allow me to enter the UEFI, although it would power on. The fans (both gpu and cpu fans) would run briefly after around 9-10 seconds then stop. Then the fans stop for a few seconds then start up again but no display.

Now when I try to boot up the fans don't even start, the front panel LED comes on but the pc stays idle and no display.

I have noticed there have been many others facing issues with this motherboard and the ryzen 5 3600.

Things I have tried:
- following Tom's hardware forum checklist for 'no post no boot' troubleshooting, although not religiously
- reapplying thermal paste (twice)
- checking standoffs under the mobo - didn't see any issues there
- tried starting pc with only 1 ram installed (do I need to use a specific slot?)
- checked the cpu pins for damage or bends - seemed fine
- checked all connections were in place correctly
- checked front panel connecters and reinserted them - they are in the correct pins

Was I wrong to have flashed the bios to the latest version 3.50? I noticed the box of my mobo said "ryzen 3000 desktop ready" but I didn't notice until after the bios flash.

I am tempted to just send the board back to the manufacturer or seller if they accept returns as all the parts are brand new and appeared to be functional at least for a time.

My parts:
AMD Ryzen 5 3600 3.6 GHz 6-Core Processor
Noctua NH-L12S 55.44 CFM CPU Cooler
ASRock Fatal1ty B450 Gaming-ITX/ac Mini ITX AM4 Motherboard
Corsair Vengeance LPX 16 GB (2 x 8 GB) DDR4-3000 Memory
Samsung 970 Evo 1 TB M.2-2280 NVME Solid State Drive
MSI Radeon RX 5700 8 GB MECH OC Video Card
Silverston?če Sugo SG1??B
Corsair SF 600 W 80+ Platinum Certified Fully Modular SFX Power Supply

Any help or suggestion will be much appreciated as I will probably but a new mobo from a different brand if I cannot sort this tonight. Any suggestions for itx boards that will support ryzen 5 3600 with little to no issues with the bios?

TLDR;issues booting pc or reaching post screen with asrock fatal1ty b450 gaming-itx board. Bios was flashed to v3.50 using Ryzen 5 1600.

Print Page | Close Window

Forum Software by Web Wiz Forums® version 12.04 -
Copyright ©2001-2021 Web Wiz Ltd. -