Print Page | Close Window

Z170 Extreme7+ UEFI Update 2.10 Information

Printed From: ASRock.com
Category: Technical Support
Forum Name: Intel Motherboards
Forum Description: Question about ASRock Intel Motherboards
URL: http://forum.asrock.com/forum_posts.asp?TID=1308
Printed Date: 28 May 2022 at 8:56am
Software Version: Web Wiz Forums 12.04 - http://www.webwizforums.com


Topic: Z170 Extreme7+ UEFI Update 2.10 Information
Posted By: parsec
Subject: Z170 Extreme7+ UEFI Update 2.10 Information
Date Posted: 22 Nov 2015 at 4:44pm
This thread's purpose is simply to provide owners of the ASRock Z170 Extreme7+ board with a friendly "warning" about the new 2.10 UEFI update.

There is nothing to worry about, and there is no problem with the 2.10 update!

I want to make that very clear, this is not a warning about any issues. It is just a warning that the behavior of the 2.10 UEFI update's process is different than what we normally experience.

If you just sit back and allow the 2.10 update to finish on its own, everything will be fine. I just did this myself, and am now using my Z170 Extreme7+ PC to write this forum post, with the 2.10 UEFI installed.

I am ONLY speaking about the Instant Flash UEFI update method in this thread.

Normally when we run the Instant Flash tool from the UEFI, we select the UEFI version we want to update to, from the list displayed, and confirm we want to perform the update. We next see the "Crashless Feature" progress bar moving to 100%, followed by the UEFI update itself and its progress bar. When the Update is complete, we are prompted to press Enter to restart the PC.

The UEFI 2.10 update is different from the normal sequence of events. That is mainly caused by one of the changes in the 2.10 update. From the description for UEFI 2.10:

Update ME and Microcode

ME refers to the Intel Management Engine firmware, that is part of the UEFI file itself. That update is performed in a sub-process of the 2.10 UEFI update.

The 2.10 update using Instant Flash from the Tools screen in the UEFI UI does the following:
  1. After we select the 2.10 UEFI update, we are prompted to confirm we want to perform the update, and press Enter.
  2. The PC immediately shuts off. This is the main surprise of the 2.10 update. DO NOT try to shutoff the power to the PC, or remove the USB flash drive. Just watch your monitor.
  3. The PC will start moments later, and immediately we are back in the Instant Flash program. We can see, "ME Update" and a progress bar. This step normally does not happen.
  4. When the ME update is complete, we are back to the usual sequence of events, with one exception. We see the Crashless Feature running, and then the UEFI update itself.
  5. When the UEFI update is complete, we are not prompted to press Enter. The PC just shuts off by itself.
  6. The PC will start and shutdown once again, without anything displayed on the monitor. Finally the PC starts, performs the POST process, and prompts us to either enter the UEFI to change settings, or boot the PC with the UEFI defaults. This of course means the UEFI update is complete.
The immediate shutdown of the PC after pressing Enter to start the UEFI update shocked me. I imagine others will feel the same way, since there is no warning about this occurring. I decided to leave the PC alone, and see what happens. If you do that too, everything will be fine.

If you try to press Reset or the Power button, or pull the plug from the PSU, I don't know exactly what will happen, but it won't be good. Wink



Replies:
Posted By: STANKYLEG
Date Posted: 23 Nov 2015 at 7:20am
Any change log notes as to what this update does?   I can't seem to find it anywhere.  Also, is there any update of the use of RAID 0 Samsung 950 Pro  with 2.1 update?  I'm afraid I may just return my other 950 Pro.  Either way, what a great board.  AsRock has been wonderful the last 5 generations I have used them


Posted By: parsec
Date Posted: 28 Nov 2015 at 12:06am
I'm not aware of any change-log for ASRock UEFI/BIOS updates. All we know comes from the Description field on the UEFI download page. This is from the 2.10 update:

1.Update ME and Microcode
2.Update RAID ROM and EFI driver

IMO, all of these changes are important, particularly the the last two.

New (Intel) RAID Option ROMs and EFI driver are just what we need for RAID support of PCIe SSDs.

The previous versions (14.5) worked but Intel removed the IRST 14.5 driver from their IRST download page, replaced by 14.6. I was not happy with the way the 14.5 Option ROM worked with RAID 0 arrays, they were easily broken. I had two Samsung AHCI SM951 PCIe SSDs in RAID 0 in my Z170 Extreme7+ board, and I know other users have used 950 Pros in RAID 0.

Hopefully these updates from Intel will improve the RAID 0 functionality and performance of PCIe SSDs. I have not tried that yet.

IF you decide to try a RAID 0 of 950 Pros, I suggest not diving right into using them as your OS drive. Create it as a data drive and see how it performs. Try different stripe sizes, which changed performance significantly.

I guess I'll need another 950 Pro to see how RAID 0 works now. IMO, RAID 0 volumes of PCIe SSDs is not worth it, unless your usage has a benefit from very fast sequential, large file read and write performance.


-------------
http://valid.x86.fr/48rujh" rel="nofollow">


Posted By: wfieger
Date Posted: 30 Nov 2015 at 5:54pm
I updated from USB stick and found the same sudden shutdown there. Only thing is that my board never restarts itself once it shuts down. I had to restart manually and the BIOS update process continued. Only thing is I still have ME version 11.0.0.1168 now.
What is your version?

@ASRock: Is there any advice from your side to handle a not automatically restarting board?




-------------
/cu


Posted By: parsec
Date Posted: 01 Dec 2015 at 11:53pm
Originally posted by wfieger wfieger wrote:

I updated from USB stick and found the same sudden shutdown there. Only thing is that my board never restarts itself once it shuts down. I had to restart manually and the BIOS update process continued. Only thing is I still have ME version 11.0.0.1168 now.
What is your version?

@ASRock: Is there any advice from your side to handle a not automatically restarting board?




The ME firmware update is version 11.0.0.1180.

The first part of the 2.10 update is the ME firmware update, which is shown on the screen. You apparently did not get that part of the update when restarting manually. Was the first part of your update the "Processing Crashless Feature"?

You can try applying the 2.10 update again, but I have no idea why your board did not start automatically. Where did you connect the USB flash drive?


-------------
http://valid.x86.fr/48rujh" rel="nofollow">


Posted By: wfieger
Date Posted: 03 Dec 2015 at 4:30am
Yes, the first part of my update was the "Processing Crashless Feature".
I just tried to update again with a freshly formatted stick and a fresh download of the instant flash update and it was the same as before: Immedeate shutdown after the update is started and no restart. I waited about 10 minutes. Then I decided to power on manually. First thing appeared was the "Processing Crashless Feature", after that the UEFI update started and finished.
After the UEFI update the board shuts down. I have to power on manually again. It runs a few seconds, then shuts down again. Again I need to restart manually - it does not happen automatically.

This not restarting automatically is a thing I noticed from the first boot I did with this M/B. This is my second Extreme 7+ M/B. The first copy did restart on its own. This one never does. I use a different PSU with this one, it's a bequiet ATX 2.4 PSU. The other one ran on a Seasonic ATX 2.31.

And I use a different case - Cooler Master CM500 - just to mention that also. Everything else is the very same components. And a very different behaviour on restarting...


-------------
/cu


Posted By: wfieger
Date Posted: 03 Dec 2015 at 9:20pm
I forgot to mention that I still do not get the ME update. After 3 times updating with v2.10 I'm still on mE 11.0.0.1168.
Any advice from your side how I could get that issue resolved?




-------------
/cu


Posted By: parsec
Date Posted: 10 Jan 2016 at 2:41pm
So SORRY I overlooked this for so long! Embarrassed

So you still have the issue where the 2.10 UEFI update sequence shuts down your PC, but it never starts by itself?

If so, that is what seems to cause the skipping of the ME firmware update. If you don't see a screen with the ME Firmware update title on it, it obviously never happens. Since you see the Crashless feature running, the ME Firmware update is being skipped.

I'm using a SeaSonic PSU in my Z170 Extreme7+ board. Question for you, what is Deep Sleep set to in the UEFI? The default value, or something else?


-------------
http://valid.x86.fr/48rujh" rel="nofollow">


Posted By: milchuck1000
Date Posted: 04 Jan 2017 at 4:09pm
Originally posted by parsec parsec wrote:



If you try to press Reset or the Power button, or pull the plug from the PSU, I don't know exactly what will happen, but it won't be good. Wink

I can tell you what will happen since I did it today.  The update seemed to be taking an exceptionally long time with nothing on the screen so I manually rebooted it.  It ended up bricking my computer. Resetting the CMOS does nothing and the backup bios doesn't seem to work either.  It will run through several POST codes and then stop on 00.  The POST code suggests a CPU problem but I've run this computer with the same CPU for months with no problems.  Wish they had been clearer with the instructions.  


Posted By: Xaltar
Date Posted: 04 Jan 2017 at 4:50pm
Pull power from the wall, clear CMOS, remove the battery and let the system sit for about an hour. Switch to your backup BIOS, replace the battery and power and see if the system comes to life. A bad flash can cause issues with the RTC which can only be corrected by removing the battery. You may additionally want to pull and reseat all the board's power connections while you are at it.

Let us know how it goes. 


-------------


Posted By: Hatrix
Date Posted: 27 Feb 2018 at 10:07pm
" rel="nofollow - Hi. 
Let me try and explain as best as i can. English is not my main language.
My pc setup is:
I5-2500k
ASROCK Z77 Extreme 4
16gb 1600mhz ddr3
GTX970 4GB (Running at 8x instead of 16x due to having the PCIe SSD adapter at 4x, one of the things i didn't know that was going to happen but doesn't make much difference)
SSD M.2  NVMe Samsung 960 EVO 250gb + with PCI express adapter (PCIe 3.0 x4  Host adapter m.2 NGFF PCIe SSD One Stop Serial Technology, can find the link to this adapter but the general site is onestopsystems.com)
PSU Corsair CX600 V2
Plus 3 Sata HDD hard drives 500gb, 1tb and a 2tb.

I been having an issue for a week now and I've been reading asrock forums for some time now about the booting of M.2 SSDs but only now i registered. 
And next ill explain why i replied to this topic and didn't create a new one.

So let me start.
I have updated my ASROCK Z77 Extreme 4 to version 2.90P from the asrock bios page to enable boot with my Samsung 960 and running UEFI GPT Windows10PRO. On Bios everything is on default except the Boot option "Ultra Fast" setting to enable UEFI.


Everything was running perfect for like 1 month.

For the past week i have been having some issues.
It started with the PC won't turn on, had to clear bios and set the Ultra fast setting one again.

Then after maybe 3 days of solving the issue i press the ON button on my case but the screens wont turn on.
I tried using the backup bios with the jumper and the pc didn't even turn on and MB internal red LED number wouldn't even light up.  Was completely dead. After unplugging every cable for a few minutes and after many attempts clearing bios thing it started working.

Then when i was about shutdown the pc 3 nights ago i clicked shutdown process on windows, the monitors turn black(normal) and the pc just wouldnt't shutdown. Like it was waiting the function to click in and shutdown. so i clicked 4 seconds on the case off button.

The next day had to start the process of using jumpers again because PC wouldn't start. but this time and only after a few tries it popped up a message (kind of looked like a BIOS UEFI Update that it was updating some kind of firmware.)

And the Process that parsec explains in 2. 3. 4. 5. and 6. steps happen exactly like that.
Remember i have been running this bios update completely fine for more then a 1 month.

And the computer started normally.

Yesterday i shutdown again for the night and again wont shutdown completely. This time i waited for like 15 min before i pressed 4 second case button. I don't think it's the PSU but i could be wrong.

Today i normal started the pc up and i wanted to get you this out before i kill my pc. i even started to look at new cpu, MB and Ram prices but i am not willing and money stable enough at the moment to buy a new setup. If i get this fixed i won't even touch it for 1 year or 2 more. 

So my questions are, do i try and update bios again because maybe it's damaged or corrupted?
what do you guys think this is all about?


Posted By: chillbro
Date Posted: 27 Aug 2019 at 3:38am



Excellent Blog! I would like to thank for the efforts you have made in writing this post. I am hoping the same best work from you in the future as well.
I wanted to thank you for this websites! Thanks for sharing. Great websites! https://apkfasak.com/ https://apkmoto.com/


Posted By: Geeksquad007
Date Posted: 15 Nov 2019 at 3:29pm

Mostly people face multiple problems in many home appliances and do not get help properly, so we provide the best Customer Service with our best technicians and experts on Geek tech Support.
visit:- https://www.geektech.support/

-------------
linda wilson


Posted By: patriciagomez121
Date Posted: 11 Dec 2019 at 1:57pm
This is really good to see. facebook[URL=http://www.facebook.com]facebook[/URL]


Posted By: patriciagomez121
Date Posted: 11 Dec 2019 at 1:58pm
[URL=http://www.example.com]My Link[/URL]     


Posted By: patriciagomez121
Date Posted: 11 Dec 2019 at 1:59pm
This is really good to see. https://facebook.com
[URL]http://www.example.com[/URL]


Posted By: patriciagomez121
Date Posted: 11 Dec 2019 at 2:02pm
This is really good to see.

-------------
[URL=https://www.facebook.com]My Link[/URL]



Print Page | Close Window

Forum Software by Web Wiz Forums® version 12.04 - http://www.webwizforums.com
Copyright ©2001-2021 Web Wiz Ltd. - https://www.webwiz.net