Print Page | Close Window

AB350M Pro4 NVME drive problem

Printed From: ASRock.com
Category: Technical Support
Forum Name: AMD Motherboards
Forum Description: Question about ASRock AMD motherboards
URL: https://forum.asrock.com/forum_posts.asp?TID=13187
Printed Date: 16 Jun 2024 at 10:37am
Software Version: Web Wiz Forums 12.04 - http://www.webwizforums.com


Topic: AB350M Pro4 NVME drive problem
Posted By: dmn
Subject: AB350M Pro4 NVME drive problem
Date Posted: 17 Dec 2019 at 4:17pm
Hello,

Recently I've purchased m.2 NVME drive for my system(Ryzen 5 1600, AB350M Pro4), and encountered the following problem. With the drive installed my system seemingly hangs after displaying A0 code. If I remove the drive, it boots fine.
I've tried resetting bios, disconnecting my hard drive and trying to boot with just a bootable usb stick. Eventually upgraded my bios to the latest beta version(was originally on 5.80, since I used 200ge for a while). That still didn't sovle my problem.
Naturally I assumed that m.2 drive was faulty, but first decided to check it on my co-worker's board, and it booted without a hitch.
So now I'm assuming the problem is related to my motherboard. But before trying to RMA it, I'd like to exhaust all my options.
Did anyone encounter similar issues? Is there something else I could try? Could it be because of using newer bios versions, not exactky fit for older CPU's?



Replies:
Posted By: Ray62
Date Posted: 17 Dec 2019 at 8:55pm
What NVME drive are you using?
And just to be sure:
M2_1 supports NVME PCIe Gen3 x4
M2_2 supports M.2 SATA3 only



-------------
Asrock Fatal1ty X370 Professional Gaming Offline
Under test:
MSI X570_MEG_ACE | AMD Ryzen 9 3900X | Scythe Mugen5 | 2x16GB F4-3200C14D-32GTZ@3466 | ASUS GeForce GTX 1080 Ti FE


Posted By: dmn
Date Posted: 17 Dec 2019 at 11:05pm
M2_1 is the one I tried to use.
As for the drive itself it's a branded product of our local reseller, which you probably never heard about. Based on Phison PS5013-E13T controller and Toshiba memory. Not an uncommon combo, I suppose.
I do understand that it's not on the list of supported models, but then the list is rather small. So picking many other drives would've been a gamble as well.
Question is whether it's a gamble that didn't pay off, in which case, no promblem, I can still return the drive and try again with a different one.
Or is it some harware/firmware problem on mobo side.
The drive did boot on another mobo and I'm pretty sure it's not on QVL there either.



Print Page | Close Window

Forum Software by Web Wiz Forums® version 12.04 - http://www.webwizforums.com
Copyright ©2001-2021 Web Wiz Ltd. - https://www.webwiz.net