Print Page | Close Window

X570 Taichi RGB Software will not respond still.

Printed From:
Category: Technical Support
Forum Name: AMD Motherboards
Forum Description: Question about ASRock AMD motherboards
Printed Date: 18 Jun 2024 at 5:11pm
Software Version: Web Wiz Forums 12.04 -

Topic: X570 Taichi RGB Software will not respond still.
Posted By: jlpotocki
Subject: X570 Taichi RGB Software will not respond still.
Date Posted: 27 Jan 2020 at 6:46am
Okay I have been have issues with the RGB on my Taichi X570 since day one. I follow the steps on flashing no results. I tried messing with BIOS no results. I uninstalled and reinstalled the RGB Software multiple times once again no results, and I even tried to contact ASRock TS never got a reply.

I can not do the following:
Change colors
select effects
turn off RGB except in the BIOS menu only (turns back on after leaving BIOS.)

It will also not recognize the RGB in the Wraith Prsim Cooler nor the RGB in my RAM modules.

Ryzen 7 3700X
32GB (16X2) OLOy WarHawk Model MD4U163216BEDA
3X 2TB Intel 660p M.2 SSD
MSI Radeon RX5700 Mech OC
Windows 10 Pro Version 1903

I can really use some help with this one. Oh BTW I can not turn off the lights when I shut down as well.

Posted By: Miller2000
Date Posted: 29 Jan 2020 at 10:41pm
I have had a lot issues with that software as well. Emailed asrock according to below and got the answer underneath:

Problem Description
The RGB lighting on the motherboard does not function properly. It initially worked fine but has now started to give issues. The led strip behind the motherboard is flickering.

I connected the AKASA Vegas X7 RGB fans to the RGB1 connection and this is also flickering to white intensly with the same frequency as the motherboard led strip. Many of the modes does not function properly either for the motherboard ledstrip and the Fan RGB.

Polychrome Sync verison 2.0.28 and Firmware V3.4.

I paid a premium price for this motherboard and was expecting much better quality than this... Please help me resolve this or I will go back to the shop and get an ASUS instead...

Answer from Asrock:
For this problem would suggest flash LED FW manually to try, please refer to the following link:

1.Uninstall the ASRock Polychrome 2.0.28 in Control Panel.

2. Download the ASRock Polychrome 2.0.38 by below link and install it.
ASRock Polychrome utility:

3. Type "CMD" in search bar and right click to choose "Run as administrator".

4. Go to Polychrome utility installation folder by typing "cd C:\Program Files (x86)\ASRock Utility\ASRRGBLED\Bin"

5. Flash the RGB chip using the following command "WriteFW.bat"

After step 5, kindly wait about 30 sec and the FW flash will finish.


Posted By: jlpotocki
Date Posted: 29 Jan 2020 at 11:29pm
I am already on version 2.0.38, and I mentioned that I flashed the software in the original post. I did do one thing differently today I updated the BIOS from 1.7 to 2.7 it worked for the LEDs on the board itself In fact the lights will now turn off when I power down however it still will not recognize the RAM's LED nor the LED strips & Fans it just stays in a rainbow pattern. I even put in a graphic card that has ARGB that is compatible with the software, and the software will not recognize it as well. So I fixed 2 issues, and I still got a ways to go.

Posted By: Miller2000
Date Posted: 29 Jan 2020 at 11:34pm
Have you tried any 3rd party applications for the Ram? I tried many different applications. I was also stuck on the rainbow pattern, but it finally released after jumping back and forth between softwares. Beaware though that introducing additional softwares to control the RGB can introduce new problems.


Posted By: jlpotocki
Date Posted: 29 Jan 2020 at 11:41pm
Which 3rd party app(s) did You use?

Posted By: Miller2000
Date Posted: 29 Jan 2020 at 11:43pm
Sorry 3rd party would probably be the wrong word. E.g. MSI's application to control the RTX card also sensed the memory sticks RGB's.

G.skill also has its own software - hence not 3rd party for the sticks itself - and that also detected the memory but worked very bad in combination with Asrocks sw.


Posted By: jlpotocki
Date Posted: 29 Jan 2020 at 11:54pm
I see. Well I may dabble with that, but ASRock really needs to work on these issues regardless I have no issues with Gigabytes nor ASUS RGB software, but they don't make motherboards that I need. I bought this board so I can run all 3 M.2 & 8 SATA ports at the same time plus the BIOS is easier to deal with Memory Overclocking, but their RGB Software is just terrible.   

Posted By: Miller2000
Date Posted: 30 Jan 2020 at 2:44am
I completely agree. And if you search the forum you will see that the problem has existed for at least 2 generations of mother boards, which is completely unacceptable. Pure garbage and totally unnecessary to fail in such a ting on a complex product as a mother board.

On the same topic, there should really be a standard implemented SOON for this RGB nonsense.


Posted By: gizmic
Date Posted: 30 Jan 2020 at 11:46am
i suggest open control panel look at the date of installation and sort it from the day you've install asrock rgb and a couple of other programs that it installs for rgb to work. Then remove all rgb related apps for other pc parts. do a double restart and install asrock only the rgb should flicker during installation if it didnt it could be that it didnt flash.

ive been using asrock rgb from day one and only had problems when i installed gskill that prompt me to reflash and now i'm using it with synapse


Posted By: plastiek
Date Posted: 29 Aug 2020 at 1:34am
I Got my new PC up and running today. I was really looking forward to this taichi motherboard.

ASROCK!, have you ever thought of testing your motherboards BEFORE they leave your factory?

If you did you would have picked up the bios problem where the CPU was running to hot.

You also would have picked up that you RGB program (that ASROCK created) does not work. ON YOUR OWN MOTHERBOARD. Running in administrator mode sometimes opens up and then does not even detect the montherboard own RGB

you also would have picked up that the latest bios upgrade breaks SLI configuration.


look at all the RGB complaints and for how long it has been going on, and still no fix from your side.

If i knew this before buying the motherboard, i would have bought Gigbyte or MSI, at least their own programs work on their motherboards

To anyone looking to buy this taichi board. Know this.
Asrock does not peform QA on their products. I had to upgrade my bios 3 times in one wee, every time the update break something else.

Really disappointment in ASROCK!

Posted By: Miller2000
Date Posted: 29 Aug 2020 at 2:36am
I completely agree with you. My RGB's are turned off due to some flickering that just wont stop. Completely useless.

It is such a hassle going in with the motherboard for a claim, but I am so close to making the shop buying it back.

The RGB i can live without. The other problem I have is that the computer wont boot properly every time I "cold start". It reboots 4 times and then sets all the Bios settings to default and even looses the Time settings. It's crazy.

Last Asrock product I will ever buy. I dont even care if they fix it now. I've had the goddamn thing since December 2019.


Print Page | Close Window

Forum Software by Web Wiz Forums® version 12.04 -
Copyright ©2001-2021 Web Wiz Ltd. -