Print Page | Close Window

deskmini a300 boot problem

Printed From: ASRock.com
Category: Technical Support
Forum Name: HTPC&Gaming Barebone&Others
Forum Description: Question about HTPC&Gaming Barebone&Others
URL: http://forum.asrock.com/forum_posts.asp?TID=13918
Printed Date: 23 Sep 2023 at 10:22pm
Software Version: Web Wiz Forums 12.04 - http://www.webwizforums.com


Topic: deskmini a300 boot problem
Posted By: michischo
Subject: deskmini a300 boot problem
Date Posted: 25 Mar 2020 at 11:09pm
I have just set up my new a300 (outfitted with an athlon 200GE, 8 gb ram, sata-ssd) and installed windows 10 home. the system came up fine (at first) and i started the windows update process to install the latest updates. I had to do several reboots and after one of those, the system did not come back. All that appeared on the screen was a dotted circled, singalling an ongoing process going on, after a while even that disappeard and the screen went black. The system did not shut down, obviously it was hanging at some point before booting into windows.
I can restart and enter the uefi-setup, but i can't find anything useful to change there. I tried to reboot into my windows setup-stick and to reinstall the OS, but it won't boot from the stick as well.
I tried to find a solution in the forum. I found a hint at a possible problem with the used memory slot, so i flipped the ram to the other slot, but that did not change a thing.
Some people have reported problems with the video-configuration, some similar issues seemingly could be addressed by resetting the CMOS, but I am unsure as to what to try next.
current bios is ver. 3.5
thankful for any hint...



Replies:
Posted By: ASRock_TSD
Date Posted: 27 Mar 2020 at 10:22am
Dear Michischo,

Thank you for choosing ASRock.

Regarding your case, we provide some suggestion to try.
1. Clear CMOS to load BIOS default.
2. Update to the latest BIOS.
http://www.asrock.com/nettop/AMD/DeskMini%20A300%20Series/index.asp#BIOS
3. Re-install a clean OS and install the latest driver from ASRock site.

Thank you!
Yours truly,
ASRock TSD


Posted By: michischo
Date Posted: 27 Mar 2020 at 7:38pm
Following a hint from Asrock-Support, I detached the disks and was able to boot to bios (uefi). Turned out that one of the two sata disks i had installed was bad. After tearing that disk out (it was a preused one, installed in sata 2) the system came back.
Nevertheless i updated the Bios, everything continued to work fine.

However, after adding another spare (preused) disk to sata 2, that disk also failed after a short time. Again, the system is fine after removal of that disk. Like the disk before, the drive is no longer accessible on another system.

This makes me wonder whether maybe the A300 killed both disks. Has anybody had similar problems? Right now, i am using just one disk in sata 1.


Posted By: ASRock_TSD
Date Posted: 31 Mar 2020 at 7:44pm
Dear Michischo,

Regarding your case, please help to check if the problem relates to SATA port or SATA cable.
If possible, please change another SSD to try.

Thank you!
Yours truly,
ASRock TSD


Posted By: michischo
Date Posted: 31 Mar 2020 at 8:19pm
The system is running fine with just one ssd being installed on sata 1 port. I have checked that ssd with both sata cables provided and had also hooked it up to the other port; it was functioning fine with either cable and port.
therefore i don't think that the cable is the problem. If the problem does not relate to the hdd-s having been used and worn-out before, it might be that the system is "overwhelmed" when 2 drives are connected. Perhaps the power needs of the additional are too much?


Posted By: nasenag
Date Posted: 02 Jun 2020 at 4:12am
I have been running A300 with AMD 2400G With 3.6 Bios ( this is my sub machine for testing) with Windows 10.
Updated to Windows 10 2004 Update and stop booting

Cleared CMOS - Boot Once and Stop
Everytime I clear CMOS it boots but when I Reboot it stop
Same goes with Ubuntu 20.04 - so I don?t think there is any issue with the OS it self.
I have two SSD and One M.2 NVME

I been reading many forum does this mean the power issue when two SSD is connected ??

Can AsRock confirm that it is power issue for having two SSD ?

( will try out with one SSD later today and post an update )


Posted By: jameswilddev2
Date Posted: 03 Jun 2020 at 10:03pm
I'm seeing the same problems as you with just one NVME - I get one boot per CMOS clear - ASRock did not indicate to me that fixed firmware is on the way. Perhaps if we make enough noise they will fix this bug.


Posted By: Hammerfest
Date Posted: 05 Jun 2020 at 5:08am
sucks that so many of us having issues and fix forthcoming

everyone with the issue should make a support ticket


Posted By: MotorPsico
Date Posted: 17 Jun 2020 at 2:31am
Same problem here.

Have just bought an A300, installed with Athlon 3000G, Noctua cooler, 2x4gb Crucial Sodimm and 2x1tb Crucial P1 NVMe SSD.

Installed Ubuntu 20.04 to an USB, and after rebooting from the install I get a blank screen, no Bios access, no booting.

The only solution was to clear the cmos, then I was able to enter the bios, boot and Ubuntu was working, thought I was some glitch, installed and configured things in Ubuntu, restarted and again, blank screen after rebooting.

Once again I cleared the cmos, and I was able to enter the Bios, the version of the bios was 3.5 so I updated it to 3.6.

I then installed FreeNAS to give it a try, installed and restarted without a problem, I tried couple of times so I thought the problem was solved.

I wasn?t happy with FreeNAS, so I decided to go back to Ubuntu, now I installed Ubuntu but in one of the NVMe disks, installation run without any problem, and at the time of restarting, again blank screen, no bios access no booting, nothing.

I will have to clear the cmos AGAIN in order to be able to do something.

This is really annoying, Asrock should give us a solution really fast.

I have this very clear, this is solved within a week or the case is going back and I will give very bad opinions about A300 setup.

Could it be a UEFI problem? Read about this kind of problems in Ubuntu forums.


Posted By: linuxrocks
Date Posted: 27 Jun 2020 at 12:37am
I too have this problem. After clearing CMOS I get one boot. A reboot will just cause a black screen.


Posted By: 3735943886
Date Posted: 29 Jun 2020 at 12:57pm
The problem is probably d/t virtualization.
I don't know why but when I enable SVM and hyperV, the box won't boot.


Posted By: Hammerfest
Date Posted: 30 Jun 2020 at 9:06am
Regarding virtualization problem: This is a known issue due to the buggy AGESA/Modules in the the last 2 BIOS updates that added ONLY the initial support for Zen+ (3x00G APU's).

So far, support in my tickets have stated that there are no plans to update the AGESA/Modules for this model, despite the fact that they literally have forum's full of people with issues.

That said, create a ticket to suppport, maybe it will get them to at least change the tone to "we will update it to the latest when we have time" (and actually do it) which is even more acceptable then "nope, let it die with its KNOWN bugs"...
BTW, they did release a 3.53 beta which fixed the issues (shocker, updated modules!) only to revert with 3.60... maybe you can get them to link you to it!



It is what it is and I am responsible for 20+ of these in one way or another and ASRock has made my life a living hell...


Posted By: J Z
Date Posted: 23 Jul 2020 at 3:00pm
Hello,

have a new BIOS which solves the problems

https://shop.jzelectronic.de/news.php?sw=AM4&kat=Bios

-------------
Kind Regards,
JZ

https://shop.JZelectronic.de - Der Shop mit ausgesuchter ASRock Profi Hardware

https://www.facebook.com/asrock.de


Posted By: Digitalkaese
Date Posted: 28 Jul 2020 at 3:52pm
Hello J Z,
Have recognised that you have created a new BETA BIOS P3.60L thanks for that.
But I must say that I am not brave enough to flash it, I would prefer official downloads from Asrock. Do not want to brick my A300.
Has anyone else tested it?
Does this support 4700g already?
Thanks


Posted By: J Z
Date Posted: 28 Jul 2020 at 4:59pm
No JZ recommendation for the 3.60L, too many BUGs I noticed.

A new BIOS with AGESA V2 1002 will come.

-------------
Kind Regards,
JZ

https://shop.JZelectronic.de - Der Shop mit ausgesuchter ASRock Profi Hardware

https://www.facebook.com/asrock.de


Posted By: J Z
Date Posted: 29 Jul 2020 at 5:37pm
New BIOS online with me :)

-------------
Kind Regards,
JZ

https://shop.JZelectronic.de - Der Shop mit ausgesuchter ASRock Profi Hardware

https://www.facebook.com/asrock.de


Posted By: djax
Date Posted: 24 Oct 2020 at 7:43am
Hello,

I have the same problem. I have installed the last Ubuntu 20.10, but after the restart, the screen stays black. I clear the CMOS and a normal boot occurs, but the screen stays black again after the reboot.
My config:
MB: AS300W with the 3.6 BIOS
APU: AMD Ryzen 5 3400G
RAM: 2x16 GB Corsair Vengeance
Storage: 1x Crucial P1 (CT1000P1SSD8)

Does a beta version of the BIOS fix the issue?

Best regards,
djax



Posted By: Digitalkaese
Date Posted: 24 Oct 2020 at 1:53pm
After certain Grub updates on Linux Mint 19 I also experienced the black screen you are describing. Rolling back this Grub update fixed the issue but of course this cannot be your solution. Since I have flashed Beta BIOS 3.60K the problem is gone for months, it has never occurred again. Also the Grub Update was possible without any issues.
I recommend to use the latest Asrock Beta BIOS 3.60K as it fixes several issues including yours.
My machine: A300, 2400G, 3.60K, 2*16GB Kingston, 2*NVME Samsung Drives


Posted By: djax
Date Posted: 25 Oct 2020 at 7:41am
Thank you.
I unplugged the cables,
cleared the CMOS,
removed the nvme drive,
put keyboard and power
updated the BIOS to the 3.60K,
unplugged the power,
put back the nvme drive,
plugged back the cables,
start, restart
and it WORKS!!!


Have a nice day


Posted By: Serj47
Date Posted: 26 Oct 2020 at 5:54pm
I have BIOS 3.60K and linux mint installed, and I have never experienced any problems with loading. Which BIOS version does the system fail to boot with?

The only problem that bothers me is errors when loading the kernel, "AMD-Vi: Unable to read / write to IOMMU perf counter"
I enabled iommu = on and amd_iommu = on in the kernel boot parameters, and virtualization in the BIOS, but that didn't help ..
1.Advanced - AMD CBS - nbio common options - nb configuration - IOMMU Enable
2.Advanced - North bridge configuration - SR IOV Enable
3.Advanced - CPU config - SRVmode Enable

cpu = Athlon 200GE


Posted By: djax
Date Posted: 26 Oct 2020 at 9:29pm
Hi Serj47,

I had issues with the BIOS v3.6 that came from the factory.

I upgrade it with the BIOS v3.6K that is in BETA on [URL=https://www.asrock.com/nettop/amd/deskmini%20a300%20series/index.asp#BIOS]Asrock A300 Bios web page[/URL].

I saw that JZ offers newest beta BIOS, but as how he can have/compile newer BIOS than Asrock, I stayed on the safe side.

Best regards,
djax


Posted By: xesy
Date Posted: 27 Oct 2020 at 12:19pm
Originally posted by djax djax wrote:


I saw that JZ offers newest beta BIOS, but as how he can have/compile newer BIOS than Asrock, I stayed on the safe side.



Bios is compiled by Asrock but they can not offer it officialy with renoir support - amd will be angry, so they released it via their eu distributor. That's how business in todays world works, buy more and more new sh*t every year and as manufacturer pay extra duty




Print Page | Close Window

Forum Software by Web Wiz Forums® version 12.04 - http://www.webwizforums.com
Copyright ©2001-2021 Web Wiz Ltd. - https://www.webwiz.net