Print Page | Close Window

(Solved)ASRock X299 Taichi Bluetooth

Printed From: ASRock.com
Category: Technical Support
Forum Name: Intel Motherboards
Forum Description: Question about ASRock Intel Motherboards
URL: https://forum.asrock.com/forum_posts.asp?TID=14007
Printed Date: 16 Jun 2024 at 11:14am
Software Version: Web Wiz Forums 12.04 - http://www.webwizforums.com


Topic: (Solved)ASRock X299 Taichi Bluetooth
Posted By: icd
Subject: (Solved)ASRock X299 Taichi Bluetooth
Date Posted: 06 Apr 2020 at 6:33am
Hi,

Having some trouble with the bluetooth driver. I installed the driver via download page on the asrock website and had no luck turning on bluetooth. Icon doesn't show up in the bottom right corner of the screen and I cant find bluetooth in device manager, even after showing hidden devices. Also downloaded it from asrock app shop after uninstalling original download and no luck.

Any smart people able to give some advice?

specs:
asrock x299 taichi
intel 7820x 8 core
nvidia rtx 2070 super
2 tb platter, 32 gigs of optane memory
250 gb m.2 samsung evo 970

Thanks!



Replies:
Posted By: ASRock_TSD
Date Posted: 07 Apr 2020 at 10:48am
Dear Icd,

Thanks for posting your query.

Regarding your question about Bluetooth, does it WiFi work?
If both WiFi/Bluetooth cannot work, it can be that WiFi module is not detected properly.

Kindly try to remove WiFi bundle with the screws and check is cables and WiFi module is connected properly.

WiFi bundle can be found on page.15 from the link below:
https://download.asrock.com/Manual/X299%20Taichi.pdf

With thanks,
ASRock TSD


Posted By: icd
Date Posted: 08 Apr 2020 at 7:30am
Hi,

WiFi works and the antennas are installed.
Very odd, but I found a very old bluetooth USB adapter that I plugged in and now it works with and without the adapter. Thanks for the response!


Posted By: Renato
Date Posted: 13 Nov 2020 at 6:37pm
After trying everything including contact the useless ASROCK support I uninstalled Intel Wireless in devices manager (Intel dual Band Wireless ac 3168) and its driver. And restarted. Bluetooth is back.



Print Page | Close Window

Forum Software by Web Wiz Forums® version 12.04 - http://www.webwizforums.com
Copyright ©2001-2021 Web Wiz Ltd. - https://www.webwiz.net