Print Page | Close Window

[Help!] Asrock B450m Steel Legend

Printed From: ASRock.com
Category: Technical Support
Forum Name: HTPC&Gaming Barebone&Others
Forum Description: Question about HTPC&Gaming Barebone&Others
URL: https://forum.asrock.com/forum_posts.asp?TID=14102
Printed Date: 19 Apr 2024 at 3:31am
Software Version: Web Wiz Forums 12.04 - http://www.webwizforums.com


Topic: [Help!] Asrock B450m Steel Legend
Posted By: Boygetout
Subject: [Help!] Asrock B450m Steel Legend
Date Posted: 14 Apr 2020 at 1:41pm
Hey, I recently bought a 970 EVO drive for my computer and windows or my bios won't detect it, I've put it in the Ultra M.2 slot and I don't know what to do. Please help.

Specs
Motherboard : B450m Steel Legend
CPU : Ryzen 7 3700x
GPU : RTX 2060
RAM : 2 x 8 2133 (2133) G.Skill Trident Z
Bios Version : 2.90



Replies:
Posted By: Xaltar
Date Posted: 14 Apr 2020 at 3:59pm
Which M.2 slot did you try? You need to use the M2_1 slot for NVME drives.

-------------


Posted By: Boygetout
Date Posted: 14 Apr 2020 at 4:07pm
I used the top M.2 slot, the one that says Ultra M.2


Posted By: Boygetout
Date Posted: 14 Apr 2020 at 4:18pm
I did also try the bottom slot and still no bios recognition.


Posted By: Xaltar
Date Posted: 14 Apr 2020 at 6:21pm
Check this thread:

http://forum.asrock.com/forum_posts.asp?TID=1236&KW=NVME+as+boot&PN=1&title=how-to-install-windows-on-a-pcie-ssd

I am afraid I have not used NVME drives with my systems so can't offer much more
than I already have as advice.

-------------


Posted By: Boygetout
Date Posted: 14 Apr 2020 at 11:51pm
Still no help. Someone please help me, I'm starting to think that the SSD might be broken or my motherboard M.2 slot isn't working.


Posted By: Xaltar
Date Posted: 14 Apr 2020 at 11:59pm
Did you read the thread I linked? It covers your exact problem multiple times.

-------------


Posted By: Boygetout
Date Posted: 15 Apr 2020 at 1:46am
Yes, I read the thread. I'm still saying that I tried the solutions and they never worked.


Posted By: Xaltar
Date Posted: 15 Apr 2020 at 2:45am
You can try cleaning the contacts in the slot with some isopropyl alcohol and a
cotton bud, also clean the contacts on the drive itself. When clean make sure the
M.2 drive is fully inserted into the slot and give it another go. If that still
fails you can try returning the drive. If you have another system to test it in
that would be even better.

-------------


Posted By: Hammerfest
Date Posted: 05 Jun 2020 at 5:32am
I would say either a bad M.2 or bad M.2 slot, sadly, easiest way is to get a cheap-o $30 NVMe and test

I have 2 of these with customers (and the older b350m pro 4 as well) and no issues so far (knock on wood)



Print Page | Close Window

Forum Software by Web Wiz Forums® version 12.04 - http://www.webwizforums.com
Copyright ©2001-2021 Web Wiz Ltd. - https://www.webwiz.net