Print Page | Close Window

x570 Steel Lengend wifi - No Display

Printed From: ASRock.com
Category: Media&User's Review
Forum Name: AMD Motherboards
Forum Description: ASRock AMD Motherboards
URL: https://forum.asrock.com/forum_posts.asp?TID=14144
Printed Date: 25 May 2024 at 7:33pm
Software Version: Web Wiz Forums 12.04 - http://www.webwizforums.com


Topic: x570 Steel Lengend wifi - No Display
Posted By: Tockryde pl
Subject: x570 Steel Lengend wifi - No Display
Date Posted: 19 Apr 2020 at 8:51pm
Hi
I have just a build a PC with
x570 Steel Lengend wifi Motherboard
Ryzen 7 3700x CPU
500GB Sabrent PC1e 4.0 SSD
32GB Ballistic Gaming Memory (DDR4 3600)
NO dedicated GPU

When I turned on the PC the VGA indicator on the motherboard lits red. But after reboot the VGA indicator lits again but then goes off. It then sounds like it boots into BIOS but not display is showing on monitor.

I thought this motherboard comes with an integrated graphics. So I should be able to boot to BIOS and see the display.

Does this motherboard has an integrated GPU if so how do I get to see the display.

Thanks.

PS: I'm waiting for GPU to be delivered but I was hoping to ensure all works as it should.



Replies:
Posted By: Xaltar
Date Posted: 19 Apr 2020 at 10:06pm
You need a dedicated GPU. Only APUs have integrated graphics (2200g/3200g/2400g/ 3400g/Athlon 3000ge/200ge etc).

-------------


Posted By: Tockryde pl
Date Posted: 26 Apr 2020 at 2:47pm
Thanks Xaltar.
I found out the hard way.



Print Page | Close Window

Forum Software by Web Wiz Forums® version 12.04 - http://www.webwizforums.com
Copyright ©2001-2021 Web Wiz Ltd. - https://www.webwiz.net