Print Page | Close Window

ASRock 310 doesn't start

Printed From: ASRock.com
Category: Technical Support
Forum Name: HTPC&Gaming Barebone&Others
Forum Description: Question about HTPC&Gaming Barebone&Others
URL: http://forum.asrock.com/forum_posts.asp?TID=14885
Printed Date: 01 Mar 2024 at 6:54am
Software Version: Web Wiz Forums 12.04 - http://www.webwizforums.com


Topic: ASRock 310 doesn't start
Posted By: kustode79
Subject: ASRock 310 doesn't start
Date Posted: 05 Jul 2020 at 1:35am
Hi .
I bought a new AsRock 310 and I added the following items, carefully following what reported on the official website regarding compatibility, namely:
https://www.asrock.com/nettop/Intel/DeskMini%20310%20Series/#Support

In my case I purchased:
CPU: 1151 Core i7 i7-9700 (R0) Coffee Lake 3.0GHz 12MB 65W

RAM: Crucial 32GB DDR4 2666 CT32G4SFD8266.16FB2 DS 2 2666

Unfortunately the pc doesn't never turn on. The electrical signal is there, the fans are running, but absolutely nothing appears (not even the bios): completely a black screen.
This by testing all three ports (HDMI, Display port, VGA).
If I remove RAM, I can listen two beeps.

I have also tested the functioning of the processor on another pc and it works.
I have tested the Ram on another pc and it works.

Now I have a doubt.
Looking at the compatibility matrix I see that my processor Core i7 i7-9700 is supported but there is an entry here
https://www.asrock.com/nettop/Intel/DeskMini%20310%20Series/#CPU
which says "SINCE BIOS 4.20".
I ask myself: is it possible that the minipc AsRock 310 doesn't start because it has a lower bios? Wouldn't it give any output, not even bios?
If so, a customer like me who buys the minipc and also the CPU (which is supported) how can use the product? Do I need to further patch the bios? In my opinion, the product should be able to work as it is declared to work. Alternatively, I have to pay someone who must have a lower CPU, extend the bios, and then put my CPU.
Can you help me? In case my AsRock 310 has a lower bios, is it correct that I see absolutely nothing?
Thanks



Replies:
Posted By: Ghussey
Date Posted: 29 Aug 2020 at 2:57am
This may help.
https://www.asrock.com/support/index.asp?cat=FindBIOS



Print Page | Close Window

Forum Software by Web Wiz Forums® version 12.04 - http://www.webwizforums.com
Copyright ©2001-2021 Web Wiz Ltd. - https://www.webwiz.net