Print Page | Close Window

Z270M Pro4 M.2 Raid configuration

Printed From: ASRock.com
Category: Technical Support
Forum Name: Intel Motherboards
Forum Description: Question about ASRock Intel Motherboards
URL: https://forum.asrock.com/forum_posts.asp?TID=15698
Printed Date: 30 May 2024 at 5:21am
Software Version: Web Wiz Forums 12.04 - http://www.webwizforums.com


Topic: Z270M Pro4 M.2 Raid configuration
Posted By: AHoffpauir
Subject: Z270M Pro4 M.2 Raid configuration
Date Posted: 30 Aug 2020 at 12:17am
I tried setting up the raid using 2 M.2 NVME drives, I ran through the following steps:


    1.     Press F2 or Del during POST to get into BIOS.
    2.     Press F6 to Advanced mode.
    3.     Select Advanced, Storage Configuration, and set SATA Mode selection from [AHCI] to [Intel RST Premium With Intel Optane System Acceleration (RAID Mode)].
    4.     Set Launch Storage OpROM Policy from [Legacy only] to [UEFI only].
    5.     Set M2_1 ??RST Pcie Storage Remapping from [Disabled] to [Enabled].
    6.     Set M2_2 ??RST Pcie Storage Remapping from [Disabled] to [Enabled].
    7.     Press F10 to save configuration change and get into BIOS again.
    8.     Select Advanced, Intel(R) Rapid Storage Technology, Create RAID Volume.
    9.     Key-in a volume name and press <Enter>, or simply press <Enter> to accept the default name
    10.     Select your desired RAID Level and press <Enter>
    11.     Select the hard drives to be included in the RAID array and press <Enter>
    12.     Select a stripe size for the RAID array and press <Enter>
    13.     Select Create Volume and press <Enter> to start creating the RAID array


Everything looks great until I get to windows 10 install which shows the error "Windows can't be installed on this drive" see attached image.



Replies:
Posted By: AHoffpauir
Date Posted: 30 Aug 2020 at 12:25am


Posted By: ASRock_TSD
Date Posted: 31 Aug 2020 at 11:55am
Dear AHoffpauir,

Thank you for posting your query to the ASRock forum.

We have checked, using M.2 x2 building RAID1/0 the Win10 can be installed properly.

Please make sure that you have the BIOS 2.50 updated.
If possible, please try with a different Win10 installation method and try to re-build the RAID to see if it will work.

With thanks,
ASRock TSD


Posted By: AHoffpauir
Date Posted: 31 Aug 2020 at 11:59am
As I noted, the bios is updated, I have tried rebuilding the RAID several times using different settings to no avail. Please post the exact steps to building a M.2 raid for use with Widows 10.


Posted By: ASRock_TSD
Date Posted: 31 Aug 2020 at 1:44pm
Dear Ahoffpauir,

Thanks for the reply.

Please fill out the form from the link below to get further assistance from the technical support.
https://event.asrock.com/tsd.asp

With thanks,
ASRock TSD



Print Page | Close Window

Forum Software by Web Wiz Forums® version 12.04 - http://www.webwizforums.com
Copyright ©2001-2021 Web Wiz Ltd. - https://www.webwiz.net