Print Page | Close Window

Fatal1ty Z77 Pro,Etron USB 3.0 and Win10

Printed From: ASRock.com
Category: Technical Support
Forum Name: Intel Motherboards
Forum Description: Question about ASRock Intel Motherboards
URL: https://forum.asrock.com/forum_posts.asp?TID=1668
Printed Date: 29 May 2024 at 7:50pm
Software Version: Web Wiz Forums 12.04 - http://www.webwizforums.com


Topic: Fatal1ty Z77 Pro,Etron USB 3.0 and Win10
Posted By: OceanBlue72
Subject: Fatal1ty Z77 Pro,Etron USB 3.0 and Win10
Date Posted: 06 Jan 2016 at 7:14am
Hello,

i have an ASRock Fatal1ty Z77 Professional and wanted to upgrade from Win 7 Ultimate 64bit to Win 10 Pro.
Before that i've tested this in a VM to check if all of my devices, like Logitech G940, Spacemouse Pro, headtracker with PS3 Cam and opentrack, software like simffb, throttlelights and sx2vjoy are fully working (i need this for CAD, Elite Dangerous and SC). Everything was fine.

So upgrading to Win 10 and there seems to be a massive problem with the Etron J188 USB 3.0 Controller. The Etron working fine under Win 7 with the whql driver 119, but under Win 10 i've got bluescreens and not working devices like my spacemouse pro. I think that was the reason, why i don't have this problem in the VM under Win7. It was the same with the Windows driver for the Etron Controller.

So for the moment i'm back to Win 7.

Has anyone experiences with this board and its Etron Controller under Win 10 and can give me some hints?

Thanks
Marcus



Replies:
Posted By: wardog
Date Posted: 06 Jan 2016 at 3:42pm
First off Etron pulled 119 from availability. I too had problems when they initially release it publicly. 119 is buggy as hell.

I have the EJ168 on my Z77 Extreme6.

Go https://www.dropbox.com/s/yiqmhis8hgoo1r0/SETUP_0.118.zip" rel="nofollow - HERE to d/l 118. It is stable on Win10x64 here. As was the in-the-box driver Microsoft provided inside my Win10 installation media.

Still, d/l and install 118. That should take care of those issues there for you.

IMPORTANT: Uninstall the old Etron driver FIRST! I can not stress that enough. Uninstall, reboot, then install 118. DO NOT perform an over the top driver install here.


Posted By: OceanBlue72
Date Posted: 06 Jan 2016 at 9:26pm
Thanks for your answer! I will try this on my next attempt to setup Win10.
I've thought that 119 was ok, because this works fine under Win 7, 118 too.





Posted By: OceanBlue72
Date Posted: 12 Jan 2016 at 5:29am
@wardog:
Thanks a lot! Now at my second attempt it works!

Marcus


Posted By: wardog
Date Posted: 12 Jan 2016 at 5:43am
Originally posted by OceanBlue72 OceanBlue72 wrote:

@wardog:
Thanks a lot! Now at my second attempt it works!

Marcus


Handshake



Print Page | Close Window

Forum Software by Web Wiz Forums® version 12.04 - http://www.webwizforums.com
Copyright ©2001-2021 Web Wiz Ltd. - https://www.webwiz.net