Print Page | Close Window

B550 Taichi USB Driver

Printed From: ASRock.com
Category: Media&User's Review
Forum Name: AMD Motherboards
Forum Description: ASRock AMD Motherboards
URL: http://forum.asrock.com/forum_posts.asp?TID=17571
Printed Date: 24 Sep 2021 at 4:53am
Software Version: Web Wiz Forums 12.04 - http://www.webwizforums.com


Topic: B550 Taichi USB Driver
Posted By: gothamcity6
Subject: B550 Taichi USB Driver
Date Posted: 23 Dec 2020 at 5:04am
Hello,

I built a new PC recently with a B550 Taichi MB, and I am having issues with the USB ports. I am running Windows 10.

The main problem is with the onboard USB headers. I have tried connecting the USB connectors on my computer case, as well as a separate USB port plate that I have, to the onboard USB 2.0 headers. Whichever port or header I use, I can connect devices and they show up in windows as usual, but every 20-40 seconds, it appears like the USB port disconnects for a second and reconnects. For example, when I connect a keyboard, every other sentence the board will stop input or will freeze on a key input and repeat it until the port has reset. I haven't tried file transfer, but I believe it would never really work because it would get interrupted.
This issue effectively makes the USB headers useless, and makes it impossible for me to have functioning USB ports on my computer case.

The other hint I have that there is an issue is my USB mouse (Logitech M510) appears to be moving in a grid pattern, jumping between grid points that are spaced every 6 pixels or so. I have the appropriate utility software (SetPoint) from Logitech. Some blogs I have seen suggest that one reason this may be happening is an out of date MB USB driver.

There is no mention of the USB driver on the AsRock support page for the Taichi B550. I don't know if it is just not required, or if it is included in one of the other drivers, or if it is just missing.

I have tried
> Disabling the ability for windows to turn off USB devices
> Scanning for updates for windows drivers

I haven't tried deleting drivers and restarting, but can if anyone thinks that will help

Thanks!



Replies:
Posted By: StefaanC
Date Posted: 22 Feb 2021 at 4:32am
Windows 10 by default uses power saving for usb ports.
    Open Control Panel.
    Click on Hardware and Sound.
    Click on Power Options.
    Under "Preferred plan," click the Change plan settings link for the    plan you're currently using. ...
    Click the Change advanced power settings link.
    Expand USB settings.
    Expand USB selective suspend setting and turn this off.


Posted By: StefaanC
Date Posted: 22 Feb 2021 at 4:39am
ah ok , or in the control panel system, hardware the usb section choose look for updates or download the latest driver from AMD B550 drivers.
It's a package for all main board drivers.


Posted By: gothamcity6
Date Posted: 03 Mar 2021 at 2:40am
I think updating the chipset drivers from AMD worked, Thanks!

What I did:
1) Manually download and install AMD B550 chipset drivers
2) Reconnect my additional USB ports to the motherboard (via onboard USB headers)

There have been some windows updates since I last tried to fix this, so maybe they had something to do with it too, but I don't know. I had installed the chipset drivers right after building, but I guess they needed to be updated?

Thanks again!


Posted By: StefaanC
Date Posted: 03 Mar 2021 at 4:58pm
Windows10 has an application that tries to trick drivers in fault , if that succeeds then the driver is removed. windows update can force a drivers from the Microsoft store despite the more recent driver is installed usual for network drivers and audio drivers but also my usb eprom programmer i need to re-install every time after a windows severe update.

if windows has a problem, re-install the AMD chipset drivers and the system runs fine again.



Print Page | Close Window

Forum Software by Web Wiz Forums® version 12.04 - http://www.webwizforums.com
Copyright ©2001-2021 Web Wiz Ltd. - https://www.webwiz.net