Print Page | Close Window

PCI passthough on ASRock Z490M-ITX/ac

Printed From: ASRock.com
Category: Technical Support
Forum Name: Intel Motherboards
Forum Description: Question about ASRock Intel Motherboards
URL: https://forum.asrock.com/forum_posts.asp?TID=18175
Printed Date: 20 May 2024 at 5:04am
Software Version: Web Wiz Forums 12.04 - http://www.webwizforums.com


Topic: PCI passthough on ASRock Z490M-ITX/ac
Posted By: TC_
Subject: PCI passthough on ASRock Z490M-ITX/ac
Date Posted: 20 Feb 2021 at 4:59am
Hi, i am trying to get PCI passthough working on my ASRock Z490M-ITXAC on Ubuntu 21.04.
I have a GPU that i want to pass though to a windows VM, but i belive that the GPU is getting grabbed by the system.
I am quite sure that I have done all I need to in Ubuntu to not let the ubuntu driver grab the card, and i am looking into EFI settings.

I have spesified in:
Advanced > Chipset Configuration > Primary Graphics Adapter
that i want to use the onboard graphics (IGPU i assume), but the display never wakes if i have it connected to the HDMI on the motherboard.
But i can access the EFI setting when using the GPU.
This leads me to belive that the Motherboard is not using the IGPU as primary.

Any Idea what i am doing wrong?


HW list:
ASRock Z490M-ITX/ac
Intel Core i3-10100
Radeon RX 580
Corsair VENGEANCE® LPX 32GB, 2 x 16GB



Replies:
Posted By: TC_
Date Posted: 21 Feb 2021 at 9:34pm
I found the issue.

Enable kernel setting is grub:

"video=efifb:off pci=realloc"

in addition to the setting i already had:

"intel_iommu=on iommu=pt kvm.ignore_msrs=1 vfio-pci.ids=1002:67df,1002:aaf0"

for completeness, here is the entire line from /etc/default/grub

GRUB_CMDLINE_LINUX_DEFAULT="intel_iommu=on iommu=pt video=efifb:off pci=realloc kvm.ignore_msrs=1 vfio-pci.ids=1002:67df,1002:aaf0"



Print Page | Close Window

Forum Software by Web Wiz Forums® version 12.04 - http://www.webwizforums.com
Copyright ©2001-2021 Web Wiz Ltd. - https://www.webwiz.net