Print Page | Close Window

Intermittent crashes in Windows

Printed From:
Category: Technical Support
Forum Name: AMD Motherboards
Forum Description: Question about ASRock AMD motherboards
Printed Date: 13 Jul 2024 at 5:17pm
Software Version: Web Wiz Forums 12.04 -

Topic: Intermittent crashes in Windows
Posted By: jakesterpdx
Subject: Intermittent crashes in Windows
Date Posted: 27 Feb 2021 at 6:25am

ASRock B550M/ac, BIOS v1.60.
AMD Ryzen 7 3700X
16GB DDR4 3000 Micron 16-18-18
WD Blue SN550 NVMe 1TB
600W Gold PSU
ThermalTake H200 TG RGB
PNY GeForce RTX 3060 Ti 8GB XLR8 Gaming REVEL EPIC-X RGB Dual Fan Edition

When I first set everything up, I had lots of issues. I replaced the NVMe, and then everything worked perfectly for over 2 weeks. Then, without changing anything at all (neither software nor hardware) I started to get some crashes in Asgard?s Wrath a few days ago. A few days after that, things got much worse: Chrome would crash upon startup, for example. I ran sfc /scannow and it found errors that it could not repair.

I am very comfortable working on computers, so I decided to simply reinstall Windows from scratch (including deleting the existing partitions on the hard drive). I have been trying to install Windows and my apps unsuccessfully ever since then. It?s frustrating, because the problems I?m seeing are all over the map: usually I can make it all the way through installing Windows (using a USB drive, deleting the partitions every time) without any issues. However, I immediately start running into issues after that.

For example, I?ve started to notice that most times, if I run sfc /scannow before doing anything else, it already finds issues, but not always. Other times, it will BSOD while applying Windows Updates. Sometimes, I can make it through updates, but installing drivers will cause a BSOD. If all of that works, installing the Oculus app will fail. One time, even this succeeded, but installing Asgard?s Wrath, an 80gb game, failed repeatedly. When checking Event Viewer, I?ve seen errors in over a dozen .sys files including ntfs.sys. I?ve also tried using the Windows Reset app to download the image over the internet, in case there was an issue with the USB drive and/or the USB port or driver. I ran into the same issues that I?ve described above. I?ve also tried using the BIOS format command on the NVMe and I have reset the BIOS settings (using F9) ??after resetting, the only things I change are the RAM to use the XMP 2.0 profile and disabling the CSM compatibility mode.

This is so bizarre, because like I mentioned above, everything was working perfectly. I was really convinced that it had been a bad hard drive, but now I feel like it could be almost anything! It seems to me that the problem must be somewhere in the hardware, but whether it?s the motherboard, power supply, or even another component, I cannot say. I don?t suspect the CPU, RAM, or GPU because they pass rigorous testing (MemTest, Furmark, Prime95, etc). It feels to me like an issue along the path between the NVMe, which is I suspect the motherboard or PSU, but I'm just not sure.

Any ideas?

Posted By: StefaanC
Date Posted: 04 Mar 2021 at 12:50am
the hard drive is a m2 ssd and do know that manufacturers are allowed to sell ssd's with bad sectors in so if you got corrupt sectors then sfc /scannow can mark these bad sectors but start a dos prompt with admin rights to do scannow and be noted, repeat this process at least 3 times.
without admin rights sfc can read but not correct bad sectors;

Posted By: jakesterpdx
Date Posted: 09 Mar 2021 at 3:52am
When I originally suspected the hard drive, it was because the BSOD£s often referred to ntfs.sys and because the most consistent issue was installing an 80gb game, which I (wrongly) assumed pointed to the hard drive being the problem. It turns out to be a stick of RAM. Whatever is wrong with that stick of RAM is very, very subtle, as I further discuss below.

During the last week, I re-doubled my troubleshooting efforts £I even bought another B550 motherboard from Best Buy (I returned this today after it was clear the motherboard was not the culprit). I discovered I had a number of behaviors that I had led me astray during the process:
-I ran many, many RAM tests including Windows Memory Diagnostic and MemTest86 on a USB stick, and none of these has never found an issue with the RAM, which made me think the RAM was fine. I£ve run these tests with just the one bad stick, and it still reports that the RAM is fine. I can£t explain this.
-On a fresh install of Windows, sfc /scannow would report corrupted files £it turns out this is a known issue when a system has an nVidia graphics card:" rel="nofollow -
-When attempting to install the Oculus app on a fresh install, Windows Defender was blocking it. I can£t find any documentation about this issue, but I£m certain the Oculus install is valid (I re-downloaded it multiple times directly from, and disabling Defender let the install sail right through. It£s possible that running Defender updates would also add Oculus to a whitelist. Whatever the case, these install failures led me down many rabbit holes before I realized that I simply needed to disable Defender before installing Oculus
-I have only found one thing that reliably causes the computer to crash with the bad RAM stick installed: installing the game Asgard£s Wrath, which is 80gb in size (thank goodness for my gigabit internet). It turns out that, after a few times of downloading this, Oculus will block my IP address, so in order to continue testing I had to run a VPN. This took a while to figure out, too, and also sent me down rabbit holes.

So, after figuring out all of these problems, I can now reliably produce either a crash (when only the bad stick is installed) or a successful run by doing the following:
1. Reset motherboard to defaults except enabling XMP profile on RAM and disabling CBS
2. Fresh install of Windows (deleting all partitions)
3. Disable Windows Defender
4. Install latest amd_chipset_software_2.13.27.501
5. Install and run VPN
6. Install Oculus
7. Install Asgard£s Wrath
a. With bad RAM, while it sometimes crashes before this, if it hasn£t crashed yet, it will always fail here
b. With good RAM, everything works including the install

Posted By: StefaanC
Date Posted: 09 Mar 2021 at 3:02pm
do mind that sfc /scannow must be started with admin rights, otherwise scannow will just scan but not fix problems. i would not install oculus at a fresch boot. in my case, x399 taichi:
installed windows 10, reboot
installed mainboard chipset drivers and reboot
installed realtek HD audio drivers and reboot
installed graphic drivers in my case Radeon FX580 and reboot.

Once the system crashed could start but video driver damaged and that was due to bad SSD cell scannow did fix that and re-installed the driver.

if damaged cells are in the documents folder then no problem but then there will be one app that can not be started again and scannow can fix the cell as bad but not fix the problem except deleting the file.

And do note , SSD Manufacturers are allowed to sell SSD's with errors in the design as long the number of bad cells is within a certain threshold list where SSD's are bad or good for selling.

also quick formatting does not find damaged cells, good old slow format did check harddisk for errors during formatting and hence it was so slow.

Print Page | Close Window

Forum Software by Web Wiz Forums® version 12.04 -
Copyright ©2001-2021 Web Wiz Ltd. -