Print Page | Close Window

Polychrome not detecting 5700 XT GPU

Printed From: ASRock.com
Category: Technical Support
Forum Name: AMD and Intel Graphics Card
Forum Description: Question about ASRock AMD and Intel graphics card
URL: http://forum.asrock.com/forum_posts.asp?TID=18416
Printed Date: 29 Jan 2023 at 12:35am
Software Version: Web Wiz Forums 12.04 - http://www.webwizforums.com


Topic: Polychrome not detecting 5700 XT GPU
Posted By: apc01352
Subject: Polychrome not detecting 5700 XT GPU
Date Posted: 19 Mar 2021 at 11:36pm
I have a phantom gaming d 5700xt. a few weeks ago polychrome decided that it no longer wanted to recognize the gpu, so i cannot change the rgb color. The rgb is currently stuck on green, which i believe is the beginning of the stock rainbow waive, but its not moving.

I have done 2 fresh installs of windows, and updated polychrome to the most recent beta on the asrock support page for my motherboard (b550 pg velocita) since it is more recent than the copy on the support page for the gpu. GPU page has 1.0.13. Motherboard page has 2.0.94. I have updated to the most recent bios for the motherboard (1.90), and the issue started around the time i made that update



Replies:
Posted By: ASRock_TSD
Date Posted: 22 Mar 2021 at 5:05pm
Dear Apc01352,

Thank you for posting your query to the ASRock forum.

Regarding your question, kindly refer to the following:
1. Boot up the system and install the graphics card driver.
2. Download the following tool and unzip it.
    https://download.asrock.com/TSD/Desktop/RGBFW/GPU/RX5700XT_PGD.zip" rel="nofollow - https://download.asrock.com/TSD/Desktop/RGBFW/GPU/RX5700XT_PGD.zip
3. Run command prompt as Administrator.
4. Go to the directory of where the tool is located.
   e.g. Type cd (Directory of the RX5700XT_PGD file)
5. Run the update tool by typing "Update_RX5700_PG.cmd"
6. The update process may take a while.
7. When the message "Update Pass" shows up, it means that the graphics card firmware has been flashed successfully.
8. Please turn on the RGB software and check if the RGB can be controlled properly.
    https://download.asrock.com/Utility/RGB/PolychromeRGB%28v2.0.94%29.zip" rel="nofollow - https://download.asrock.com/Utility/RGB/PolychromeRGB(v2.0.94).zip

With thanks,
ASRock TSD


Posted By: apc01352
Date Posted: 22 Mar 2021 at 8:11pm
Originally posted by ASRock_TSD ASRock_TSD wrote:

Dear Apc01352,

Thank you for posting your query to the ASRock forum.

Regarding your question, kindly refer to the following:
1. Boot up the system and install the graphics card driver.
2. Download the following tool and unzip it.
    https://download.asrock.com/TSD/Desktop/RGBFW/GPU/RX5700XT_PGD.zip" rel="nofollow - https://download.asrock.com/TSD/Desktop/RGBFW/GPU/RX5700XT_PGD.zip
3. Run command prompt as Administrator.
4. Run the update tool by typing "Update_RX5700_PG.cmd"
5. The update process may take a while.
6. When the message "Update Pass" shows up, it means that the graphics card firmware has been flashed successfully.
7. Please turn on the RGB software and check if the RGB can be controlled properly.
    https://download.asrock.com/Utility/RGB/PolychromeRGB%28v2.0.94%29.zip" rel="nofollow - https://download.asrock.com/Utility/RGB/PolychromeRGB(v2.0.94).zip

With thanks,
ASRock TSD


This worked, Thank you! Just a quick note, you have to open the file location in CMD before typing in the prompt to update


Posted By: ASRock_TSD
Date Posted: 23 Mar 2021 at 1:54pm
Dear Apc01352,

Thanks for letting us know.

We will add that step to our previous post.

Thanks so much.

With thanks,
ASRock TSD


Posted By: Blitzeno
Date Posted: 09 Jun 2021 at 11:28am
Same thing happens to my rx 5500 xt PG and I cant find any fix :(


Posted By: Blitzeno
Date Posted: 09 Jun 2021 at 11:30am
Same thing happens to my rx 5500 xt PG, I launch polychrome and it always gets stuck in green and I cant find any fix, can anything be done for my situation?


Posted By: JuliaLucy
Date Posted: 09 Jun 2021 at 7:09pm
Originally posted by Blitzeno Blitzeno wrote:

Same thing happens to my rx 5500 xt PG, I launch polychrome and it always gets stuck in green and I cant find any fix, can anything be done for my situation?


What worked out for my 5600 XT was deleting all the software related to RGB devices.
(Razer software, Ballistix MOD, turns out Samsung Magician software can also be an issue if you have that installed)
I then followed the same steps that are listed above, same driver eventho its not for my card, but it worked.


Posted By: leandro79rj
Date Posted: 26 Jun 2021 at 4:49am
It worked for me. I'm happy.
Mine is RX5500XT.
But mine kept updating all the time I needed to use CTRL + C To exit after I completed 100%
I'm using polychrome version V.2.0.96 (Fimware) v.3.4


Thank you!!!

-------------
LMM


Posted By: SaadHamdi
Date Posted: 27 Aug 2021 at 4:35pm
Hey I have the same problem and tried this fix but it says every time I do this fix it gives me this message with a big (Update Fail).
=================================================================
              ASRock ISP Tool v1.0.10.2 Built: 20210310
        (C)2019 ASRock Incorporation. All Rights Reserved
=================================================================
WARNING! PLEASE DON'T STOP THIS PROGRAM DURING FIRMWARE UPDATING.

[ Configuration ]
Program Interface ...... ADL_I2C_OEM
Adapter ................ AMD Radeon RX 5700 XT

[ Chip - Current]
FW Version ............. 0x00000000
FW Release ............. 0x00000000
FW Feature ............. 0x00000000
HW Version ............. 0x00000000
Device ID .............. 0x00000000
Flash Mode ............. Unknown (0x00)
Config0 : Config1 ...... 0x0019FDB4 : 0x0019FD37

Jump to LDROM                     [ Fail ]
Process Time                      [ 0.019 seconds ]
*************************
       Update Fail
*************************
Any help could be appreciated.


Posted By: ASRock_TSD
Date Posted: 30 Aug 2021 at 1:45pm
Dear SaadHamdi,

Thanks for posting.

Please provide the full model name of the graphics card.

With thanks,
ASRock TSD


Posted By: SaadHamdi
Date Posted: 30 Aug 2021 at 4:07pm
Model name is rx 5700 xt phantom gaming D 8G oc


Posted By: SaadHamdi
Date Posted: 31 Aug 2021 at 4:24pm
Model name is asrock rx 5700 xt phantom gaming D 8GB oc


Posted By: ASRock_TSD
Date Posted: 01 Sep 2021 at 9:43am
Dear SaadHamdi,

Thanks for the reply.

For your case, advanced support is required. Kindly fill out the form from the link below and ASRock will arrange an expert to assist you with this.
https://event.asrock.com/tsd.asp?ln=en" rel="nofollow - https://event.asrock.com/tsd.asp?ln=en

With thanks,
ASRock TSD


Posted By: QuRi76
Date Posted: 21 Feb 2022 at 2:28pm
So I have a phantom d 5700xt and an extreme 4 x570 and I am currently on WIN11 with the 2.0.114v of poly chrome and I keep getting an error of driver cannot be loaded, re-install, if it happens again, report problem with your system configuration as detail as possible?


Posted By: QuRi76
Date Posted: 23 Feb 2022 at 1:49am
Help.



Print Page | Close Window

Forum Software by Web Wiz Forums® version 12.04 - http://www.webwizforums.com
Copyright ©2001-2021 Web Wiz Ltd. - https://www.webwiz.net