Print Page | Close Window

SSDs Not Recognized in New Build

Printed From:
Category: Media&User's Review
Forum Name: AMD Motherboards
Forum Description: ASRock AMD Motherboards
Printed Date: 19 Jul 2024 at 4:17pm
Software Version: Web Wiz Forums 12.04 -

Topic: SSDs Not Recognized in New Build
Posted By: WeeWilly
Subject: SSDs Not Recognized in New Build
Date Posted: 13 Apr 2021 at 9:17pm
I'm a first-time builder and this is a completely brand new build. All seemed normal in the build process except that neither of my two SSDs seem to be properly recognized. I have removed and reinstalled them to make certain they were seated properly and it made no difference.

Can you help?

From ASRock System Configuration Utility:

Main Screen:
- UEFI BIOS Version: x570 Phantom Gaming 4 P3.10
- Processor Type: AMD Ryzen 7 3700X 8-Core Processor
- Processor Speed: 3600MHZ
- Microcode Update: 870F10/8701021

- Total Memory: 16GB
- DDR4_A1: None
- DDR4_A2: DDR4-2666 8GB
- DDR4_B1: None
- DDR4_B2: DDR4-2666 8GB

Advanced/Storage Configuration Screen:
- SATA Port1: Not Present
- SATA Port2: Not Present
- SATA Port3: Not Present
- SATA Port4: ST4000M004-2C (4000.7GB)
- SATA Port5: Not Present
- SATA Port6: Not Present
- SATA Port7: Not Present
- SATA Port8: Not Present
- SATA PortM.2_3: Not Present

Advanced/Storage Configuration/NVMe Configuration Screen:
- Bus:1 Dev:0 Func:0: ADATA SX8200PNP
- Size: 512.1GB

- Bus:4 Dev:0 Func:0: ADATA SX8200PNP
- Size: 1024.2GB

I installed Windows 10 Home from thumb drive onto HDD to see what Windows saw. It does not see the SSDs.

The build:
- Motherboard: ASRock X570 Phantom Gaming 4
- Processor: AMD Ryzen 7 3700X 8-Core with Wraith Prism LED Cooler
- Memory: Crucial Ballistix 3200 MHz DDR4 DRAM Desktop Gaming Memory Kit 16GB
- Graphics Card: MSI Graphic Card GT 1030 2GH LP OC
- SSD-1 in M2_1: ADATA XPG SX8200 Pro 512GB 3D NAND NVMe Gen3x4 PCIe M.2 2280 Solid State Drive
- SSD-2 in M2_3: ADATA XPG SX8200 Pro 1TB 3D NAND NVMe Gen3x4 PCIe M.2 2280 Solid State Drive
- HDD: Seagate BarraCuda 4TB Internal Hard Drive HDD ??3.5 Inch SATA
- Case: SilverStone Technology FARA B1
- Power Supply: SilverStone Technology 550 Watt 80 Plus Bronze ATX PSU

Posted By: sofarfrome
Date Posted: 17 Apr 2021 at 7:29am
The mobo will not recognize them until you either install an OS on one of them or get into windows and use disk management to give them an identity.

Guide to install Windows 10 on NVMe M.2 drive:

The NVMe M.2 drive should be the only storage drive connected.

NVMe SSDs do not appear within the BIOS until Windows creates the system partition with the EFI Boot Sector. Your M.2 SSD contains UEFI driver information within the firmware. By disabling the CSM module, Windows will read and utilize the M.2-specific UEFI driver

Go into the BIOS, under the boot tab there is an option for CSM. Make sure it is disabled.

Click on the secure boot option below and make sure it is set to another OS, not windows UEFI.

Click on key management and clear secure boot keys.

Insert a USB memory stick with a bootable UEFI USB drive with Windows 10 Setup* on it, USB3 is quicker but USB2 works too. A Windows DVD won?t work unless you?ve created your own UEFI Bootable DVD.

Press F10 to save, exit and reboot.

Windows 10 will now start installing to your NVME drive as it has its own NVME driver built in.

When the PC reboots hit F2 to go back into the BIOS, you will see under boot priority that windows boot manager now lists your NVME drive.

Click on secure boot again but now set it to Windows UEFI mode.

Click on key management and install default secure boot keys

Press F10 to save and exit, Windows will finish the install. Once you have Windows up and running, shutdown the PC and reconnect your other SATA drives.

Ryzen 1700, ASRock Taichi X370, G.SKILL Flare X Series 16GB DDR4 3200, Samsung EVO850 250GB

Posted By: Papanunu
Date Posted: 07 Sep 2022 at 8:27pm
Hello. I have problem installing windows 11 off a usb on a brand new PC built. I am stuck at blue windows logo after choosing winpe setup that appears on gnu grub. I think it might have something to do with the ssd? I'm not quite sure but I tried turning on secure boot with csm disabled, but still it doesnt make any difference. I also tried turning on and off tpm with no success.

I am using b550m itx phantom. Klevv ssd 1tb m2 nvme.

Posted By: Papanunu
Date Posted: 07 Sep 2022 at 8:37pm
Additional info for my above comment.

On bios, sata port 1-4 and sata m.2 are listed as not present, but underneath it all there is a NVMe configuration folder, and when I open it I can see my klevv ssd listed there next to "Bus:1 Dev:0 Func:0"

Print Page | Close Window

Forum Software by Web Wiz Forums® version 12.04 -
Copyright ©2001-2021 Web Wiz Ltd. -