Print Page | Close Window

TRX40 Creator - "Code 54" After Reboot

Printed From: ASRock.com
Category: Technical Support
Forum Name: AMD Motherboards
Forum Description: Question about ASRock AMD motherboards
URL: http://forum.asrock.com/forum_posts.asp?TID=18692
Printed Date: 01 Mar 2024 at 8:02pm
Software Version: Web Wiz Forums 12.04 - http://www.webwizforums.com


Topic: TRX40 Creator - "Code 54" After Reboot
Posted By: Moose
Subject: TRX40 Creator - "Code 54" After Reboot
Date Posted: 24 Apr 2021 at 9:27pm
ASRock TRX40 Creator + AMD Ryzen Threadripper 3970X Processor
BIOS 1.73 64GB (4x Kingston Server Premier KSM32ES8/16ME Memory 16GB 3200MHz DDR4 ECC CL22 DIMM 1Rx8 Micron - Part Number: Kingston 9965684-032.A00G (Micron)

PC always boots up fine from a cold start.
After a software initiated reboot (windows restart for example), the system will stay on a black screen and the red debug LED cycles through and stops on Code 54 which seems to indicate a memory issue. After a manual reboot using the hardware reset button, the PC boots up everytime.

I know this RAM is not on the official Memory QVL yet new but a very similar Kingston ECC is listed as supported (KSM26ED8/16ME). This issue might be a related to something else like a BIOS setting and I've tried various things.

PC has been stress tested (CPU, RAM, GFX) and no issues over the past 2 months. Just raising awareness of this to see if anyone else has the issue?



Replies:
Posted By: ket
Date Posted: 26 Apr 2021 at 7:54pm
You can try;

1. Running HCI memtest to see if any errors are detected, let it run to at least 300%.
2. Increase memory voltage to 1.4v
3. Take 2 sticks out and see if you get the same problem
4. Did you get this issue with firmware 1.7? (non-beta release)
5. Look at the serial numbers on your memory, the final digits will be in sequence. Eg; 0314, 0315, 0316, 0317. Install the memory modules so they are all in order.
6. Try increasing tCWL and tRDWR to 16 or 18.


Posted By: Moose
Date Posted: 28 Apr 2021 at 2:19am
Thanks for these ideas to try.

1. Already ran various memtest86 tests which took a long time and passed, unless there is something special about HCI memtest.
2. Tried voltage at 1.4v on all banks, no change.
3. Tried with 2 sticks, no change.
4. Yes, happened in 1.7 non-beta.
5. Moved them to be in order by serial number (assuming bank A2 is the first slot, B2 second, C2 third and D2 last for quad channel) - no change.
6. tCWL was already set to 18 by default, so tested at 22 and no change. Also increased tRDWR to 18 and no change.


Posted By: ket
Date Posted: 01 May 2021 at 5:15am
Have you tried disabling Gear Down mode and manually setting Command Rate to 2T? TRFC should already be set loose enough but you could try adding 50 or 100 to that and see if that helps as well.


Posted By: Moose
Date Posted: 26 May 2021 at 9:21pm
Originally posted by ket ket wrote:

Have you tried disabling Gear Down mode and manually setting Command Rate to 2T? TRFC should already be set loose enough but you could try adding 50 or 100 to that and see if that helps as well.


Tried all that but didn't fix the issue.


Posted By: ket
Date Posted: 29 May 2021 at 9:12am
What are your full system specs? POST failure on restart is probably a RAM training issue but depending on things like what CPU you have a voltage bump to vsoc might be effective, as might increasing ProcODT. Try downloading ZenTimings and posting a screenshot of it something might stand out.


Posted By: Moose
Date Posted: 30 May 2021 at 12:34am
CPU: AMD 3970X
MB: TRX40 Creator
RAM: 4x Kingston 16GB 3200 ECC (Matching)
PSU: Seasonic 1300W Platinum
GPU: RTX 3090
HDD: 2x WD SN850 Black 1TB, 1x Samsung 970 EVO 500GB



Posted By: ket
Date Posted: 04 Jun 2021 at 7:24pm
Do you know what ICs your memory is using? (You can get that infor with Thaiphoon Burner) Quite a lot stands out there;

1. Disable GDM (Gear Down Mode)
2. ProcODT should be ok at 60 Ohms but you can try 68 Ohms as you're running 4x sticks.
3. Try reducing VDDG voltage I've found on the 3000 series at least if that voltage is set too high it can actually negatively impact stability, on my 3700X with 32GB 3600MHz Klevv BoltX I have it set to 0.85v, it could probably go even lower than this. Try 0.9v and slowly work your way down to see if that makes a difference.
4. You have a lot of oddly aggressively set timings considering you are running 4 sticks across all DIMM banks. Try changing TRRDS to 6 or 7, TRRDL to 9 or 10, TFAW try 45, TWTRS try 6 or 8, TWRWRSD & TWRWRDD try 7 or 8, try a TCKE of 9. Lastly TRDRDSD & TRDRDDD might be a little tight as well try a value of 5 or 6.


Posted By: Moose
Date Posted: 04 Jun 2021 at 9:12pm
Tried all that and still the same.
The BIOS wouldn't allow a lower value than 0.9v for VDDG.

This is the datasheet for the memory, it is the Micron variant:
https://www.kingston.com/dataSheets/KSM32ES8_16ME.pdf

This is what ZenTimings looks like after all these changes:



Posted By: ket
Date Posted: 05 Jun 2021 at 1:25am
Micron is a real pain on Ryzen, the only CPUs I have that (kind of) run Micron memory happily are based on Zen+. Hynix based memory works very well on Zen, Zen+, Zen2, etc though. As does the now old and ever growing in expense B-Die. You could try switching CMD2T to 2T to see if that works, disabling PowerDown might help too. Outside of that though I think you're out of luck unless you're happy to reduce the memory frequency a bit.


Posted By: Moose
Date Posted: 05 Jun 2021 at 1:58am
Thanks for the suggestions to try anyway, I just tried with CMD2T set to 2T and PowerDown disabled as well as reducing the frequency to as low as 2666MHz and it still occurs unfortunately.

Furthermore, Asrock list a similar Kingston ECC (KSM26ED8/16ME) as supported which is Micron but is Dual-rank and mine is Single-rank though so may be a factor:
https://www.asrock.com/mb/AMD/TRX40%20Creator/#Memory" rel="nofollow - https://www.asrock.com/mb/AMD/TRX40%20Creator/#Memory

I mean the system is stable, it's just this reboot issue maybe it is something else but the code 54 seems to indicate memory. There's loads of BIOS settings available not even mentioned in the manual so maybe more things to try.


Posted By: Moose
Date Posted: 05 Jul 2021 at 3:00am
Well, believe it or not but after restoring the BIOS to defaults and configuring the same existing settings one-by-one, the issue has gone away. But I left all voltage and timings on Auto as well which was the same as initial testing. The only difference I can think of is I was saving and loading configurations, maybe there was a hidden setting being changed or something when loading a configuration. I have been in contact with ASRock support about this recently so will pass on this information. I also found that Overclocking is disabled when TSME is enabled (the BIOS menu disappears and Ryzen Master stops supporting it).


Posted By: ket
Date Posted: 30 Jul 2021 at 7:18pm
Thats weird but not unheard of, didn't we already try resetting CMOS defaults a few times and it didn't work? Might be a hidden setting, or more likely the auto settings have changed one or two settings thats a very common occurrence, and why I'm not a fan of auto settings on mainboards. Use ZenTimings to have a peek at what timings the board is using now and if you have one compare them to an older screenshot when the board was using auto timings to see if anything is different.


Posted By: Moose
Date Posted: 31 Jul 2021 at 9:08pm
Originally posted by ket ket wrote:

Thats weird but not unheard of, didn't we already try resetting CMOS defaults a few times and it didn't work? Might be a hidden setting, or more likely the auto settings have changed one or two settings thats a very common occurrence, and why I'm not a fan of auto settings on mainboards. Use ZenTimings to have a peek at what timings the board is using now and if you have one compare them to an older screenshot when the board was using auto timings to see if anything is different.


Yes, did try BIOS reset a few times. Just had a look at ZenTimings and everything is the same as originally posted (post #7). Very strange.


Posted By: ket
Date Posted: 03 Aug 2021 at 8:00pm
Very strange indeed, not had an issue like this apparently magically fix itself before. Might be worth cleaning the gold contacts on the memory with a soft white artists eraser and ensuring the DIMM slots are clear of any dust and general debris. Has Windows done any updates recently? Perhaps one of those did something to remedy the problem. Chalk this one up to one of lifes little mysteries for now I guess.


Posted By: Rogash1
Date Posted: 15 Oct 2022 at 11:02pm
I'm still facing this issue in 2022 with the newest bios version 1.83. Was anyone able to resolve the problem so far?


Posted By: Moose
Date Posted: 15 Oct 2022 at 11:34pm
Originally posted by Rogash1 Rogash1 wrote:

I'm still facing this issue in 2022 with the newest bios version 1.83. Was anyone able to resolve the problem so far?


Haven't seen the issue for a long time now.
Also using 1.83 currently and it is working fine.

Try restoring your BIOS to defaults and then reflashing your bios with the same latest version and then restoring to default once again and see if it does it at default settings (you might want to disable bitlocker in Windows first if that is applicable).




Print Page | Close Window

Forum Software by Web Wiz Forums® version 12.04 - http://www.webwizforums.com
Copyright ©2001-2021 Web Wiz Ltd. - https://www.webwiz.net