Print Page | Close Window

ASRock FM2A88X pro+ freeze at bios screen

Printed From: ASRock.com
Category: Technical Support
Forum Name: AMD Motherboards
Forum Description: Question about ASRock AMD motherboards
URL: http://forum.asrock.com/forum_posts.asp?TID=18816
Printed Date: 29 Jul 2021 at 1:38am
Software Version: Web Wiz Forums 12.04 - http://www.webwizforums.com


Topic: ASRock FM2A88X pro+ freeze at bios screen
Posted By: RoboBobo
Subject: ASRock FM2A88X pro+ freeze at bios screen
Date Posted: 11 May 2021 at 3:57pm
Hello. I have PC with mainboard AsRock FM2A88X pro+
( https://www.asrock.com/mb/AMD/FM2A88XPro+/index.asp" rel="nofollow - https://www.asrock.com/mb/AMD/FM2A88XPro+/index.asp )
I just updated BIOS through UEFI Instant Flash (from 2.? to 3.4)
Stupid idea to update without good reason, i know, but it's done. And update finished without problems.
But after reboot pc always freeze at bios info screen. Windows not loading, keyboard not working and can't enter BIOS with F2.

I tried (nothing works)
-disconnect all usb devices.
-disconnect hdmi from NVIDIA card then connect after power on.
-open PC and disconnect SATA decices

Is something other i could try before i call for professional help?
Something which I can do without special tools, just with my hands?

But please give me detailed answer becouse i'm not very familiar with hardware :)

Or is it any way to restore old BIOS version?



Replies:
Posted By: RoboBobo
Date Posted: 11 May 2021 at 3:59pm
edit:correct link https://www.asrock.com/mb/AMD/FM2A88X%20Pro+/index.asp" rel="nofollow - https://www.asrock.com/mb/AMD/FM2A88X%20Pro+/index.asp


Posted By: datonyb
Date Posted: 11 May 2021 at 11:10pm
you could try just 1 ram stick
and unplug pc from wall ,remove the small coin sized battery on the board
press and hold power button for a few seconds several times to discharge every last bit of power from the board
then plug back into wall and see if its cleared the cmos and reset itself to enable you to enter the bios menu

-------------
[url=https://valid.x86.fr/jpg250][/url]

3800X, powercolor reddevil vega64, gskill tridentz3866, taichix370, evga750watt gold


Posted By: RoboBobo
Date Posted: 14 May 2021 at 5:47am
Batery removed for about two hours. I also disconnect graphic card audio cable, usb cable from mainboard. But nothing helped.

So, probably my board is bricked?


Posted By: RoboBobo
Date Posted: 15 May 2021 at 5:35am
I was playing with cables connected to motherboard and after disconnect something, PC starts booting correctly.
So, probably problem fixed (I only have to check which device is problematic).



Print Page | Close Window

Forum Software by Web Wiz Forums® version 12.04 - http://www.webwizforums.com
Copyright ©2001-2021 Web Wiz Ltd. - https://www.webwiz.net