Print Page | Close Window

Various Deskmini H470 Issues

Printed From:
Category: Technical Support
Forum Name: HTPC&Gaming Barebone&Others
Forum Description: Question about HTPC&Gaming Barebone&Others
Printed Date: 19 May 2024 at 10:37pm
Software Version: Web Wiz Forums 12.04 -

Topic: Various Deskmini H470 Issues
Posted By: alocalu
Subject: Various Deskmini H470 Issues
Date Posted: 30 May 2021 at 2:43pm
I have three H470s both installed with Intel i7-11700 and 2*16GB Crucial RAM, each with varations on the storage situation:

    SATA1 - S4610 400GB SATA drive as OS drive runing Ubuntu 21.04

    Front M.2 - Corsair MP510 960GB

    Back M.2 - Corsair MP510 960GB

    Front M.2 - Silicon Power 34A80 1TB

    Front M.2 - Corsair MP510 1920GB as OS Drive runing Ubuntu 21.04

    Front M.2 - Corsair MP510 1920GB as OS Drive runing Ubuntu 21.04

    Front M.2 - Silicon Power 34A80 1TB

Issues that I have encountered:
    System will randomly shutdown itself for no apparent reason (not under load). Can't find any cause in sysmtem log.

[LIST=2]Can't boot without HDMI connected. I need this to run headless so it's real pain.[/LIST=2]
[LIST=3]M.2 slot on the back (hyper m.2 slot) has extremely slow write speed. I'm talking about under 100MB/s with Gen3 NVMe drive installed.[/LIST=3]

Steps that I have tried to fix these issues without success:
    BIOS has been updated to the newest 2.1 version.

[LIST=2]Tried with various BIOS settings, such as change the CPU voltage and set power adapter watt.[/LIST=2]
[LIST=3]Cross test all the hardwares that I have on hand.[/LIST=3]

I'm running into a dead end now and really wish if anyone can at least provide some evidences on what could be causing these issues.


Posted By: aforumuser
Date Posted: 31 May 2021 at 3:06pm
As a data point, I've been running now a H470 for more than half a year as headless Linux server without problems - but on a 10.Gen CPU.

...EXCEPT I had 2 problems at the beginning:

* I had a bad set of ram causing random, rare crashes in use. Try running" rel="nofollow - for 3 days in loops and check your max temp and power usage. After successful start of memtest remove USB stick it was booted from, so you notice when a spontaneous reboot happens (otherwise it would just boot up again and continue running when you are not looking all the time). Changed ram under warranty, no more problems.

* Enabling all power saving options in BIOS makes very low idle power, but also the system unstable. Try disabling PCIE chipset power saving options and CPU C10 deepest sleep and see whether your crashes go away - at the cost of higher idle power...

Good luck!

Posted By: alocalu
Date Posted: 01 Jun 2021 at 8:48pm
Thanks man for your information, I will definitely mess around with those power saving setting to see if that can make any improvement on the shutdown issue.

Since my last post, I have done more tests and can confirm that even with a Gen 4 drive installed on the Hyper slot (tested with 2 Seagate Firecuda 520 1TB), slow writing speed issue persists.

I'm just curious that is there no one in here using this case/motherboard with 11th gen intel cpu at all? No one having the same issue? Because from what I have experienced, this is a significantly serious issue.

Posted By: aforumuser
Date Posted: 04 Jun 2021 at 2:21am
Some more thoughts:

1) Someone on Reddit complained that ASRock botched video output update on H470:" rel="nofollow -
"Deskmini H470 does have this issue on 11th Gen because ASRock FORGOT upgrading iGPU?ôs GOP."

...maybe this is somehow related to your HDMI problem?

2) I received another H470 + 10.Gen CPU this week as they are available again and set it now up.
First upgraded from shipped UEFI 2.0 to 2.1, because, well, why not make it 11.Gen capable?

I installed everything. Tested it. Multiple reboots. Ok, fine, done.
Detached monitor and keyboard, ready as a headless Linux box.
Shutdown. Moved to location.
Boot and... Power LED on a bit.
Power LED turns off. WTF?.
Power LED on again. H470 is not responding via net?
See no debug output, because no monitor. :-(

Attached monitor again and check what's wrong.
Reason is, the box tries to boot with CSM, but that part of the install is non-working.
But... I deliberately disabled CSM support in UEFI and tested warm reboots multiple times!
CSM support was now ENABLED - it turned itself on again?

So this is another data point. :-/
Don't know whether this is a 2.1 issue or whether some combination of
options is/was different to the other H470s I already deployed.
I'm not that motivated to try options and debug to the others, they are in use, sorry...

Posted By: alocalu
Date Posted: 04 Jun 2021 at 8:31pm
Yea I've read the reddit post while searching answers for my encountered issues, seems like a possible cause. Thanks again for sharing this and your experience.

The HDMI issue can simply be dealt with by installing a dummy HDMI plug, the real issue with my setup is about the writing speed of hyper m.2 slot. It's barely usable at this point. Right now I'm testing this with Win 10 Enterprise installed, just trying to rule out the possibility that it's a OS compatibility issue. Will keep everyone here posted (if anyone find this to be useful).

Print Page | Close Window

Forum Software by Web Wiz Forums® version 12.04 -
Copyright ©2001-2021 Web Wiz Ltd. -