Print Page | Close Window

X570 Phantom Gaming 4 - No BIOS Video Output

Printed From: ASRock.com
Category: Technical Support
Forum Name: AMD Motherboards
Forum Description: Question about ASRock AMD motherboards
URL: http://forum.asrock.com/forum_posts.asp?TID=19041
Printed Date: 26 Jul 2021 at 11:47am
Software Version: Web Wiz Forums 12.04 - http://www.webwizforums.com


Topic: X570 Phantom Gaming 4 - No BIOS Video Output
Posted By: Eryxx
Subject: X570 Phantom Gaming 4 - No BIOS Video Output
Date Posted: 08 Jun 2021 at 10:29pm
I recently installed this brand new motherboard and AMD Ryzen7 5800X, however, I do not see ANY output from the UEFI BIOS, either upon initial boot nor using the ASRock Boot to UEFI utility within Win10, nothing except black monitors.

I have already cleared the CMOS via the motherboard jumper, still seeing no video from the BIOS.

Any/all assistance appreciated.



Replies:
Posted By: Eryxx
Date Posted: 09 Jun 2021 at 12:34am
More info: This new BIOS has never been updated, the new build actually booted fine using the drives/Win10 from the previous motherboard, until that image apparently became corrupted from a failed driver update.
Without any BIOS display, I am unable to recover the previously backed-up image or even reload Windows from scratch.


Posted By: Eryxx
Date Posted: 14 Jun 2021 at 4:50am
Resolved this one on my own.

For whatever reason, the secondary GPU in PCIe3 was preventing the primary GPU in PCIe1 from outputting the BIOS graphics, resulting in black monitors until Win10 loaded.

Disabling the secondary GPU by disconnecting the power connector allowed the BIOS graphics to display normally again.


Posted By: ket
Date Posted: 15 Jun 2021 at 7:46pm
Thats actually pretty normal behaviour on a multi monitor setup. Check the UEFI for an option to specifically tell it to output a display on PCIe 1 (primary PCIe 16x slot) first, and make sure your primary monitor is connected to the primary GPU in the display output the GPU considers to be primary (usually the right most display output port).



Print Page | Close Window

Forum Software by Web Wiz Forums® version 12.04 - http://www.webwizforums.com
Copyright ©2001-2021 Web Wiz Ltd. - https://www.webwiz.net