Print Page | Close Window

NVME running at PCIe 1.0 x4

Printed From: ASRock.com
Category: Technical Support
Forum Name: AMD Motherboards
Forum Description: Question about ASRock AMD motherboards
URL: http://forum.asrock.com/forum_posts.asp?TID=19283
Printed Date: 23 Sep 2021 at 8:27pm
Software Version: Web Wiz Forums 12.04 - http://www.webwizforums.com


Topic: NVME running at PCIe 1.0 x4
Posted By: meeowth
Subject: NVME running at PCIe 1.0 x4
Date Posted: 20 Jul 2021 at 10:20pm
I have a B450M pro4-f, with a 5600x. I recently got a 1tb Gen 4 NVME drive, which I inserted and cloned Windows onto from the existing SATA install. I was instantly able to select it as the boot drive and then wipe the SATA drive. So everything seemed good.

I know the motherboard only supports PCIe gen 3x4 so the drive won't run at it's full speed, but I'm fine with that.

But I did a speed check and noticed that the speed was not much higher than the SATA, and on further inspection all hard drive software I checked it with such as CrystalDiskInfo identify that it is running at PCIe 1.0 x4 and not PCIe 3.0 x4.

I have gone into the bios and tried changing the M.2 PCI speed setting from Auto to Gen 3, I have tried a few different versions of the bios including the latest. I have turned off CSM. I have changed the mode of the x16 slot to 8x8 (even though the nvme slot is not meant to be sharing lanes here)

It is definitely in the correct (near CPU) slot since it is working and the other M.2 slot is SATA only.

I have tried to find other people with the same problem, but I can't find anyone else who's NVME drive is specifically running at PCIe 1.0 x4

I do not have another computer with an nvme slot and I don't have any friends nearby with one



Replies:
Posted By: Khun_Doug
Date Posted: 23 Jul 2021 at 2:31am
By chance does this NVMe SSD have a flashable firmware? Some NVMe drives do have upgradeable firmware. I had a Plextor drive that failed during backups. A firmware upgrade resolved the problem.


Posted By: meeowth
Date Posted: 23 Jul 2021 at 10:11am
It is a https://www.gigabyte.com/au/Solid-State-Drive/AORUS-NVMe-Gen4-SSD-1TB#kf" rel="nofollow - Gigabyte Aorus NVME gen4 and the official software indicated it is on the latest firmware with no option to update.


Posted By: Khun_Doug
Date Posted: 23 Jul 2021 at 1:15pm
There are two possibilities to test. The first thing would be to see if any NVMe drive runs at the proper speed. The easiest way is to get an inexpensive one that is just enough storage to hold a copy of Windows, and test it. You could look on Internet for a used one, as this is just for testing.

The other possibility is that the NVMe drive you have is defective. If you test another NVMe drive, and it works properly, then the SSD you have could likely be defective. It is also possible that on your motherboard a PCI 4 SSD will not properly drop back to PCI 3. Again, this is something you can test by using only a PCI 3 NVMe when testing another disk.



Print Page | Close Window

Forum Software by Web Wiz Forums® version 12.04 - http://www.webwizforums.com
Copyright ©2001-2021 Web Wiz Ltd. - https://www.webwiz.net