Print Page | Close Window

X570 Taichi Razer Killer NIC (I'm done!)

Printed From: ASRock.com
Category: Media&User's Review
Forum Name: AMD Motherboards
Forum Description: ASRock AMD Motherboards
URL: http://forum.asrock.com/forum_posts.asp?TID=19364
Printed Date: 27 Jan 2022 at 1:59pm
Software Version: Web Wiz Forums 12.04 - http://www.webwizforums.com


Topic: X570 Taichi Razer Killer NIC (I'm done!)
Posted By: Hyperstrike
Subject: X570 Taichi Razer Killer NIC (I'm done!)
Date Posted: 05 Aug 2021 at 10:32am
I'm basically over the Killer NIC on my x570 Taichi Razer.
When it works, it's acceptable.

However, it's ridiculously prone to the NIC just dropping out.
Not powering down (I've turned that off.) But, mid-data-stream, I simply lose network.

Fiddled power management.
Combed the internet for suggestions.
I grabbed the latest drivers from Intel.

I've been screwing with it since mid-April. I had nice, steady performance for about 2 weeks. Enough time to dismantle my old rig. Then this crap started.

RMA'ing the board isn't acceptable. Because I can't afford to have this system down for more than a day.

So I've bought myself a nice Intel NIC, and this should be the end of it.

Killer has always been a "gimmick". And, now that they've been bought out by Intel, they're a pointless gimmick.

ASRock! Just give us on-brand Intel for our Ethernet solution from now on! Make everyone's life easier!



Print Page | Close Window

Forum Software by Web Wiz Forums® version 12.04 - http://www.webwizforums.com
Copyright ©2001-2021 Web Wiz Ltd. - https://www.webwiz.net