Print Page | Close Window

Painfully slow memory speed on a new B550 ITX

Printed From: ASRock.com
Category: Technical Support
Forum Name: AMD Motherboards
Forum Description: Question about ASRock AMD motherboards
URL: https://forum.asrock.com/forum_posts.asp?TID=19367
Printed Date: 22 May 2024 at 1:49pm
Software Version: Web Wiz Forums 12.04 - http://www.webwizforums.com


Topic: Painfully slow memory speed on a new B550 ITX
Posted By: afora
Subject: Painfully slow memory speed on a new B550 ITX
Date Posted: 06 Aug 2021 at 2:47pm
Hi guys,

Something's wrong with my brand new B550 ITX board - it's very very slow!

I got:
- a brand new rig built slower than my 5 year old laptop (see commands I ran to benchmark below)
- I now replaced the CPU, mobo, and memory with exactly the same model replacements - no parts are faulty
- I updated BIOS to v2.1
- In BIOS' XMP setting I can choose either Auto or XMP Profile DDR4-3400 with no difference observed
- If I chose Auto XMP Settings the mobo auto detects all memories I tried as 2,400MHz even though I tried 2,666, 3,200 and 3.600. Something sticky is there.

Benchmarked read/write speeds:
THIS RIG ->                             - 3.3GB/s
Supermicro + Xeon E-2226G           - 6.6GB/s
Old laptop + Intel Core i5-8250U - 4.5GB/s

It feels there's some sort of problem with hardware/BIOS but I'm not a hardware guy, so I tweaked around but nothing seems to work. The only not officially compatible part is an SSD, but I cannot see how it would make any difference for the memory test.

I would really appreciate any help - I'm kinda at the point of getting a different motherboard make and model.


THE SETUP:
------------

All parts are compatible with B550 Phanto Gaming ITX/AX mobo as per:
https://www.asrock.com/mb/AMD/B550%20Phantom%20Gaming-ITXax/index.asp#MemoryRN" rel="nofollow - https://www.asrock.com/mb/AMD/B550%20Phantom%20Gaming-ITXax/index.asp#MemoryRN
https://www.asrock.com/mb/AMD/B550%20Phantom%20Gaming-ITXax/index.asp#CPU" rel="nofollow - https://www.asrock.com/mb/AMD/B550%20Phantom%20Gaming-ITXax/index.asp#CPU

- Ryzen 5 Pro 4650G
- Hyperx Predator 16x2 - HX432C16PB3K/32
- B550 Phantom Gaming ITX/ax

THE BENCHMARK:
---------------
sudo mkdir -p /mnt/test1
sudo mount -t tmpfs /mnt/test1 /mnt/test1
free
df -h -t tmpfs
dd if=/dev/zero of=/mnt/test1/test bs=1M



    Replies:
    Posted By: Khun_Doug
    Date Posted: 07 Aug 2021 at 9:03am
    I'm not that familiar with Linux, but I do have an Asrock motherboard with Win 10, 64GB RAM, 1 TB boot SSD M.2 PCIe Gen 4, another 1 TB on the second M.2 PCIe Gen 4 slot, and 4 TB on one SATA port, a Blu-Ray ROM on another SATA port. I have X570 Creator with a Ryzen 5950X. The RAM is corsair something with XMP 3600.

    It looks like you are testing disk I/O. I wouldn't expect RAM speed to make major differences with disk I/O speeds.

    You can try disabling the XMP profile and setting the DRAM speed and voltage manually. Remember that the DRAM speed should be exactly twice the speed of the CPU memory fetch. So a speed of 3400 would have a CPU memory clock of 1700. And you also want to be sure the RAM is in the proper slots.



    Print Page | Close Window

    Forum Software by Web Wiz Forums® version 12.04 - http://www.webwizforums.com
    Copyright ©2001-2021 Web Wiz Ltd. - https://www.webwiz.net