Print Page | Close Window

USB 3.0 problem on ASRock B560 Steel Legend ATX

Printed From: ASRock.com
Category: Technical Support
Forum Name: Intel Motherboards
Forum Description: Question about ASRock Intel Motherboards
URL: https://forum.asrock.com/forum_posts.asp?TID=19637
Printed Date: 14 Apr 2024 at 7:56pm
Software Version: Web Wiz Forums 12.04 - http://www.webwizforums.com


Topic: USB 3.0 problem on ASRock B560 Steel Legend ATX
Posted By: SomewhereOnEarth
Subject: USB 3.0 problem on ASRock B560 Steel Legend ATX
Date Posted: 28 Sep 2021 at 2:29pm
Hello. First of all sorry for my bad english.
I have very strange problem with USB 3.0 and ASRock B560 Steel Legend.
When I try to copy big file 20+ GB from USB to USB device via USB 3.0 on motherboard using different USB cases for SDD with UASP support it immediately hangs and destination devices falls into raw (checkdisk says) temporary until reboot.
After force reboot file system is normal again, destination file is 0 byte there.

What I have tried:

1. Tried to change BIOS settins XHCI Hand-off to disable and enable
2. Fresh install Windows 10
3. Tried to boot into WinPE (based on Win10 working for years)
4. Fresh install Windows 11 Beta (MSDN)
5. Tried different SSD's and repartition them, format (Samsung EVO 870, Samsung PRO 860, GoodRAM IRDM)
6. Tried different USB cases (Orico 2521U3-BK, Baseus CAYPH-B01, ADATA ED600)
7. Tried to unplug USB mouse, USB keyboard, tried with PS/2 Keyboard connected only + two USB SSD (without USB mouse and keyboard)
8. Reset CMOS
9. Tried different USB 3.0 ports
10. Tried to unplug front panel (USB 3.0 and 2.0 connectors)

Everytime I have this effect with USB 3.0. When I try to copy or move from SATA to SATA big files everything is OK! No problem at all.
With USB 2.0 on motherboard (near to PS/2) works well! And same USB devices works well via USB 2.0 ports!

I have few SSD Samsung and they are mostly new.
This devices plugged to another computer works well!

PSU 80+ Platinum
Bios version 1.80 (I know there is 2.0 version but changelog says there is TPM enabled by default and that's all changes)
Any suggestions?



Replies:
Posted By: SomewhereOnEarth
Date Posted: 28 Sep 2021 at 2:58pm
Additional info:

When I trying to copy using USB 2.0 progress bar (Total Commander) immediately shows speed and file copy starts without problems, ends too. System works well!

When via USB 3.0 progress bar hangs at start and nothing happens. System also mostly hangs. After few minutes Total Commander gives me an error file not copied and system (Installed or WinPE) starts working better.

Mouse via USB 3.0 works OK. Keyboard too. Weird. :(


Posted By: SomewhereOnEarth
Date Posted: 29 Sep 2021 at 12:54am
I've found this
https://www.asrock.com/Support/faq.asp?id=417

So, this is an old problem but firmware update for ASMedia ASM1074 linked there won't pass on B560 Steel Legend. It is for Intel Braswell platform.

Where is FW update for B560 then?


Posted By: Auggybendoggy
Date Posted: 10 Nov 2021 at 10:28pm
did you ever get this worked out?


Posted By: SomewhereOnEarth
Date Posted: 12 Nov 2021 at 9:59pm
Originally posted by Auggybendoggy Auggybendoggy wrote:

did you ever get this worked out?


No. There is still a problem. Besides I've tried Type C port with several devices and it's working perfect. Because it's not ASM1074 hub. Front panel USB 3.0 working perfect too. So, the problem is ASM1074 (Windows, Linux tested) and I don't know how to fix it. ASrock support didn't see a problem.

You can google ASM1074 problems. There was different devices with this hub not working properly. HP has a firmware for ASM1074 but it's not compatible with B560 Steel Legend.


Posted By: Llander455
Date Posted: 24 Nov 2023 at 12:14am
I have windows 11 and when I try to transfer large files to an external SSD drive it stops and then locks up my computer. I have tried different brands of external SSD drives and it happens to all of them leading me to think the issue is with the USB ports. I have changed out from Type A usb to C port and it still fails on the transfer and locks up the computer. I do not know how to fix this issue with the USB ports on my computer.

-------------
Llander455


Posted By: Chillout
Date Posted: 26 Nov 2023 at 1:36am
You can try disabling USB Legacy support in the BIOS.

I "fixed" the problem and bought a $20 USB PCIE adapter card ( https://www.amazon.com/gp/product/B077VRWZPK/ref=ppx_yo_dt_b_search_asin_title?ie=UTF8&psc=1" rel="nofollow - https://www.amazon.com/gp/product/B077VRWZPK/ref=ppx_yo_dt_b_search_asin_title?ie=UTF8&psc=1 ) and have my external hard drives plugged into that. I can now copy terabytes without it dropping off and freezing the rest of my USB devices.



Print Page | Close Window

Forum Software by Web Wiz Forums® version 12.04 - http://www.webwizforums.com
Copyright ©2001-2021 Web Wiz Ltd. - https://www.webwiz.net