Print Page | Close Window

X570 Pro4 BIOS won't update past 3.0 with 5800x

Printed From: ASRock.com
Category: Technical Support
Forum Name: AMD Motherboards
Forum Description: Question about ASRock AMD motherboards
URL: http://forum.asrock.com/forum_posts.asp?TID=21145
Printed Date: 07 Jul 2022 at 7:10am
Software Version: Web Wiz Forums 12.04 - http://www.webwizforums.com


Topic: X570 Pro4 BIOS won't update past 3.0 with 5800x
Posted By: Shawstin
Subject: X570 Pro4 BIOS won't update past 3.0 with 5800x
Date Posted: 25 Jan 2022 at 12:03pm
After upgrading to a Ryzen 7 5800x and going through the process of updating the bios to be compatible without a Ryzen 3000 series processor, the bios will not update past version 3.0. This is an issue because games with Easy Anti Cheat will cause the computer to just shut off. I have tried pretty much everything but a BIOS update to fix this and people with the same issue as me pretty much all say updating their bios fixed this issue.
I have tried several flashdrives but no matter what I do the instant flash utility will not detect any version of the bios for the x570 pro4. The flashdrives were all formatted to fat32, I have tried every usb port on the motherboard, I have tried small and large fat32 paritions on the usbs, and nothing I have done has been able to allow me to update my BIOS.
Is there some alternative method I need to be using besides the Instant Flash utility or do I just need to buy a new motherboard?



Replies:
Posted By: Xaltar
Date Posted: 25 Jan 2022 at 4:01pm
Which version are you trying to update to, 4.20?
I am sure this is a silly question but did you extract the raw BIOS file to the
flash drives or just put the zip on there? The zip file needs to be extracted.

-------------



Print Page | Close Window

Forum Software by Web Wiz Forums® version 12.04 - http://www.webwizforums.com
Copyright ©2001-2021 Web Wiz Ltd. - https://www.webwiz.net