Print Page | Close Window

CSM Requires graphics card£

Printed From: ASRock.com
Category: Technical Support
Forum Name: Intel Motherboards
Forum Description: Question about ASRock Intel Motherboards
URL: https://forum.asrock.com/forum_posts.asp?TID=22325
Printed Date: 19 May 2024 at 10:31pm
Software Version: Web Wiz Forums 12.04 - http://www.webwizforums.com


Topic: CSM Requires graphics card£
Posted By: marmalodak
Subject: CSM Requires graphics card£
Date Posted: 13 Mar 2022 at 3:41pm
Z690 Extreme
Core i7 12700K

I bought this motherboard and CPU combo because I did not want to install a graphics card.

However, CSM can't be enabled without a graphics card and CSM is required to set a boot device, both in menu and on the boot screen.

Please explain how I can boot.



Replies:
Posted By: threadzipper1957
Date Posted: 14 Mar 2022 at 11:28pm
Hello,

best would be to use the support form:
https://event.asrock.com/tsd.asp?ln=en" rel="nofollow - https://event.asrock.com/tsd.asp?ln=en
Are you using the latest BIOS 4.01, and what IOS do you want to install, also state which version and release.
Compatibility Support Module, was to support Legacy hardware, but when you use the built in Graphics in the CPU, it can handle CSM disabled.
CSM should be disabled, and this means the OS will be installed in UEFI mode, Windows calls it GPT.
The bootmenu in UEFI is different from the old fashioned BIOS, there is no point settings up a boot priotity.
leave CSM Disabled, the insert the USB stick with the OS you want to install, during boot press f11 to get into the bootmenu, and select the UEFI (USB) device, this is all.
You don't need CSM to be enabled to instal an OS


-------------
Kind Regards


Posted By: IXer0
Date Posted: 30 Jan 2023 at 9:15am
I have a similar problem with z690 steel legend wifi 6e/d5 and core 17-12700, except I have a Biostar RX 560 graphics card installed and yet when I go to Compatibility support module in the UEFI it says, "CSM is disabled. To enable csm, please install an external graphics card". I am on UEFI version 9.03.

I want boot be able to boot in legacy mode. Anyone has any suggestions?

-------------
My new rig:
Asrock z690 Steel Legend WiFi 6E/D5
Intel Core 17-12700
32GB RAM (Kingston Fury 16GB x2)
1 Biostar RX560 4GB 128-bit DDR5 GPU
Dell P2314H 23" & Dell P2210 22" monitors
2023.01.28


Posted By: threadzipper1957
Date Posted: 30 Jan 2023 at 8:20pm
Hello,

Intel and AMD have removed legacy support, mor eand more. over the past years.
But your problem seems to be that your graphics card, is either not recognized, which means onboard graphics wil keep working, and the card is not found in device manager, or your card does not support Graphics Output protocol, and send the wrong information to UEFI.
The last can only be solved by a firmware update for the graphics card.
You can try to set the PCIE slot in BIOS to Gen3, instead of Auto

-------------
Kind Regards


Posted By: joonsmith
Date Posted: 31 Jan 2023 at 1:16am
Will there be any need of graphics card to play https://pgslot.pub/slot-promotion/" rel="nofollow - pg slots

-------------
JS



Print Page | Close Window

Forum Software by Web Wiz Forums® version 12.04 - http://www.webwizforums.com
Copyright ©2001-2021 Web Wiz Ltd. - https://www.webwiz.net