Print Page | Close Window

N68C-GS4 FX Gigabit LAN card problem

Printed From:
Category: Technical Support
Forum Name: AMD Motherboards
Forum Description: Question about ASRock AMD motherboards
Printed Date: 29 May 2024 at 7:16pm
Software Version: Web Wiz Forums 12.04 -

Topic: N68C-GS4 FX Gigabit LAN card problem
Posted By: OmegaInfo
Subject: N68C-GS4 FX Gigabit LAN card problem
Date Posted: 16 Mar 2016 at 6:56pm
It seems that the motherboard N68C-GS4 FX integrated Atheros AR8171 Gigabit LAN card isn't capable of being Gigabit !!! I have only managed to get it running in fast ethernet mode (100 instead of 1000). I thought perhaps it is a software issue (you don't get an option in the driver to force Gigabit speed) and tried every possible combination with no success (tried every revision of driver possible various OS-es installed different cables bootable CDs etc). It seems that the problem exists also in a similar motherboard with a different LAN Gigabit card (N68C-GS FX) according to people in other forums. Maybe the same Nvidia chipset doesn't get along with integrated LAN cards that aren't Nvidia on similar motherboards ? Few of the latest BIOS revisions on this motherboard seem to be fixing LAN card problems. Well when is it going to get fixed finally Confused ? I thought I could fix my problems by switching my new motherboard with the only other similar (compatible) motherboard but I don't want to risk getting into same problems again. Don't get me wrong the motherboard works great and with no problems just that glitch is getting on my nerves as I do A LOT of networking stuff and fast ethernet speeds just don't cut it. I have sent an official complaint to the support department already but they aren't answering. Speak up Asrock !!!

Posted By: wardog
Date Posted: 21 Mar 2016 at 7:32am
The Atheros AR8171 is indeed a Gb controller.

What switch/modem/router are you connecting it to?

Posted By: OmegaInfo
Date Posted: 21 Mar 2016 at 12:23pm
Just an update: Asrock Support did answer my request and I supplied them with info they needed. Thanks guys. I am using it to connect it directly with another laptop (which also has a Gbit LAN card). Beside the numerous examples on the internet about the identical Atheros card having identical issues on other platforms (even laptops !!!) of the type "there isn't an option in the driver to force it to work Gbit" and even weirder I opened the *.inf of the driver and the driver itself HAS AN OPTION to work Gbit but somehow magically it doesn't appear in the final menus of the driver when you install it. People on other forums didn't get it to work properly but they are guessing either the windows kernel is limiting it because of some hardware conflict (the driver itself says no problems here). Or there is some mega problem where the LAN card and the MB chipset are fighting a hidden war somewhere. Either way the LAN card on the laptop clearly works (it has an option to force Gbit) and the LAN card on the desktop clearly doesn't (it doesn't have an option to force Gbit). And to make things even clearer I did try auto-negotiate on both ends (still no Gbit) different driver revisions (still no Gbit) different OSes (still no Gbit) different cables (5e and 6 cat - still no Gbit) etc etc. And to be turbo mega weird I digged up an Atheros Ethernet Utility that checked the LAN card internally and the connected cables and it says everything is OK. To me it seems that this is a thing that only a BIOS/UEFI patch can fix. But I have no clue what's causing it. If you guys have a clue please enlighten me.

Posted By: parsec
Date Posted: 21 Mar 2016 at 12:33pm
First of all, there is no "LAN card" included with your board. The Atheros AR8171 networking chip is used in your board.

My ASRock X99 board has both an Intel I218V and the Atheros AR8171 networking chips in it. The Atheros chip is running at 1Gbps according to Windows Network and Sharing Center, its Device Manager entry, and the LED indicator on its RJ45 input jack.

I happen to use several simple network switches, whose speed is 1Gbps, so I know the connection between the switch and Atheros AR8171 port is a 1Gbps connection.

and I are wondering what router or other device is connected to that PC's network input, to verify its speed is 1Gbps. You provided no information that the signal into that chip is a 1Gbps signal.

You may have a problem with the board and chip, but verifying the network signal source speed is the first question that must be answered.

The Nvidia chipset is PCIe 1.1, so is fast enough for a 1Gbps signal. The Nvidia chipsets in general are poor, and no longer supported by Nvidia.

While not a fix for your board, a Gigabit wired networking card can be had for less than $15, $10 is not uncommon.

A recent BIOS update includes a LAN improvement, have you tried it?" rel="nofollow -

-------------" rel="nofollow">

Posted By: wardog
Date Posted: 21 Mar 2016 at 7:42pm
Correct me if I'm wrong but don't you need a crossover cable to use from computer to computer?

Seeings you do a lot of networking, why not just connect them through a switch, or the switch on your router?


Posted By: OmegaInfo
Date Posted: 10 May 2016 at 10:25am


I have solved the case myself.

I have successfuly RMA'd my MBO to the authorised vendor and got a substitute new MBO.

I have tested the new MBO and everything works OK.

The first new MBO was faulty.


Print Page | Close Window

Forum Software by Web Wiz Forums® version 12.04 -
Copyright ©2001-2021 Web Wiz Ltd. -