Print Page | Close Window

Z170m PRO4S beep codes

Printed From: ASRock.com
Category: Technical Support
Forum Name: Intel Motherboards
Forum Description: Question about ASRock Intel Motherboards
URL: https://forum.asrock.com/forum_posts.asp?TID=2287
Printed Date: 25 May 2024 at 6:53am
Software Version: Web Wiz Forums 12.04 - http://www.webwizforums.com


Topic: Z170m PRO4S beep codes
Posted By: ahansen
Subject: Z170m PRO4S beep codes
Date Posted: 23 Mar 2016 at 6:23am
My machine won't POST, has no image on screen, but has LEDs and fans spinning. I put in an on board speaker, and I get three long beeps that repeat. My question is, what does this indicate? The manual doesn't list any codes.

The PSU and VGA adapter are known good.

CPU is Intel 6600K, RAM is 2 x 8GB DDR4 2666 G.SKILL Ripjaws 5 modules. Interestingly, 2666 isn't listed as compatible but speeds lower and higher are listed. Could it be failed RAM modules or a speed this board can't handle? No sticks in the board produces the same 3 tones. Single sticks in any slot also produce the same tones.



Replies:
Posted By: parsec
Date Posted: 23 Mar 2016 at 11:43am
The AMI UEFI/BIOS on your board does not have a three long beep code.

If we assume it is a three short beep code, that is a memory problem. Here's a page describing the AMI beep codes:

http://www.bioscentral.com/beepcodes/amibeep.htm" rel="nofollow - http://www.bioscentral.com/beepcodes/amibeep.htm

All DDR4 memory will default to a speed of 2133 or even less. The full speed of DDR4 memory that is over 2133 will only be applied with an XMP profile, or a manual setting of the maximum advertised speed.

The only reason you don't see a memory speed of 2666 in the specs of your board (and other Z170 boards) is that speed is based on a BCLK of 133MHz instead of the standard 100MHz. Your board's UEFI will have a 2666 listing if the BCLK is set to Auto in the DRAM Configuration screen.

Is the memory you have one of these models: http://www.gskill.com/en/finder?cat=31&prop_3=2666MHz&prop_4=0&prop_1=0&series=2481&prop_2=16GB+%288GBx2%29&prop_6=Dual+Channel+Kit" rel="nofollow - http://www.gskill.com/en/finder?cat=31&prop_3=2666MHz&prop_4=0&prop_1=0&series=2481&prop_2=16GB+%288GBx2%29&prop_6=Dual+Channel+Kit

If it is, check the QVL list on each of them, you'll find your board on the G.SKILL list. So they should be compatible. If you check the specs, you'll see that the SPD Speed is 2133, the default speed.

You should be using the A2 and B2 slots with two DIMMs, as you have. Have you tried clearing the UEFI/BIOS when you moved the memory around? You should clear the UEFI whenever you change a memory configuration.

You are sure the memory is seated correctly? All to easy to make this mistake.

Have you ever had the board start to the point you can get into the UEFI/BIOS, or install Windows?

One possibility is bent pins in the CPU socket. The only way to check that is remove the CPU.

Sorry but I must ask, do you have a cable from the PSU connected to the 4/8 pin CPU power connector on the board?

Both DIMMs being defective would be unusual, but not impossible. G.SKILL have great customer service, if you need to use a different model of memory, they will likely trade that model for the one you have now. I'm using Trident Z memory in my ASRock Z170 board.



-------------
http://valid.x86.fr/48rujh" rel="nofollow">


Posted By: Cicca
Date Posted: 26 May 2016 at 3:44am
Hi all....I'm experiencing the same problem here.....3 long beeps (at least, they seem to be long enough....) during the POST...
I've read it should be a RAM problem related, but DIMMs (2 x KINGSTON HyperX Fury 8 GB DDR4 2666 MHz CL15) are brand new, as well as the MB, and the whole PC, just assembled....
According to this page:
http://www.asrock.com/mb/Intel/Z170%20Pro4S/index.asp?cat=Memory&Model=Z170%20Pro4S&Vendor=HyperX" rel="nofollow - http://www.asrock.com/mb/Intel/Z170%20Pro4S/index.asp?cat=Memory&Model=Z170%20Pro4S&Vendor=HyperX
the compatibility is ok (module is HX426C15FB/8), but I'm having the beeps regardless in which slots I put them in....
Could someone please help...?! Thanks a lot in advance...




Posted By: Xaltar
Date Posted: 26 May 2016 at 1:09pm
Cicca, can we get your full system specs please. 

If you are using a dedicated graphics card make sure you have it's PCIe power cables connected, if you do not that can cause post beeps that fall outside of the standard AMI codes.


-------------


Posted By: Cicca
Date Posted: 26 May 2016 at 2:41pm
That's the full configuration:

MB ASROCK Z170 PRO4S socket LGA 1151 chipset Z170 ATX
Processore INTEL Core i3-6100 (Skylake) Dual-Core 3.70 GHz integrated GPU HD 530 Socket LGA 1151 boxed
ASUS Radeon R9 380 4 GB GDDR5 Strix OC Edition
2 x KINGSTON DIMM HyperX Fury 8 GB DDR4 2666 MHz CL15
HD SEAGATE Desktop HDD 2 TB Sata III 6 Gb / s 3.5" Buffer 64 Mb 7200 Rpm
Case ITEK INVADER R03 Middle Tower ATX

Graphic card is correctly power connected and apparently working (at least, light is on, and fans spin)....

Thanks a lot for any hint....


Posted By: Xaltar
Date Posted: 26 May 2016 at 2:45pm
Try removing the GPU, clear CMOS and boot with the integrated graphics. Let us know what happens.

-------------


Posted By: Cicca
Date Posted: 26 May 2016 at 3:17pm
Thanks Xaltar.....
Do you mean "physically remove" the GPU from the processor....?! How to do that..?! Wacko
Forgive my hardware newbiness....I've been out of the scene for a while.... Unhappy


Posted By: Xaltar
Date Posted: 26 May 2016 at 3:32pm
I mean remove the ASUS R9 380 Strix from the motherboard. If you did not build the PC yourself or are not comfortable playing with the insides of your case I would recommend you take it to a professional to avoid causing damage to your system unintentionally.

If you do try to fix it yourself then be careful when working inside the case. When you remove the R9 380 make sure you do not forget to unlatch the retention clip on the PCIe slot before pulling the card out, it should lift out easily. The retention clip is a white clip found on the PCIe slot itself, they can be tricky to unlock, especially with dual slot GPUs so be careful and take your time.


-------------


Posted By: Cicca
Date Posted: 26 May 2016 at 3:45pm
OK....that sounds more familiar to me..... Wink
I assembled it by myself....I'm experienced enough in simple activities like that....althought my last assembled PC was some 4-5 years ago.....thanks a lot for your suggestions anyway......
sorry again for the dumb question....Ouch


Posted By: Xaltar
Date Posted: 26 May 2016 at 3:50pm
The only thing dumb about a question is not asking it, no matter how silly it may seem Wink It's always better to ask than do it wrong. Make sure you clear CMOS after removing the GPU and before you power the system on.

-------------


Posted By: Cicca
Date Posted: 27 May 2016 at 3:28am
Just tried....nothing changes....that was not the problem.....Ouch
Other ideas..?!


Posted By: parsec
Date Posted: 27 May 2016 at 11:35am
Have you done a UEFI/BIOS clear yet? You can do that by moving the jumper on the CLR_CMOS header. That header is on the lower edge of the board, on the right side.

Do you know how to do that? Be sure the PC is off, PSU is off and disconnected from AC power.


-------------
http://valid.x86.fr/48rujh" rel="nofollow">


Posted By: Cicca
Date Posted: 27 May 2016 at 2:22pm
Yes, I did it twice....once before removing the video card (since I had moved the DIMMs from a slot to another), and then after.....same threee long beeps immediatly at the power up....


Posted By: Xaltar
Date Posted: 27 May 2016 at 2:38pm
OK, now try removing the RAM from the system entirely and see if you get the same beep code without it. If the code is different then the RAM is not the problem.

-------------


Posted By: Cicca
Date Posted: 30 May 2016 at 2:33pm
Hi....update status: removed both DIMMs (from slots A2/B2), cleared the CMOS, turned on.....same three beeps.... Confused....turned off, mounted the DIMMs back, but in slots A1/B1, cleared the CMOS again, turned on....and....NO BEEPS.... Big smile
Now....the new problem is that it doesn't seem to post/boot....I say "seem" because I have no proper cable to connect the monitor (the video card has a Dispay Port output, but the MB no, and the monitor has no HDMI input)....but I hear no "beep" between the POST and the boot (in any case, it can't boot anything since the HD is empty)....
Now....what's your suggestion...?! Buy a cable, and see how it goes on....or try to mount the video card back....?!


Posted By: Xaltar
Date Posted: 30 May 2016 at 2:54pm
Try mount the video card and see how it goes. Good luck.

-------------


Posted By: Cicca
Date Posted: 03 Jun 2016 at 3:29pm
YEAH !!! It goes !!! Thanks for all the help !!! Big smile


Posted By: Xaltar
Date Posted: 03 Jun 2016 at 4:08pm
Glad to hear it, awesome job Big smile

-------------



Print Page | Close Window

Forum Software by Web Wiz Forums® version 12.04 - http://www.webwizforums.com
Copyright ©2001-2021 Web Wiz Ltd. - https://www.webwiz.net