Print Page | Close Window

X570 Taichi Razer Edition

Printed From: ASRock.com
Category: Technical Support
Forum Name: AMD Motherboards
Forum Description: Question about ASRock AMD motherboards
URL: http://forum.asrock.com/forum_posts.asp?TID=23546
Printed Date: 29 Jun 2022 at 12:26am
Software Version: Web Wiz Forums 12.04 - http://www.webwizforums.com


Topic: X570 Taichi Razer Edition
Posted By: Obsidian
Subject: X570 Taichi Razer Edition
Date Posted: 12 May 2022 at 10:10pm
I've got a new build, and I've been unable to get it to boot at all. I'm using a 5800X, and when I turn on the PSU the board lights up, but I am unable to power on the system.

Case power button does not work, board power button does not work or light up. No Dr. Debug.

I thought I might be able to reflash the bios, so I pulled the board out and removed everything. Followed instructions for bios flashback, and it will not start. Removed the CMOS battery and left it to sit overnight.

Tried again, still refuses to start bios flashback.

Is there something I could be missing, or am I looking at a bad board?

I'm using the same model board in another build with a 5600X and it bored first time no problem.



Replies:
Posted By: Xaltar
Date Posted: 12 May 2022 at 11:50pm
Make sure you have the correct 8pin power cable connected to the board. It should
be a 4+4 cable not a 6+2. I have seen this cause a board not to respond to the
power switch.

-------------


Posted By: Obsidian
Date Posted: 13 May 2022 at 4:03am
Wiring is all correct. That still wouldn't explain why bios flashback won't start.


Posted By: Xaltar
Date Posted: 13 May 2022 at 8:03pm
The fact that the board won't power on (the RGB lighting up doesn't mean the board
is powering up) is what concerns me. It means there is either something power related
not connected correctly, which is why I mentioned the 8pin, or there is a dead
short somewhere.

The board will behave like this when there is an issue with power, it's a safety
feature to prevent component damage in the event of a short/incorrect voltage.

Have you tried connecting up the board outside of the case and powering up like that?
A standoff in the wrong place or loose screw between the board or the case is
often behind this kind of behavior. You can also check to see if any of the
component legs are bent over and touching adjacent legs/contacts.

Let us know how it goes.

-------------


Posted By: Obsidian
Date Posted: 14 May 2022 at 9:21am
I already had everything uninstalled from the board, so I did a full inspection of the PCB for damage. Removed all shrouds, heat sinks, etc.

Inspected under magnification and could find no damage or cause for a short. As a last step I cleaned the PCB with an alcohol wash and soft brush in case there was something conductive I couldn't see causing the short.

That worked. Not sure what I washed off, but it's working now.


Posted By: Xaltar
Date Posted: 14 May 2022 at 2:40pm
Awesome, glad to hear it

-------------



Print Page | Close Window

Forum Software by Web Wiz Forums® version 12.04 - http://www.webwizforums.com
Copyright ©2001-2021 Web Wiz Ltd. - https://www.webwiz.net