Print Page | Close Window

X570 System hangs when trying to access BIOS

Printed From: ASRock.com
Category: Technical Support
Forum Name: AMD Motherboards
Forum Description: Question about ASRock AMD motherboards
URL: http://forum.asrock.com/forum_posts.asp?TID=23570
Printed Date: 09 Aug 2022 at 3:58am
Software Version: Web Wiz Forums 12.04 - http://www.webwizforums.com


Topic: X570 System hangs when trying to access BIOS
Posted By: Tubmonkey74
Subject: X570 System hangs when trying to access BIOS
Date Posted: 23 May 2022 at 11:10pm
Hi all,

I recently upgraded my BIOS to 3.50, all seemed to go fine and I was able to access BIOS yesterday with no issues. As of this morning, my system boots perfectly into Windows but I can't get into BIOS at all. If I use Restart to UEFI or hit Del/F2 it's the same result, the system hangs at the ASRock splash screen telling me to Hit F2/Del to enter Setup and goes no further. If I boot without trying to enter setup, Windows starts with no issues.

I tried the Clear CMOS button on the back, switched off the PSU and removed the power cable then held the button in for 15 seconds. Is that the right thing to do? In any case, can anyone offer any advice on what I could do in order to access BIOS please? I'm trying to lower my temps, and want to get to PBO and Curve Optimizer to undervolt in BIOS...

Thanks in advance!



Replies:
Posted By: Tubmonkey74
Date Posted: 23 May 2022 at 11:12pm
I forgot to mention, the board is an ASRock Phantom Gaming X570-ITX/TB3.


Posted By: Xaltar
Date Posted: 25 May 2022 at 7:16pm
Try disconnecting everything from your board that you don't need to enter BIOS.
Just leave CPU, RAM and GPU connected, make sure you disconnect drives, additional
USB devices (other than keyboard and mouse) and see if it still hangs.
I have seen some peripherals cause this issue, even flash drives/USB wireless adapters.

-------------



Print Page | Close Window

Forum Software by Web Wiz Forums® version 12.04 - http://www.webwizforums.com
Copyright ©2001-2021 Web Wiz Ltd. - https://www.webwiz.net