Print Page | Close Window

EP2C612 WS no display

Printed From: ASRock.com
Category: Technical Support
Forum Name: Intel Motherboards
Forum Description: Question about ASRock Intel Motherboards
URL: http://forum.asrock.com/forum_posts.asp?TID=24652
Printed Date: 18 Aug 2022 at 4:06am
Software Version: Web Wiz Forums 12.04 - http://www.webwizforums.com


Topic: EP2C612 WS no display
Posted By: torin3
Subject: EP2C612 WS no display
Date Posted: 20 Jun 2022 at 7:07am
I just got a used EP2C612 WS motherboard (might be refurbished, the board looked pristine).

I got 2 E5-2650 V4 Xeons to use with it, along with 4x8GB ECC RDIMMs

I'm trying to boot with it and I have no display at all. The fans power on, the BMC LED works. I can connect to the IPMI webclient and it shows no errors. When I try remote management, the display window is black.

With or without USB stick or SATA SSD doesn't appear to make a difference.

I've tried with the onboard VGA port plugged in and with a PCI-E video card.

The troubleshooting LED number block never lights up, so no codes there.

Any suggestions, or anything else to try?

Thanks!



Replies:
Posted By: torin3
Date Posted: 22 Jun 2022 at 10:30am
Is there a guide to remote BIOS updates for this board?


Posted By: Xaltar
Date Posted: 22 Jun 2022 at 6:00pm
Contact ASRock Tech Support, sadly I have no experience with ASRock Rack products
so wouldn't even know where to begin troubleshooting. All my experience with WS
and server boards is with Supermicro and a few Intel boards (way back when).

https://event.asrockrack.com/tsd.asp

They should be able to help you, even if the board is a refurb. ASRock support is
usually very good with supporting older products, I even got a new BIOS chip for
an old ASRock socket 775 board a couple of years back.

Good luck

-------------


Posted By: torin3
Date Posted: 26 Jun 2022 at 2:38am
Weird, I thought I'd set this up for email notification. I'll have to check my spam.

I did try the remote server management software from ASRock, and while it found the machine, it said it wasn't online.   I can update the firmware through Megarac SP, but it already is at the latest version.

I have opened a support ticket. Thank you!



Print Page | Close Window

Forum Software by Web Wiz Forums® version 12.04 - http://www.webwizforums.com
Copyright ©2001-2021 Web Wiz Ltd. - https://www.webwiz.net