Print Page | Close Window

deactivate CSM to enable SAM - risks£

Printed From: ASRock.com
Category: Technical Support
Forum Name: AMD Motherboards
Forum Description: Question about ASRock AMD motherboards
URL: http://forum.asrock.com/forum_posts.asp?TID=24791
Printed Date: 26 Sep 2022 at 4:39pm
Software Version: Web Wiz Forums 12.04 - http://www.webwizforums.com


Topic: deactivate CSM to enable SAM - risks£
Posted By: bumjams
Subject: deactivate CSM to enable SAM - risks£
Date Posted: 01 Aug 2022 at 9:36pm
Hey everyone

I have read a few threads on CSM and even tried to read through some articles, but to be honest I am still overwhelmed with the topic.

I know that I have to deactivate CSM and activate 4G decoding for SAM in the UEFI. So far so good.
But what I don't quite understand is whether there are certain risks if I deactivate CSM now. For example, my computer will no longer boot (and this cannot be solved by simply changing the BIOS settings).

According to Diskpart, my boot SSD is in GPT mode.
my BIOS is set to UEFI instead of Legacy
CSM is currently activated, Windows boots and runs with this setting since Gotthelfs times without any problems.

So what can happen if I deactivate CSM? Am I overlooking anything that can ensure that I really "get out of there" unscathed?




Replies:
Posted By: threadzipper1957
Date Posted: 05 Aug 2022 at 9:58pm
Compatibility Support Module in shiort CSM, does exactly what it says.
When enabled, it allows Legacy hardware to be used, usually under CSM, you would have an option Launch Storgae Oprom Policy, when set to legacy it supports lagesy mode, when set to UEFI only it is set to UEFI mode.
When you have a USB stick with Windows on it, and press f11 for the bootmenu, you USB stick is usually twice in the list.
One time as USB device (your OS wil be installed in Legacy mode (MBR))
One time as UEFI device (your OS, will be instaleld in UEFI Mode (GPT)
Your BIOS does not have an option to set it to UEFI, actuall BIOS is not the correct term, it is UEFI, and is the succesor of the old fashioned BIOS.
Setting CSM to Enabled should not cause a problem, but when your OS is installed in UEFI (GPT) mode, it has no extra value, so why even bother.
It is better to set CSM to disabled, this way your OS is always installed in UEFI mode.
When you want to upgrade from Windows 10 to 11, your old OS, MUST be installed in UEFI mode, otherwise you must first convert MBR to GPT, before you can upgrade.
Microsoft has a tool mbr2gpt for that, but it doesn't always work.
My advice, keep CSM disabled, because it is also needed to enable above 4G Decoding which in its term, enabled Clever Access Memory

-------------
Kind Regards


Posted By: bumjams
Date Posted: 06 Aug 2022 at 12:00am
not sure you got my message correctly.

my Windows install is already set to GPT and BIOS is set to UEFI.
But CSM is currently still activated and I am worried that, once I deactive it, I will not be able to boot again.


Posted By: kerberos_20
Date Posted: 22 Aug 2022 at 9:41am
if its already installed in GPT and CSM has storage set to uefi, then you dont have to worry about your boot drive not booting your windows on it
when you disable CSM one thing will happen, GPU firmware will switch to UEFI, there are some cases where GPU UEFI drivers(its called GOP) fails to load, but dont worry, asrock is one of good bios makers and in this case it has proper CSM fallback, which means if GOP fails, CSM will auto enable itself
you can check that when disabling CSM, rebooting and entering bios that CSM will be either enabled or disabled

in case it gets enabled (due to CSM fallback), you will need to update your GPU firmware

-------------
http://valid.x86.fr/diq4l4" rel="nofollow">
http://www.userbenchmark.com/UserRun/47132492" rel="nofollow - userbenchmark



Print Page | Close Window

Forum Software by Web Wiz Forums® version 12.04 - http://www.webwizforums.com
Copyright ©2001-2021 Web Wiz Ltd. - https://www.webwiz.net