Print Page | Close Window

J5040-ITX SATA Controller driver install Problem

Printed From: ASRock.com
Category: Technical Support
Forum Name: Intel Motherboards
Forum Description: Question about ASRock Intel Motherboards
URL: http://forum.asrock.com/forum_posts.asp?TID=24805
Printed Date: 26 Sep 2022 at 6:28pm
Software Version: Web Wiz Forums 12.04 - http://www.webwizforums.com


Topic: J5040-ITX SATA Controller driver install Problem
Posted By: Toshy
Subject: J5040-ITX SATA Controller driver install Problem
Date Posted: 06 Aug 2022 at 12:17pm
Sorry.

My english ist bad and ich only understand some basic word (+google translate).

1. My Computer shows very often in event log

"\Device\RaidPort0"
ID 129

sometime ""\Device\RaidPort1"

i test lot of things, nothing helps.

know i want to install osther

"ide ata/atapi controller" / sata controller.

windows install the "standart sata controller" from date 2006 (in german not same same as in english. i not know english name)

on one internetsite (not asrock not asmedia) i found "J5040-ITX.SATA_AHCI-RAID_ASMedia_v3.3.5.0.zip"
bit in the devide manager i found

2 controller with same name. ich think, ohne ist from intelchip the controller, one from asmedia chip.

but ist dont know which controller i must use with J5040-ITX.SATA_AHCI-RAID_ASMedia_v3.3.5.0.zip-drivers.

how can I find out which entry belongs to as media.


2. Farther:
where can i find a current driver for the "intel sata controller"?

3.does the motherboard have a raid function?
I haven't found any information on this. I ask because of the event error message.

i hope you can unterstand me.

thanks and greetings




Replies:
Posted By: RLGL
Date Posted: 06 Aug 2022 at 9:48pm
See:
https://www.asrock.com/mb/Intel/J5040-ITX/#Specification" rel="nofollow - https://www.asrock.com/mb/Intel/J5040-ITX/#Specification

-------------
Asrock Z370 Gaming K6,Intel i7 8700K,
Asrock x570 Taichi



Posted By: Toshy
Date Posted: 07 Aug 2022 at 1:42am
Thanks to you.

I know this site. But not help me complete.
There i not found "raid" funktion, but the internal sata controllers trigger a warning with the term "raid" in event log.
as an advanced layman with a relatively large amount of experience, i still don't understand it.

on most sites i found chip name ASM1061, but on some ASM1061R (with R).
eventualy there exists 2 versions of the chi? "R" with raid?
https://www.asmedia.com.tw/product/9daYQ10sxaHh0tXD/8A0yQ9Fsx6HuAsY2" rel="nofollow - https://www.asmedia.com.tw/product/9daYQ10sxaHh0tXD/8A0yQ9Fsx6HuAsY2
https://www.asmedia.com.tw/product/77BYq58SX3HyepH7/58dYQ8bxZ4UR9wG5/ASM1061" rel="nofollow - https://www.asmedia.com.tw/product/77BYq58SX3HyepH7/58dYQ8bxZ4UR9wG5/ASM1061

my "idea" is (sorry, my english not found ideal words) that eventuealy the chip on mainboard ist the "R"-Version or ist not R-Version and windows use wrong driver.

And so i want in next step
replace the drivers of the controllers. I hope someone here knows how I can distinguish between them in the device manager.

at asrock or asmedia i not found different (on asmedia no) driver for both chips.

sometime 3-5 times in minute the warning comes in eventlog file. and i not know why and if this is very bad.

if i deactivate both, no warnings.

oh, i forgot. my windows is installed over nvme on mini express card. works fine. eventualy a combination problem?




Print Page | Close Window

Forum Software by Web Wiz Forums® version 12.04 - http://www.webwizforums.com
Copyright ©2001-2021 Web Wiz Ltd. - https://www.webwiz.net