Print Page | Close Window

Taichi X470 Wlan problem

Printed From:
Category: Technical Support
Forum Name: AMD Motherboards
Forum Description: Question about ASRock AMD motherboards
Printed Date: 24 Feb 2024 at 10:05am
Software Version: Web Wiz Forums 12.04 -

Topic: Taichi X470 Wlan problem
Posted By: vzzoli
Subject: Taichi X470 Wlan problem
Date Posted: 17 Aug 2022 at 8:49pm
Hi all,

I have a Wifi/Bluetooth problem with Taichi x470 board on Windows 10/11.
The bluetooth works well, but if I enable integrated WLAN in the BIOS the Windows freeze different phases of the boot sequence. Most cases it reaches the login screen, but i cannot login because the whole system and the cursor starts stuttering then freeze. After a while the computer reboots itself. I never get BSOD, in the system event viewer shows only "unexpected shutdown".
What i tried, but none of those helped:
- swap stock wifi card to Intel AX160
- disable Bluetooth
- reinstall/upgrade wifi/bt driver 19.5 -> 22.5 (on 22.5 windows freeze with disabled wifi too), couldn't find older driver
- removed/swapped between slots all expansion cards, RAM, disabled all onboard integrated devices

At this point it seems to be an average hardware fault, BUT THE SYSTEM WORKS FLAWLESS WITH WIFI ON ANY LINUX DISTRIBUTION. Unfortunately I must use Windows.
I looked for Realtek chipset wifi card, but the swap too complicated for me, because I have to disassembly the whole system.


Posted By: threadzipper1957
Date Posted: 18 Aug 2022 at 5:20pm
When the system works flawless under Linux, the only conclusion is, that is is a Windows problem, or that there is other hardware Active.
The Linux solution to drivers differs between Windows and Linux.
But what other hardawre is used, CPU, BIOS, PCIE cards, USB hardware, M.2 SATA.
Maybe igt's best to use the support form" rel="nofollow -
I see currently it is under maintenance, but when you select a European country, and language English, your request is mostly forwarded to ASRock Euope support
When using gmail, always check your spam folder for replies.
Now to this issue, I know this can also happen when you have an older release of Windows, and try to upgrade.
It works best when doing a clean install of Windows 11 (then you have the latest version, in GPT mode, with CSM set to disabled.
Alwayus connect only the drive you want to install Windows on, and wipe all partitions, before installing Windows
After the Windows installation, Always first install the AMD chipset driver." rel="nofollow -

Kind Regards

Posted By: vzzoli
Date Posted: 18 Aug 2022 at 5:40pm
Thank you for your answer, I'm going to fill the form!

Since then I tried few, but didn't worked:
- I tried more windows 10 and 11 clean install
- More BIOS version from 3.20 to 4,70
- After clean install disabled wifi, installed latest AMD-all-in driver and after that version what Asrock suggested to the installed BIOS version

I will install Windows with disabled CSM, this is the only thing what I haven't tried.

Print Page | Close Window

Forum Software by Web Wiz Forums® version 12.04 -
Copyright ©2001-2021 Web Wiz Ltd. -