Print Page | Close Window

Why R2.0 for WRX80 Creator£ Some 1.0 issue£

Printed From: ASRock.com
Category: Technical Support
Forum Name: AMD Motherboards
Forum Description: Question about ASRock AMD motherboards
URL: https://forum.asrock.com/forum_posts.asp?TID=24963
Printed Date: 15 Apr 2024 at 11:34am
Software Version: Web Wiz Forums 12.04 - http://www.webwizforums.com


Topic: Why R2.0 for WRX80 Creator£ Some 1.0 issue£
Posted By: adrjork
Subject: Why R2.0 for WRX80 Creator£ Some 1.0 issue£
Date Posted: 04 Oct 2022 at 1:06am
Hi everyone, newbie here.
Yesterday I saw a new WRX80 Creator R2.0
It surprised me: a new revised version after less than 2 months since the 1st version!
What does it mean? Perhaps some issue on the 1st version? Perhaps R2.0 solves some compatibility issue with upcoming hardware (like 4090 cards or AMD 5000 series CPUs)?
I wonder this because I had planned to buy the 1st WRX80 Creator + 4090 + AMD 5965WX. Should I wait for R2.0?
Thanks in advance.



Replies:
Posted By: Thriplerex
Date Posted: 05 Oct 2022 at 2:48pm
Owner of a rev 1.0 WRX80 Creator here. Apparently, this is more of an aesthetic change to the labeling of the rear I/O shield, and that it comes with an up-to-date BIOS version. I bought mine in early July and it came with bios version 3.0, which doesn't have support for Resizeable BAR - but version 5.0 was released later and has support for that. Examining the specs pages for the two boards, I can't find anything different other than the same specs worded slightly differently but meaning the same thing.

On the other hand, the RGB on my bottom four Trident Zs stopped being recognized by any RGB software after the update - the sticks still work fine, aside from the RGB. Something to watch out for and perhaps they fixed it with this revision.


Posted By: Thriplerex
Date Posted: 05 Oct 2022 at 2:53pm
Upon further inspection this wasn't the only change. The 10G ethernet ports have been changed from Intel X710-AT2 to Aquantia Marvell AQC113CS.


Posted By: adrjork
Date Posted: 05 Oct 2022 at 5:43pm
Hi Thriplerex, many thanks for your replies.
Well, it's a bit weird that they changed the 10G chip after a couple of months... Intel wasn't reliable for some reason?
Anyway, you confirm that the "first" WRX80 Creator works great, included 10G ports and Resizeable BAR as well, right? And beside RGB, fans works fine?


Posted By: Thriplerex
Date Posted: 09 Oct 2022 at 4:18am
The BIOS is more server-like and not that of a traditional desktop motherboard in that it's the "old-style" blue and gray layout, so there's no manual tuning for fan curves outside of the preset silent/normal/performance/full speed settings unless you use ASRock's desktop A-Tuning app (which I haven't bothered to test given how buggy it seems to be for others.)

That being said, my REBAR and 10G ports work just fine.


Posted By: adrjork
Date Posted: 09 Oct 2022 at 4:48am
Just received some infos from AsRock. It seems that the reason of an R2.0 version was the difficulty of having Intel's LAN chip in stock. So they opted for Aquantia. The point is that they consider the old "1.0" mb with Intel as a EOL product. What does it mean? Well, I suppose that they won't release any further BIOS update anymore, and this could possibly cause future compatibility issues IMO. (Perhaps yet with the upcoming 4090 GPU. Who knows?)


Posted By: rmartins
Date Posted: 28 Dec 2022 at 7:36am
Hi,
I have R2.0 (BIOS 6.09) and I do not see support for "Suspend to RAM". Without this I am unable to enter sleep mode in the OS.
Does R1.0 have this issue?
I already contacted support but I am still waiting for their reply.



Print Page | Close Window

Forum Software by Web Wiz Forums® version 12.04 - http://www.webwizforums.com
Copyright ©2001-2021 Web Wiz Ltd. - https://www.webwiz.net