Print Page | Close Window

X670E Steel Legend - Memory Issue

Printed From: ASRock.com
Category: Technical Support
Forum Name: AMD Motherboards
Forum Description: Question about ASRock AMD motherboards
URL: https://forum.asrock.com/forum_posts.asp?TID=25084
Printed Date: 21 Jul 2024 at 9:20pm
Software Version: Web Wiz Forums 12.04 - http://www.webwizforums.com


Topic: X670E Steel Legend - Memory Issue
Posted By: x670hell
Subject: X670E Steel Legend - Memory Issue
Date Posted: 14 Nov 2022 at 10:44am
I'm finishing up a build and having an issue getting the machine to POST if both memory sticks CORSAIR Vengeance are installed in A2/B2. CPU LED stays on and the DRAM LED flashes on the motherboard. I've waited MANY minutes hoping that it was memory initialization. Powers on, boots, and works fine if either of the sticks are in B2 slot. I also tried to boot with the memory in A1/B1 but that did not work either.

Motherboard: X670E Steel Legend (v1.11 BIOS)
CPU: AMD Ryzen 7 7700x
Memory: CORSAIR Vengeance (CMK32GX5M2B5600C36)
Video: ZOTAC GAMING GEFORCE RTX 3070 TI TRINITY OC
Storage: Samsung 980 Pro 2 TB M.2-2280 PCIe 4.0
CPU Cooler: ARCTIC Liquid Freezer II 280 A-RGB
Power Supply: Corsair RM850

Currently running in just a 16GB config. Since each stick works on its own, I'm skeptical of a memory hardware issue. Are there any known issues that would exhibit this behavior? Any recommendations on things to check to resolve?



Replies:
Posted By: UnrelentingPest
Date Posted: 18 Nov 2022 at 5:11am
Hey, maybe try loosening the CPU cooler a bit? I've heard that can cause problems


Posted By: cx5
Date Posted: 18 Nov 2022 at 9:54am
Originally posted by x670hell x670hell wrote:

Powers on, boots, and works fine if either of the sticks are in B2 slot.


Since you are able to boot using 1 stick only, then enter bios and manually change the timings, if you have experience with AM4+DDR4 then you know what I mean hence I won't write more because it's a hxll lot to write.

and if you read through this forums' history you will find many near similar cases, i.e. upgrade to Zen3 with new bios but can't boot with 2 sticks, etc etc etc get tips and tricks here and there, as well as other forums.....

I won't say because XMP is not EXPO hence not compatible, because there's been report of EXPO also not booting at all and needed new bios to solve, etc etc etc..... SO, don't worry about XMP, just go the traditional method of manually finding the secret-timing that your system need.

Good luck. Hope to hear good news from you later.


-------------
x370taichi@3.50gen4
AX750 Optane900P SN770
3800x PosdonZro4 BarrowPWM-17w>420x140x28
XFX SWFT319 6900XT
MSI RX560 LP to get Fluid Motion BlueskyFRC 75hz


Posted By: ptejelo
Date Posted: 22 Feb 2023 at 5:58am
I had same issue with 2x16 Gb kingstom fury KF560C36BBEA-16, my Asrock x670e steel legend only load with one of then in b2 slot, if i connect one in B2 and other in A2, cpu led was red, and memory led was blinking in red, motherboard did not load.

I solved it starting the computer with one ram module, updating my bios from 1.11 to 1.18 AS04, load windows 11, install asrock chipset, integrated graphics and audiodrivers then shutting down and putting the two modules in b2 and a2 slots

Motherboard load correctly at last

-------------
P-IT



Print Page | Close Window

Forum Software by Web Wiz Forums® version 12.04 - http://www.webwizforums.com
Copyright ©2001-2021 Web Wiz Ltd. - https://www.webwiz.net