Print Page | Close Window

X570 Taichi Issues

Printed From:
Category: Media&User's Review
Forum Name: AMD Motherboards
Forum Description: ASRock AMD Motherboards
Printed Date: 14 Jun 2024 at 1:59pm
Software Version: Web Wiz Forums 12.04 -

Topic: X570 Taichi Issues
Posted By: Qvoliszz
Subject: X570 Taichi Issues
Date Posted: 15 Nov 2022 at 5:06am
Hi All!

I have built my PC 2019.SEP.
- ASROCK X570 Taichi
- G.Skill Trident Z NEO 4x8 GB (3600MHz XMP profile is used)
- AMD Ryzen R7 3800X
- Corsair RX 750W Gold PSU
- APC surge protection power adapter

Actually I regret moving from BIOS version 2.7 or 2.8 as it was rock solid.
Since then I have multiple blue screens connected either to memory or CPU related issues. Currently I am on 4.8 and only some rare blue screens appear. Most of the times I get some memory related errors, status access violations.

But what saddens me, that after 25 months of usage my "first M.2 slot died" or something similar. My ADATA NVME disappeared. I tore the PC apart and begin to troubleshoot.
1. Swapped the ADATA and the Crucial NVME-s, the crucial was not visible, but the ADATA reappeared
2. Moved the ADATA from Slot 1 to Slot 3 and it works

If I have some time I will try the following:
Thanks to my couple I can borrow an 5600X. I will swap the CPU-s as the M.2 Slot 1 is directly connected to the CPU, if that is the case, maybe my CPU is acting up.

Posted By: Xaltar
Date Posted: 15 Nov 2022 at 3:22pm
Let us know what happens with the 5600x. Reading through your post I was going to
suggest you try another CPU given the symptoms but it seems you are already on the
same page

Good luck.


Posted By: Qvoliszz
Date Posted: 15 Jan 2023 at 1:10am
Hello All!

So the testing stage have started.
I have swapped the CPUs with my couple.

1. Observation: My 3800X in a different motherboard is able to boot from the 1st M.2 slot. So in my system the issue, where the M.2 drive is not visible in the 1st slot, is not a CPU issue.

2. Observation: My system works with the 5600X so far without noticable issues.

To test:
1. Move back the NVME to slot 1 on my Taichi x570 to see if it works there.
2. Try to reproduce errors. Like memory status access violations and other instability errors. That needs time.
3. Paralelly use the 3800X in my couple's system to see if any unusual happens.

Conclusions so far:
1. The 3800X has no issues, works perfectly.
2. The possible issue can be the Asrock motherboard (or BIOS/UEFI), but further testing is required to confirm.

If no issues are found maybe reseating the CPU will solve the issue.

Posted By: Qvoliszz
Date Posted: 01 Feb 2023 at 2:30am
Hi All!

So a follow up on my debugging tour...

1. I have tried to use M.2 slot 1 with both of my NVMe drives. They worked. So I had to switch to my old arrangament. My system drive in the 1st and the gaming drive in the 2nd slot. Possible cause is the precision sensitive mounting and the huge heatsink issue. What did I find as the possible rootcause:
- After inserting my 2280 format NVMe into the 1st slot it is easily displaced by the huge M.2 heatsink of the motherboard. The heatsink and the 1st M.2 drive shares the same screw. So I had a small ~15 cm long plastic crowbar, which I used after properly installing my dive to hold it down while I mount the heatsink. This way I could keep it in one place.
- I was really unlucky, because I have tried to install my NVMe at least 6 times before. So I have came to the wrong conclusion, that the 1st M.2 is slot is not functional. What I could not understand back then, why was the termal pad near the screwhole thinned out and torn a bit. Now I know why. It stuk to the NVMe drive as I installed the heatsink, moved/pulled it (disconnecting the drive) and also thinning the pad.
My conclusion: The huge heatsink looks good, but actually it hinders the users when it comes to ease-of-use. ASRock sacreficed functionality and usability for aesthetics. The 1st M.2 port should have it's own standoff with a dedicated screw and a new separate mounting stand for the heatsink.
Also, I am not 100% sure but I know bad cooler mounting can lead to CPU issues on AM4. What I have seen my cooler have been tightened hard and a bit uneven. It had a significantly greater tightness on the side closer the the GPU. I only have 2 thumbcrews so I don't have any stepping or reference, when I am tightening. But I have noticed it during dissassembly. When installing the 5600x and the 3800x I watched out to achieve the most uniform mounting pressure as possible with less final torque on the nuts.

2. I could reproduce the errors instantly. I could not watch a single 13 min long video on the net, because I got my old errors back (Status access violation) and some others. Application crashes and general instability issues.

3. After a two week period me and my couple had only 1 crashes each. Nothing else. I believe, that was acceptable as we did a swap of processors, but we left our system settings unchanged. We set the memory and basic setting back in our UEFIs.

So what I could gather:
- My motherboard works just fine, at least no functional defect can be found
- My CPU works well in a different motherboard (MSI B550M PRO WIFI)
- My couples CPU works well in my system

So based on my this I could rule out my 1. conclusion, that my CPU has a defect. The only thing was my motherboard left. But the picture wasn't black and white. It functioned well with the 5600x. So what is the difference? Naturally the UEFI. I am running 4.80 (my favourite was 2.70). So I have checked the install notes for the UEFI and it states, that you can simply update the BIOS, when using a 5000X CPU, but you must flash, when using a 3000X CPU. I have flashed 4.80 as the manual describes and I have started testing.

My previous problems have vanished. No chrome crashes, no rnadom instability, no memory related issues, no status access violation.....
I had a crash in a week. I wish to note, that I have a 6900XT with 22.11.2, which is known to introduce black screen, that may escalate into a crash sometimes. This issue is clearly different and it can be identified instantly. My PC now can play videos in a browser, can be left alone, it will go into sleep if allowed.

Root Cause:
- improperly installed UEFI, that caused widespread system errors

Posted By: Qvoliszz
Date Posted: 17 Apr 2023 at 4:34am
Hello @tipidet,

I have not just did, the troubleshooting, but finished it already back then.
1. Swapping the CPU was already done and described in my previus post. No issues happened during a 2 week period with both PCs (CPU swapped).
2. I have already updated the UEFI- described it and identified it as the main reason: corrupted UEFI
3. Also described after reverting from CPU swap, that only 1 issue happened, but during this time, the 22.11.2 AMD GPU driver could have been the issue. Daily I use memory sensitive programs, that do cover my 32 GB of system memory, without any issues.
4. NVMe heat generation is out of question, this is a gaming rig. I do not edit movies or move files on a daily basis so I can rule this out. Considering that I have a Cooler Master NR600 NO-ODD case with a 360 AIO that has 2 sets of fans (push+pull) + 3 exhaust fans, I consider my case a well ventillated high pressure setup. (during testing prime95+furmark 4K CPU 3800X was 73C and the GPU 6900XT was 78C, all settings on stock)

Since then I have upgraded to an 5800X3D and to UEFI ver 5.0, with the 23.4.1 GPU driver the system is rock solid.

Print Page | Close Window

Forum Software by Web Wiz Forums® version 12.04 -
Copyright ©2001-2021 Web Wiz Ltd. -