Print Page | Close Window

Deskmini X300 won't sleep or hibernate

Printed From: ASRock.com
Category: Technical Support
Forum Name: HTPC&Gaming Barebone&Others
Forum Description: Question about HTPC&Gaming Barebone&Others
URL: https://forum.asrock.com/forum_posts.asp?TID=25140
Printed Date: 31 May 2024 at 6:08am
Software Version: Web Wiz Forums 12.04 - http://www.webwizforums.com


Topic: Deskmini X300 won't sleep or hibernate
Posted By: Gordon D
Subject: Deskmini X300 won't sleep or hibernate
Date Posted: 28 Nov 2022 at 5:05am
I've had a Deskmini X300 for a while running W10 with a Ryzen 3200G in it. With the cheap price they are I recently upgraded to a 5600G.

When it had the 3200G in it would sometime sleep, but often wake up without any obvious reason. I never tried hibernate. I understand there is some issue with the X300 chipset with "S3" mode, whatever that is.

It seeming to be running really well with the 5600G in it, then just in the last couple of days W10 has completely removed any ability to select sleep mode. Its not listed in the power menu. All attempts to restore it fail. And hibernate doesn't work. It'll go into hibernate, but pops back out after 10 seconds. So the computer drones on endlessly, it has to be continually turned off when not needed, and turned back on when it is.

Its really really annoying when between them Asrock, AMD and Microsoft can't get even the basic stuff like this working right. And worse, when it was working, you stuff it upo so it doesn't work.



Replies:
Posted By: yun1534
Date Posted: 10 Jan 2023 at 3:04pm
Yes, this is the big design flaw with X300. But if you are running Linux, there is a patch available that works with BIOS 1.70 - basically restoring the S3 suspend in the ACPI table.

https://github.com/lorenz/asrock-x300-s3-fix" rel="nofollow - https://github.com/lorenz/asrock-x300-s3-fix




Print Page | Close Window

Forum Software by Web Wiz Forums® version 12.04 - http://www.webwizforums.com
Copyright ©2001-2021 Web Wiz Ltd. - https://www.webwiz.net