Print Page | Close Window

H170M Pro4S RAID and OS issues

Printed From: ASRock.com
Category: Technical Support
Forum Name: Intel Motherboards
Forum Description: Question about ASRock Intel Motherboards
URL: http://forum.asrock.com/forum_posts.asp?TID=2530
Printed Date: 03 Mar 2024 at 8:57pm
Software Version: Web Wiz Forums 12.04 - http://www.webwizforums.com


Topic: H170M Pro4S RAID and OS issues
Posted By: Twerthi
Subject: H170M Pro4S RAID and OS issues
Date Posted: 27 Apr 2016 at 7:49am
Greetings!  I've just built a new machine to function as my home server using the ASRock H170M Pro4S motherboard.  I flashed the BIOS to the latest version using the Flash from Internet feature and it worked perfectly.  After I flashed, I enabled the onboard RAID controller so that I could mirror my OS disks.  For the onboard SATA/RAID controller, I have two SSDs for the OS in a RAID 1 configuration.  The other four SATA ports are connected to laptop hard drives in an enclosure installed in one of the 5.25 inch slots in the case. In addition I have a Blu-Ray drive and another SSD being controlled by an ASMedia PCIEx1 SATA controller.
 
I am currently experiencing two issues:
1.  When booting or rebooting, the will sometimes not find all disks and report RAID has failed.  I have entered BIOS when the boot process says RAID has failed, BIOS sees all disks.  I've yet to discern a pattern of boots and reboots that lead this condition, it appears to be random.
 
2.  As stated before, I flashed the BIOS via the Internet so I'm certain the NIC is functional.  However, I am unable to install NIC drivers (I'm running Server Essentials 2012 R2).  I've tried all LAN drivers on the provided disc, downloading the drivers from Intel directly, and downloading the most recent drivers for my mobo from ASRock to no avail.
 
For issue 1, I have replaced SATA cables to ensure that wasn't the issue.  Bearing in mind what is installed in the computer, is the 430 Watt Power Supply providing sufficient power?



Replies:
Posted By: Twerthi
Date Posted: 28 Apr 2016 at 11:13pm
I've used several power supply calculators, all say that the 430 watt supply should be more than enough. I emailed technical support, but have not heard a peep


Posted By: parsec
Date Posted: 29 Apr 2016 at 1:52am
Two things to discuss here, your OS usage and potential hardware issue, so please read all of this long post. You might get lucky after all.

First, I must say that Server Essentials 2012 R2 is not an officially supported OS for your board.

While you may think you can use virtually any OS with a mother board, there may be technical reasons why that is not true. The driver support provided by Server Essentials 2012 R2 may not include the H170 chipset used in your board.

The other hardware on your board, like the Intel 219V chip (a chip that supports the networking capabilities of the H170 chipset, and together provide the network interface) may also not be supported by Server Essentials 2012 R2. A "Server" type OS is designed for professional, enterprise type hardware, and may not be completely compatible with home PC hardware.

The drivers provided on the disk for your board, and on its download page, are sorted by the versions of Windows the drivers support. Unfortunately we don't find an entry for Server Essentials 2012 R2, for the general reasons I have included above. Whether or not the drivers provided for your board can work with Server Essentials 2012 R2, is questionable and not a given. Some might work, which seems to be the case, but others are an unknown.

Examples of this can be found among ASRock's server and workstation mother boards:

http://www.asrockrack.com/general/products.asp#Server" rel="nofollow - http://www.asrockrack.com/general/products.asp#Server

You might be able to find some drivers that will work better with Server Essentials 2012 R2 and your board. Look among the socket 1151 boards. You'll find that your H170 chipset is not used by these boards, but at least the drivers are compatible with your OS. You may find some drivers that are common between say Windows 10 and Server Essentials 2012 R2.

Let's see if we can fix your RAID problem without considering the potential driver mismatch. Did you install the IRST 14.6 RAID driver from your board's disk or download page? I highly doubt the Intel RSTe RAID driver used by their server chipsets will work with your board's chipset. The question is if the IRST RAID driver will work fine with Server Essentials 2012 R2.

When you say some of the disks are not detected and the RAID volume(s) fail, is that all of your disks? That is, the OS and your HDDs in the enclosure? Or just some of the drives?

Drive enclosures can cause problems with drive recognition, depending on the enclosure design. If the enclosure is not strictly pass-thru, it can interfere with RAID software. I've seen drive enclosures, hot swap bays used with non-RAID drives cause recognition problems.

What drive enclosure are you using?

Regarding the power supply, are you using a video card, or the integrated graphics?


-------------
http://valid.x86.fr/48rujh" rel="nofollow">


Posted By: Twerthi
Date Posted: 29 Apr 2016 at 4:09am
You are absolutely correct, in the past I've had success in using the closest desktop driver to the server OS core.
I will preface this with I'm not a hardware expert by any means; that being said, the disks are presented as missing at POST (where you can hit CTRL-I to enter setup).  Does the IRST question still apply?
 
I'm using the integrated video, no additional card.
 
Here is the enclosure: http://www.amazon.com/StarTech-com-Drive-Removable-Mobile-Backplane/dp/B003F5NSA6?ie=UTF8&psc=1&redirect=true&ref_=oh_aui_detailpage_o07_s00" rel="nofollow - http://www.amazon.com/StarTech-com-Drive-Removable-Mobile-Backplane/dp/B003F5NSA6?ie=UTF8&psc=1&redirect=true&ref_=oh_aui_detailpage_o07_s00  (The first picture isn't the product, don't know why it's on there)  Newegg link http://www.newegg.com/Product/ProductList.aspx?Submit=ENE&DEPA=0&Order=BESTMATCH&Description=SATSASBAY425&N=-1&isNodeId=1" rel="nofollow - http://www.newegg.com/Product/ProductList.aspx?Submit=ENE&DEPA=0&Order=BESTMATCH&Description=SATSASBAY425&N=-1&isNodeId=1


Posted By: Twerthi
Date Posted: 06 May 2016 at 2:54am
I ended up swapping out the board with a SuperMicro board.  Using the same drives and cables, all drives are recognized and RAID never gets out of Normal status.  I'm sending the ASRock board back to Newegg.


Posted By: parsec
Date Posted: 06 May 2016 at 1:08pm
Originally posted by Twerthi Twerthi wrote:

I ended up swapping out the board with a SuperMicro board.  Using the same drives and cables, all drives are recognized and RAID never gets out of Normal status.  I'm sending the ASRock board back to Newegg.


I would need to check the specs of the SuperMicro board you are using to comment about it.

The drive enclosure does not seem to be of the type that would cause any problems with RAID.


-------------
http://valid.x86.fr/48rujh" rel="nofollow">



Print Page | Close Window

Forum Software by Web Wiz Forums® version 12.04 - http://www.webwizforums.com
Copyright ©2001-2021 Web Wiz Ltd. - https://www.webwiz.net