Print Page | Close Window

ASRock Fatality B450 Gaming-ITX - Not POSTing

Printed From: ASRock.com
Category: Technical Support
Forum Name: AMD Motherboards
Forum Description: Question about ASRock AMD motherboards
URL: https://forum.asrock.com/forum_posts.asp?TID=25336
Printed Date: 21 May 2024 at 4:07pm
Software Version: Web Wiz Forums 12.04 - http://www.webwizforums.com


Topic: ASRock Fatality B450 Gaming-ITX - Not POSTing
Posted By: mrw423
Subject: ASRock Fatality B450 Gaming-ITX - Not POSTing
Date Posted: 10 Jan 2023 at 10:30am
I just received this motherboard in the mail and I'm trying to set it up. However, I am not getting a post, nor a splash screen or anything. I've tried several monitors and they just sit at no signal.

I have a Ryzen 5 5600G and I read I may need to flash/update the BIOS in order for it to recognize it. I read a few other posts that said the machine did not need a CPU in order to get to the bios. Thinking that was my issue, I have unplugged everything and when I try to remove the CPU...it will not budge. I have installed/swapped CPUs 2-3 dozen times in my life (this is the first AMD board but I can't imagine there is something that different to this) and this thing is stuck and I am worried that I will break something if I yank or pry it out. The arrow is point in the bottom left, like the manual shows and it offered no more resistance than normal when I pulled the lever down to initially lock it in.

It is a bit late and as frustrated as I am, I know this is when hardware-breaking mistakes are made, so I am trying to do the smart thing and ask for help.

Thank you



Replies:
Posted By: eccential
Date Posted: 10 Jan 2023 at 7:53pm
You, "just received the motherboard?"

I own THREE of these boards, but I bought them all before 2020 (one in 2018 and two in 2019). I liked them so much, I tried to buy another one in 2022, but couldn't find one in stock from a reputable dealer at a reasonable price. Heck, I ordered a "NEW" "only one left" from (Sold & Shipped by) Amazon, and got an obviously used item, so I returned it immediately.

I see 5000G-series support was added in BIOS 4.20 (2020/11/19). Honestly, I don't think AsRock made any of these boards that late.

Is the board getting power and all that? is the power LED lighting up? Fans spinning up?

I don't know where you got that info, but I highly doubt this board's BIOS can be updated without a working CPU, so if the current BIOS does not support the CPU, you'll have to borrow an old supported CPU to do the flashing, or send it in to have it upgraded.

Lastly, I've never had a trouble with ZIF (zero-insertion-force) sockets in my life! Once the lever is pulled back up, NOTHING should be holding onto the CPU pins and the CPU should just slide out like nothing is holding it, since nothing should be. Same thing the other way around when inserting. Nothing should be touching the CPU pins when the lever is in UP position.

So I've no idea what went wrong here. I have doubts that the board is new, but I'm not an AsRock employee, so I wouldn't know for sure when they stopped making them.


Posted By: mrw423
Date Posted: 10 Jan 2023 at 9:43pm
I got it on Amazon and it looked new when I opened the box it.

Fans spin up, LED on the front of the case turns on.

I have no idea why the CPU seems to be stuck in place either. That is how every other CPU I've handled has behaved. There's no chassis keeping it in place. There's no adhesive on the bottom of the CPU (why would there be), so I am clueless.

But thank you for the reply.



Posted By: eccential
Date Posted: 10 Jan 2023 at 10:13pm
First, look for a sticker on top of the BIOS chip to see what BIOS version it was shipped with. At least you can tell if the current BIOS will/will not support 5600G.

Second, I'd tap on the lever to see if I can free the CPU, in case the mechanism is just stuck against some friction or something.

Lastly, as an anecdote, I bought a "new" B550 PG-ITX/AX from Amazon (again Sold & Shipped by Amazon), only to find out later that it was a return. I noticed some of the I2C pins not working properly (board sensor not readable), and when I pulled the CPU, I noticed a bit of thermal compound around the socket, and some went into the holes. I was pissed off, but it was past the return period, so I flooded the whole thing with CRC Electronic Cleaner to get it working again. It's been working fine, but still left me with bad taste.

Needless to say, I'm never buying another motherboard from Amazon. I prefer vendors that have STRICT return policies.


Posted By: mrw423
Date Posted: 11 Jan 2023 at 7:06am
So, I figured out that I need to keep pulling the lever back until you hear the *click* and then the CPU is free. I did that and it popped out, all is well.

As for the motherboard, I see a P4.80 sticker, so that should be well past the 4.2 that added the Ryzen 5500.

(And I did try to boot it without a CPU and it did not even boot. So that information was wrong anyway)

And looking into this, I didn't get it from Amazon, it was from grooves.land which had people vouching for it here and there. I opened a case with them today and they said, oh it must have been damaged from shipping, I need to open a case with USPS.

Upon checking the box, it was fine but I noticed there was no sticker or seal over it, so yeah, definitely not new.

I guess I'll have to find another motherboard that can do what this one can with all of the bells and whistles for my HTPC.


Posted By: eccential
Date Posted: 11 Jan 2023 at 9:56am
Sounds like it is actually a recent production, if the BIOS sticker says P4.80.

Umm, you originally said Ryzen 5600G, but the last post, you wrote 5500.
5500 has no iGPU, so you have to use a discrete GPU. Are you... maybe trying to hook up monitor to the motherboard's output with R5-5500 installed?


Posted By: mrw423
Date Posted: 11 Jan 2023 at 9:59am
It's the 5600G, sorry.



Print Page | Close Window

Forum Software by Web Wiz Forums® version 12.04 - http://www.webwizforums.com
Copyright ©2001-2021 Web Wiz Ltd. - https://www.webwiz.net