Print Page | Close Window

b450 steel legend in bootloop. No beeps, no post.

Printed From:
Category: Technical Support
Forum Name: AMD Motherboards
Forum Description: Question about ASRock AMD motherboards
Printed Date: 06 Jun 2023 at 2:33pm
Software Version: Web Wiz Forums 12.04 -

Topic: b450 steel legend in bootloop. No beeps, no post.
Posted By: stiefenswiegel
Subject: b450 steel legend in bootloop. No beeps, no post.
Date Posted: 28 Jan 2023 at 10:58pm
I have bought the b450 steel legend in combination with the AMD Ryzen 5 5600G.
Including two memory sticks of 8GB each i had the build working.
To prepare the system for windows 11 i only had to enable the secure boot.
After some reading i tried the option 'enable EUFI boot' and i was playing around with 'fast boot'.
Now, after saving the settings i rebooted the system and thats when nothing worked anymore.
The fans on my MB, and green leds do work, but nothing anymore.
After trying to enter the BIOS i figured i'd do a reset, since i expected the system to go to the state i initially received.
After reading, i did the following to reset the BIOS:
1. Remove any cables form the computer (power, HDMI, etc)
2. Connect the jumper switch (part 19 on the design overview)
3. Hold the power button for 30 seconds
4. Remove the CMOS battery
5. Wait for 5 minutes (tried a couple of times, wating 10 minutes and 12 hours)
6. Inserted battery
7. Removed jumper connection
8. Restarted system
Now after that, the system doesnt do anything, except for fans that run and lights that shine.
There is no display on screen, not over MB not over GFX.
Using a GFX card, or have none installed, no difference.
I have two 8GB RAM cards, tried in any combination over the slots, nothing
Used only one card, tried all slots, nothing. Not even with the other memory card.
I tried the debug speaker, but no sound there. After i did a faulty installation of the RAM, the 3 beeps as expected worked. There was no other signal after correctly installing the RAM.
I am out of options.
One thing i now feel bad about, is that jumping the system (resetting the bios), affected the BIOS version, so the CPU is not supported anymore? I know this is a very far stretch, but i have no clue for any other options.

How can i get out of this boot issue? Especially when everything worked fine before i tried playing with EUFI en fastboot?

Thank you so much for your help!

Posted By: eccential
Date Posted: 28 Jan 2023 at 11:12pm
First, it worked at first, so that's a good sign.

By any chance, you didn't leave the jumper on the CMOS clear, right? The connection is to be shorted for a short time only to clear it, rather than leaving it connected. Keeping it shorted might also drain the battery, but I'm not 100% sure about that.

And again, just to make sure, the memory sticks are in A2 and B2 (#4 in the motherboard layout drawing in the manual), right?

Clearing the CMOS setting can't erase the BIOS itself.

Note, initial boot after CMOS clear will take a bit longer than usual.

Posted By: stiefenswiegel
Date Posted: 28 Jan 2023 at 11:19pm
Thank you for the fast reply!
So, when booting i do not have the jumpers short, however, i left them short during the rest period when the battery was removed. Instructions made me believe that i had to do that (could be wrong?)
The memory cards, both one, and the two together, have been positioned in every possible configuration, but very sure, position A2 and B2
So the initial boot after i do such reset, does not seem to take longer then 30 seconds, before everything fails, shuts down, and tries again. I have left that cycle go on for 30 times, but it felt just so wrong to 'ignore it'.

So i figured that the bios would not be sweeped after jumping it, but could it go to a lower version, if the factory already did a bios upgrade before buying it? Or is this just a stupid assumption that makes no sense?

Posted By: stiefenswiegel
Date Posted: 28 Jan 2023 at 11:55pm
In some article i found this method to test if the powersupply is working properly.
I tried this:" rel="nofollow -
With succes (as described). No changes in the behaviour though

Print Page | Close Window

Forum Software by Web Wiz Forums® version 12.04 -
Copyright ©2001-2021 Web Wiz Ltd. -