Print Page | Close Window

RX 7900 XTX AQUA not detected in Polychrome Sync

Printed From:
Category: Technical Support
Forum Name: AMD and Intel Graphics Card
Forum Description: Question about ASRock AMD and Intel graphics card
Printed Date: 09 Dec 2023 at 10:14pm
Software Version: Web Wiz Forums 12.04 -

Topic: RX 7900 XTX AQUA not detected in Polychrome Sync
Posted By: TheLordOfEvil
Subject: RX 7900 XTX AQUA not detected in Polychrome Sync
Date Posted: 11 Mar 2023 at 5:08pm

My RX 7900 XTX AQUA card does not get detected in Polychrome Sync. I have tried both the download from the graphics card download page (ASRock Polychrome SYNC ver:1.0.29) as well as the one from my X670e Taichi motherboard's page (ASRock Polychrome RGB ver:2.0.131), but neither of these are detecting the GPU. I tried the beta version (2.0.136) on that page as well but no luck. Both my motherboard and G.SKILL RAM can be controlled in all versions without any issues.

Please let me know if anyone has any ideas.


Posted By: TheLordOfEvil
Date Posted: 11 Mar 2023 at 5:48pm
After a litte bit more searching I was able to find the FAQs here with links to download the firmware updates." rel="nofollow -

Trying to actually install these firmwares doesn't seem to work though. Kicks back with an error at "Jump to LDROM" unfortunately.

              ASRock ISP Tool v1.0.12.2 Built: 20221208
        (C)2019 ASRock Incorporation. All Rights Reserved

[ Configuration ]
Program Interface ...... ADL_I2C_OEM
Adapter ................ AMD Radeon RX 7900 XTX

[ Chip - Current]
FW Version ............. 0x00000000
FW Release ............. 0x00000000
FW Feature ............. 0x00000000
HW Version ............. 0x00000000
Device ID .............. 0x00000000
Flash Mode ............. Unknown (0x00)
Config0 : Config1 ...... 0x0040401E : 0x0019FC98

Jump to LDROM                     [ Fail ]
Process Time                      [ 0.032 seconds ]
       Update Fail

Posted By: ASRock_TSD
Date Posted: 14 Mar 2023 at 5:29pm
Dear TheLordOfEvil,

Thank you so much for your time posting a query to the ASRock forum.

Our team is already checking the symptom described.

Once we find the cause of this problem we will let you know.
Thank you so much for your patience.

With thanks,

Posted By: ASRock_TSD
Date Posted: 14 Mar 2023 at 6:24pm
Dear TheLordOfEvil,

We have checked with our technical support team.
Currently, they are not able to reproduce the symptom.
After flashing the RGB firmware, have you tried shutting down the computer to make sure that the RGB firmware is completely reset?

Please check if the graphics card's RGB can be controlled by the Polychrome RGB after resume from the shutdown.   

With thanks,

Posted By: KingOfTheBritons
Date Posted: 15 Apr 2023 at 4:23pm
When I first tried the firmware update, it didn't work either. But I discovered that Polychrome was running in the background, so I ended it in task manager, then restarted the computer. After that, I was able to flash the firmware with the posted instructions and it now works.

Posted By: ZaidMarc
Date Posted: 25 Jul 2023 at 7:03pm
As an ASRock user, you might find valuable assistance and potential solutions in the ASRock community forums or support pages. There, you can interact with other users who might have faced similar issues and get advice from ASRock representatives or experienced users." rel="nofollow -

Print Page | Close Window

Forum Software by Web Wiz Forums® version 12.04 -
Copyright ©2001-2021 Web Wiz Ltd. -