Print Page | Close Window

X670E Pro RS - Not booting

Printed From:
Category: Technical Support
Forum Name: AMD Motherboards
Forum Description: Question about ASRock AMD motherboards
Printed Date: 01 Jun 2023 at 5:59pm
Software Version: Web Wiz Forums 12.04 -

Topic: X670E Pro RS - Not booting
Posted By: Escalatorman
Subject: X670E Pro RS - Not booting
Date Posted: 20 Mar 2023 at 12:07am
AMD Ryzen 5 7600X - 4.7GHz/5.3GHz AM5

Asrock X670E PRO RS
BIOS version: 1.03

Kingston 32GB (2x16GB) DDR5 6000MHz CL32 FURY Renegade RGB

2xKingston NV2 M.2 NVMe Gen 4 2TB
1xKingston NV2 M.2 NVMe Gen 4 1TB


CORSAIR HXi Series HX1000i
Noctua NH-D15 chromax

All parts are brand new except GPU which was bought pre owned. assembled this weekend 18-19/3 2023.

I can access BIOS after boot, I see all my hardware listed.


I put bootable USB into port of motherboard.
<Press F11> To boot, find my drive, press enter.

Screen goes black (signla still but nothing posting) and:
Post Status Checker gives solid red on:
BOOT [x]
VGA [x]
CPU []
BOOT & VGA (and DRAM,CPU) are all off when in bios, but BOOT & VGA always turn solid red after boot.

I have tried booting repetead times, created new bootable devices.
My main bootable was a Ventoy with windos 10 ISO on, tried with fresh bootable linux Arch.
Get same result after pressing F11 I can choose my bootable USB, press ENTER and "nothing happens" nothing posts or loads.

Downloaded the latest BIOS update (1.18) and put it on a seperate USB, booted up and went to update the BIOS. This results in the UPDATE freezing at 0% no progress after 30min. Power off, boot up and try again, same result, freezing at 0% I can not manouver mouse or keyboard. Power off.

I have reseated everyting, even CPU, after this and a couple of boots I actually had a successfull boot with the USB running ventoy and win 10 ISO.
Get to update part where it will need to reboot in order to continue.
After this i CHECK BIOS so the windows bootable disc now is the first bootabel M2 disc.

Get no boot and:
Post Status Checker gives solid red on:
BOOT [x]
VGA [x]
CPU []

I now tried just running single memory and just one m2 but I'm again stuck at the same step, It wont boot past BIOS.

I forgot to mention that in between one of many tries to boot i did create a new USB for Flashback of BIOS using 1.18, rename the .ROM file to CREATIVE.ROM.
I place it in Flashback supported USB port and hold the button in for several seconds, I see that USB flashed and then the lgith for BIOS Update which should be flashing gives of solid light, indicating it not updating or accepting file.

I have tried updating to 1.07 but get the same freeze at 0% and no progress over 30min.

I am at a loss I dont really know whats going on and it feels like I have tried everyting.

Is it faulty or what can be the issue here?

Thanks to anyone who can shine some insight to my issue.

Posted By: threadzipper1957
Date Posted: 24 Mar 2023 at 5:52pm
Disconenct all hardware, and check the pins in the CPU socket, then sue another FAT formatted USB stick, preferably a small one of 4GB, because bigger ones sometimes pose a problem
Then use only 1 memory module in Slot A2, and connect a monitor to the onboard graphics, and of course both cables from the PSU.
Important is, to use Wired USB keyboard and mosue, because the Wirelss USB dongles, can distort all USB communication
Or use the tech support form, and check Your spam folder for replies." rel="nofollow -

Kind Regards

Posted By: Escalatorman
Date Posted: 27 Mar 2023 at 11:58pm
Thanks for your response, have tried this and no success. Can't se that any pins should be the issue eiter from my visual inspection and with photos taken with macro lens.

To update I have an RMA with the vendor from which i bought the board and it has been shipped today as an RMA, waiting for update on my RMA now.

Posted By: Escalatorman
Date Posted: 07 Apr 2023 at 12:37am
To update, will get a moterboard replacement from the RMA/store which I bought it from.

Also if a mod sees this thread please move it to the correct subforum.

Posted By: Xaltar
Date Posted: 07 Apr 2023 at 4:16pm
Topic moved. Good luck with the RMA, let us know how it goes and if you need further


Posted By: buchner1987
Date Posted: 12 Apr 2023 at 7:56pm
i think the issue is the BIOS Version 1.18.
Try the Flahback. I had similar the same problem with the X670E PG Lightning Board.
After Flashback to an older BIOS Version everything is fine.

Posted By: DemonAk
Date Posted: 23 Apr 2023 at 2:56am
next time try to boot with integrated videocard, just plug you hdmi/display port cable to motherboad, reset bios and power on system
for update bios flashdrive need format to FAT32, try using this older utils HP USB Disk Storage Format Tool 2.2.3

Posted By: Escalatorman
Date Posted: 16 May 2023 at 1:12am
Thanks for replying.

If I don't remember wrong I tried all the available BIOS from the official download page up to 1.18, I even store them all just in case.

I am going to be updating this weekend to the latest BIOS which has been released since I got my new board on RMA which also came with release BIOS version.

Posted By: Escalatorman
Date Posted: 16 May 2023 at 1:17am
"i think the issue is the BIOS Version 1.18.
Try the Flahback. I had similar the same problem with the X670E PG Lightning Board.
After Flashback to an older BIOS Version everything is fine."

The Board came with release date BIOS, so it was never a case of rolling back. Was a case of trying to get it to install BIOS or read anything, since I couldn't install windows since it would not read properly from the USB drive.

Posted By: Escalatorman
Date Posted: 16 May 2023 at 1:45am

Thanks to all who has responded. I thought it be best to post an update in case anyone else would end up in this thread.

I did send the board back to the vendor on RMA.
Vendor has approved of RMA. Got new board within a week and a half or so.

I got the rig with the same components listed in my first post up and running. Feels great going from a 10 year old potato to this. Think I have had the rig running since end of April.

Issues this series of Motherboard seems to have is updating BIOS.
I got the new board on the RMA, first thing I wanted to do was update BIOS to latest which at the date still was 1.18.
This motherboard takes forever to install//update it's BIOS and seems to freeze when the BIOS update is starting. It will be on 0% for a very long time and will honestly seem to have frozen since keyboard and mouse will be unresponsive. So this board behaves the same way as the old board that has been sent back on RMA.
How long did it take to update BIOS, well I can't say exactly but long enough to seriously feel very frustrated, frustrated enough to take a nap. Woke up and checked to see if anything had happened and yes it was updated and I could proceed with installing win10 and was up and running short after.

I'm not joking when I say that the board (X670E Pro RS) takes extremely long time to update. Which in it self does not seem normal.

I would think more users/consumers would have had the same issue or at least the same time consuming experience.
Though I don't know how common it is for people to actually update BIOS.

This weekend I'm going to be updating to the latest version (1.24.AS02) will be posting an update regarding that just for the sake of it being the 2nd time it will have had an update run on it.

The only Issue I at the moment which I can't really understand is:
When the computer goes into sleep/hibernate mode, after and unknown amount of time it seems to have done a reboot. Leave computer running and go to bed, wake up to booted computer, also numlock is not on after this happens.

I have turned of all the powersaving options, set it to performance and not eco mode in power setting. Only allow screens to turn of after 20 min.

Still same issue, it seems to reboot after an amount of time and numlock is not on which it is set to in BIOS to be and I don't turn of numlock since I use it frequently.


Print Page | Close Window

Forum Software by Web Wiz Forums® version 12.04 -
Copyright ©2001-2021 Web Wiz Ltd. -