Print Page | Close Window

As Rock z370 Pro 4 not turning on

Printed From: ASRock.com
Category: Media&User's Review
Forum Name: Intel Motherboards
Forum Description: ASRock Intel Motherboards
URL: https://forum.asrock.com/forum_posts.asp?TID=25687
Printed Date: 15 Jun 2024 at 4:48pm
Software Version: Web Wiz Forums 12.04 - http://www.webwizforums.com


Topic: As Rock z370 Pro 4 not turning on
Posted By: Timaya
Subject: As Rock z370 Pro 4 not turning on
Date Posted: 01 Apr 2023 at 3:34pm
Desktop motherboard won't turn on after power outage/ if wall socket is switched off for a while. Power supply is working well.



Replies:
Posted By: Xaltar
Date Posted: 01 Apr 2023 at 4:47pm
Could be the CMOS battery has died. Does the system eventually power on? If so,
what do you have to do to make it turn on?

-------------


Posted By: Timaya
Date Posted: 01 Apr 2023 at 6:11pm
If I reset the cmos (removing the battery & power cable then long pressing power button for about 30 seconds). After resetting it it then powers on and performs great.


Posted By: Xaltar
Date Posted: 01 Apr 2023 at 6:16pm
Try a new CMOS battery, it sounds like the one in there is dying/dead. It's just
a standard CR2032 so should be easy to find

-------------


Posted By: Timaya
Date Posted: 01 Apr 2023 at 11:29pm
It came with a new cmos battery, I even bought a new one but the problem persists??


Posted By: Xaltar
Date Posted: 02 Apr 2023 at 12:42am
If the system loses power unexpectedly it can cause BIOS value corruption. That
will also cause it to not POST when power is restored. Given your location I would
imagine you often have the power go out while the system is in use. If you exprerience
power loss on a regular basis another option would be to simply remove the CMOS
battery. You will lose your BIOS values on power loss but at least you won't need
to open up the PC every time.

As soon as you enter windows an go online your date and time should update automatically.
Not an ideal solution but I can't think of anything better. You could try opening
a support ticket with ASRock, they may be able to give you a better solution:

http://event.asrock.com/tsd.asp

Good luck

-------------


Posted By: Timaya
Date Posted: 29 Jul 2023 at 4:26pm
Problem solved after changing the power supply.



Print Page | Close Window

Forum Software by Web Wiz Forums® version 12.04 - http://www.webwizforums.com
Copyright ©2001-2021 Web Wiz Ltd. - https://www.webwiz.net