Print Page | Close Window

Setting up 10 on BBox 3150

Printed From:
Category: Technical Support
Forum Name: HTPC&Gaming Barebone&Others
Forum Description: Question about HTPC&Gaming Barebone&Others
Printed Date: 20 May 2024 at 4:01am
Software Version: Web Wiz Forums 12.04 -

Topic: Setting up 10 on BBox 3150
Posted By: mikiem
Subject: Setting up 10 on BBox 3150
Date Posted: 07 May 2016 at 6:04am
While I haven't finished -- new RAM ordered -- came across a little info that might be useful to some other folks.

I pulled the Wi-Fi card because I was going to run wired Ethernet, & Bluetooth performance per user reports seems iffy. It shouldn't make a difference, with 10 defaulting to the faster wired connection, but win10 1511 bricked my tablet for 3 months [until an Insider update fixed the bug] because of its similar Wi-Fi/Bluetooth chip, regardless the USB wired Ethernet dongle... I didn't want to take a chance on having to pull the card later when we have to upgrade 10 builds this summer.

I had a couple of new sticks of memory I was hoping to use, but they weren't a matched set & only 1 was used by the Beebox -- I ordered Crucial CT2KIT51264BF160B. I couldn't find anything that said it worked with the Beebox, couldn't find the numbers referenced in the ASRock AVL, & even tried finding the Team Group sticks shown in review teardowns of the non-barebox Beebox. I later found that that crucial 2 stick set I listed has been working in my son's Beebox for ~5 months. I saw in other threads that some folks had RAM problems -- maybe that will help?

The Beebox I received fired up & went into the bios fine, but I had a USB stick attached with the new bios ROM. After the bios flash I tried swapping the RAM around etc., but without the USB stick plugged in, the Beebox just sat there -- I don't know if it was going through a hardware scan routine or just wouldn't post, but after shutting it down, sticking a USB stick back in it, & turning it on, the post routine started immediately & I was able to get back into the bios. A freshly formatted GPT SSD was plugged in & seen by the bios. Maybe that'll help folks who aren't getting any display?

I created the win10 setup USB stick using the media creation tool. I set the Beebox bios to UEFI only, & I set the USB stick's UEFI loader as 1st boot [there was also a regular (legacy) USB stick choice]. I had done a dry run with the USB stick in a VM [Virtual Machine] on my regular PC -- it set up 4 partitions on the hard drive, boot, Microsoft Reserved, Recovery, & Windows, in that order. My tablet has the Recovery partition after the Windows partition. For the Beebox it was Windows, Recovery, Microsoft, then boot, **maybe** because I had 10 install to the already formatted partition vs. a completely empty disk?

With wired Ethernet 10 installed fine -- I didn't have to supply any drivers. [Once I get the new RAM & verify I have dual channel memory, I'll worry about updating drivers, but until then I won't know if I have to exchange it.] By default 10 didn't power off the Beebox when it shut down. I had to unplug -> plug in the power to get it to cold boot so I could get into the bios. Once in the bios I found that the Only choice for boot order was the win10 bootloader.

Back in 10 I changed the power off behavior, & couldn't get into the bios again [partly my fault for turning on fast boot?]. I then installed & ran the ASRock RestartToUEFI utility. That got me straight into the bios, where it performed maybe 5 minutes worth of updates, & afterward I had all the choices again in the boot order setting [*maybe* because it set the bios to default settings?].

Regardless I can now get into the bios if I want/need to, or in the case of booting to a USB stick, bring up the boot order menu by hitting the F11 hotkey.

Note: I ran 10's setup to get the partitions on the SSD, plus I was being lazy. If you want the actual setup to go faster [the Beebox CPU is not a barnburner, taking quite a bit longer to install 10 than my test with a VM], or you don't want all 4 partitions etc., research using the Apply-Image command with 10's DISM -- it's something you can do with a SSD using a dock etc. connected to your PC before you attach it to the Beebox. Or with the drive attached to the Beebox, boot to a win10 WinPE USB stick, with the install.wim or install.esd file on another USB drive. If/when you've got little disk space [e.g. the storage some Beeboxes come with], you can also use the Compact switch to save a couple few GB of space.

Posted By: mikiem
Date Posted: 11 May 2016 at 6:47am
The new RAM worked fine, & while in the bios to verify dual channel memory, turned off virtualization [no need, & *maybe* faster & more secure], set graphics RAM to the max. Firing up Windows 10, installed the ASRock supplied drivers where newer, installing & running the APPShop, which found 2 driver updates that weren't listed on the ASRock site. Then finished setting 10 up, removing apps & features irrelevant to working as a HTPC etc.

Adding WMC -- I use a HDHomerun Prime, which is a cablecard box with 3 tuners, which lets me watch & record [DVR] cable channels including premiums like HBO, but the cablecard part is set up for WMC.

Next step was installing the drivers for the HDHomerun Prime. Then I copied the C:\Windows\System32\Drivers\etc\hosts file to a temp folder, adding the following 2 lines, saving it, & copying it back, overwriting the original -- this is for the WMC guide -- then restarting Windows.

After the restart, needed to make sure that Windows 10 was set to a Private network, stop the running HDHomerun Prime service, and install WMC. Over at the MDL forum [ forums[.]mydigitallife[.]info ], in a thread titled: "Patch WMC to run on Windows 10 final & possible alternatives" they've put together a package that adds the win8 WMC. After downloading you extract the 7z file's contents -- you then need to rename the WMC64 folder to WMC, & move it to root -> C:\WMC . It doesn't hurt to read the 2 text files in that folder.

Next, I ran Installer.cmd as admin, but once it was finished, before I fired up WMC, I ran the digitalcableadvisorsetup_x64.msi & PlayReadyPC_x64.msi -- both downloaded from microsoft[.]com . Now, after restarting the HDHomerun Prime service I had stopped. it was time to start WMC, setup the HDHomerun Prime tuners etc. Note that once everything is set up, it takes a few minutes for the guide to update with the current info. Note: It may be possible to change the order of steps I've listed, or omit some, but those steps in that order were required for me to get WMC running properly in tests using this PC. Note that you *may* have to stop the Intel Security Assist Helper service temporarily while setting up WMC.

OK, WMC's running, but I'm not quite there yet... my guess is that between 10 & Intel's driver set, everything's set up for AVC/H.264 video, because HD cable programming [mpg2] doesn't look quite right in WMC. I added PowerDVD 15 Ultra, to get it's DS filters registered, then ran install_video.bat & install_splitter.bat in the folder for LAV Filters 64 bit portable version [ videohelp[.]com ]. Next I ran CodecTweakTool_606.exe [also at videohelp], setting Windows default 64 bit DS filters to LAV Filters rather than the Microsoft default, then set the LAV Filters to use Intel's Quick Sync hardware acceleration.

Now things look like they're supposed to in WMC. My final step was setting a WD Passport USB 3.0 drive as the place where I wanted WMC recordings to be stored. Why go to an external drive?... My main reason is so that I can pick up the Passport, plug it into one of our desktop PCs [or maybe my tablet], & watch recorded video there if anyone wants. A 2ndary reason is I'm using an old SSD in the Beebox that I had been using as an external drive, & it doesn't have loads of space. A 3rd reason is that I don't like to record to the system or Windows drive -- sometimes there's too much going on with the system drive and there's a problem writing the video file smoothly, without interruption of any sort.

Print Page | Close Window

Forum Software by Web Wiz Forums® version 12.04 -
Copyright ©2001-2021 Web Wiz Ltd. -